Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

print.tab_modal.enabled = false stopped working today 2/12/22 with latest FF update

more options

Cannot get out of the terrible firefox print dialog. Literally no one wants this print dialog, it is a waste of time, and does not support all the printer options. I do not want to have to click "print using the system dialog" every time. Please restore the print.tab_modal.enabled = false functionality immediately. Or better yet get rid of your stupid print dialog.

thanks

Cannot get out of the terrible firefox print dialog. Literally no one wants this print dialog, it is a waste of time, and does not support all the printer options. I do not want to have to click "print using the system dialog" every time. Please restore the print.tab_modal.enabled = false functionality immediately. Or better yet get rid of your stupid print dialog. thanks

All Replies (8)

more options

I don't even see it in 97.0 see screenshot

Helpful?

more options

Even after adding the option in 97.0, it doesn't appear to work after restarting the browser. The same issue in Nightly.

Athraithe ag jonzn4SUSE ar

Helpful?

more options

t_collins said

Literally no one wants this print dialog, it is a waste of time, and does not support all the printer options. I do not want to have to click "print using the system dialog" every time. Please restore the print.tab_modal.enabled = false functionality immediately.

What options do you need to set that are not available in the settings panel next to the preview? We've had since Firefox 84 to add features to this design and maybe no one filed a bug for the ones you need.

There is a bug on file to add a user preference to bypass the preview. I don't think it will arrive before Firefox 98 next month (and it's not guaranteed to be in Firefox 98).

Helpful?

more options

> What options do you need to set that are not available in the settings panel next to the preview?

That is a very easy question to answer. The Page Range "Selection" is missing.

Another annoyance of this is that the printers are listed in the wrong order. Correct order is defined as the order in the System Print Dialog.

For now I will continue to click "Print using the system dialog ... ", but Holy Hanna why should I have to do that every time I print? And yes, I do use the Print Range "Selection" almost every time I print. Thanks.

Athraithe ag alex250 ar

Helpful?

more options

alex250 said

> What options do you need to set that are not available in the settings panel next to the preview? That is a very easy question to answer. The Page Range "Selection" is missing.

It's in an odd place. I'll come back to that in a second.

The fastest way to set the Print Range to "Selection" is, after you select text in the document, right-click and choose Print Selection:

The preview should show the selection only, and if you have the More settings section expanded, you'll see Selection selected under the Format section (and this is where you would set it manually if you didn't use Print Selection):

Weirdly, the system dialog shows All in selected in that case, and whatever you do in that section of the dialog is ignored. Hopefully they can fix that so it matches up.

In case you were wondering why they didn't put it in the Pages section with the other print range options (All and Custom) --

-- I don't know. Would have been more obvious for Windows uses to find it there.

Helpful?

more options

alex250 said

Another annoyance of this is that the printers are listed in the wrong order. Correct order is defined as the order in the System Print Dialog.

They seems to be Z-A instead of A-Z. I hope they flip it because there's no reason for it to be in that order.

Helpful?

more options

There are now several posts about this on the new feedback site connect.mozilla.org (which has replaced mozilla.crowdicity.com). You can access this new site using your Firefox login. I would encourage anyone who has an opinion about this to visit the new site and leave some feedback.

Helpful?

more options

=== For those who do not want any preview ===

It's finally here. Firefox 101 has a preference to bypass the combined print preview/setup overlay and go straight to the system dialog. Here's how you can try it out:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste print.prefer_system_dialog and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true

If you need to restore the default display, you can call up the preference and double-click again to toggle the value back to false. There also will be a reset arrow at the right end of the row when the preference has a non-default value.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.