Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why Firefox Taking Alot Of Resource?

  • 9 bhfreagra
  • 2 leis an bhfadhb seo
  • 113 views
  • Freagra is déanaí ó jerriy

more options

Why Firefox Taking Resource Without Even Opening Multiple Tabs ,At Startup Browser Starts With 60-70 CPU Usage And Even If Close The Browser It Still Takes 60-75 Until I Close It From Windows Task Manager,Attached Some Screenshots Check It You.

Attached screenshots

Réiteach roghnaithe

Such bug is quite common across Windows users. Consider other OSs. Otherwise you need to investigate it more closely.

Read this answer in context 👍 0

All Replies (9)

more options

Have you tried any of the solutions listed here: Firefox uses too much memory or CPU resources - How to fix.

Athraithe ag Zppix ar

Helpful?

more options

Yes but nothing happened

Helpful?

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button Fx57Menu, click Help Fx57Help and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Fx68SafeMode

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Helpful?

more options

Zppix said

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:
  • Click the menu button Fx57Menu, click Help Fx57Help and select Restart with Add-ons Disabled.
If Firefox is not running, you can start Firefox in Safe Mode as follows:
  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Fx68SafeMode
If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. When you figure out what's causing your issues, please let us know. It might help others with the same problem.


opened in safe mode its the same i think there's 2 firefox running one with the normal usage and other with the 60% cpu usage so i think it's not like problem with some settings and also did clean installation but its the same again and one thing i forgot to say that the same problem was happening with the other browser yesterday so i uninstalled that browser now it's happening with firefox.

Helpful?

more options

Réiteach Roghnaithe

Such bug is quite common across Windows users. Consider other OSs. Otherwise you need to investigate it more closely.

Helpful?

more options

gorbunovalexey1996 (VITOWVN GLDNSWG) said

Such bug is quite common across Windows users. Consider other OSs. Otherwise you need to investigate it more closely.

Thank You For Your Suggestion But The Problem Got Solved By Doing Some Malware Scans

Helpful?

more options

There is absolutely a new problem with YouTube and Firefox (that has started within a the last week or two).

I have tested it with all the add-ons out but the problem doesn't go away. CPU usage spikes to 99% which is unacceptable. There's nothing remotely normal about this and, no it has nothing to do with nothing other than YouTube playing on the latest version of Firefox. Tweaking either YouTube or Firefox didn't help. Starting safe mode didn't help.

To be specific this happens whenever a video is played AND also that tab is in the foreground. CPU goes down below 50% (i.e. goes back to more or less normal, although still higher than what it used to be) when I move away from that tab and either click an existing other tab or open a new one.

Especially egregious is the videoclip is playing in "mini player" mode that YouTube has as a feature, or when in "player in player" aka pop-up mode. In that case the spike will stick to 100% and freeze sooner or later if you continue.

I have tor-browser (which is structurally an older version of Firefox) this RAM problem never shows up. Everything is as normal as it was two weeks ago on my "normal" Firefox.

Athraithe ag jerriy ar

Helpful?

more options

Tell me what to do — Downgrade?

Athraithe ag jerriy ar

Helpful?

more options

Where is the older version?

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.