Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

All webpages continue scrolling after I've taken my fingers off the touchpad

  • 10 bhfreagra
  • 1 leis an bhfadhb seo
  • 47 views
  • Freagra is déanaí ó AKASH kUMAR

more options

I've just switched to Firefox as Chrome keeps lagging. I'm running Fedora 31 and the latest version of Firefox 76.0.1.

When I use the 2 fingered scrolling and take my fingers off the touchpad, the page keeps scrolling until it slowly slows down and eventually stops or hits the end of the page. It doesn't then stop when I place my fingers back on the touchpad, so it just carries on regardless to another part of the page. It's ludicrous as it just goes past whatever I'm trying to look at! If I keep my fingers on the touchpad it stays put but as soon as I take them off, it's off on it's jollies again.

Is there anyway to disable this? I've unchecked smooth scrolling and autoscrolling. I've never had Firefox behave like this before on any Linux distro.

All Replies (10)

more options

Hi firefox739, glad to see you on Mozilla Support Forum.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  • Click the menu button and select Options (Windows) or Preferences (Mac, Linux).
  • Select the Advanced panel and the General tab.
  • Uncheck Use hardware acceleration when available.
  • Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  • Click the menu button and select Options (Windows) or Preferences (Mac, Linux).
  • Select the General panel.
  • Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
  • Uncheck Use hardware acceleration when available.
  • Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

Helpful?

more options

alex0912 is a scammer. Please do not call the number. Their account has been deactivated.

Helpful?

more options

This problem is occurring on a fresh install and is therefore not a cookies or cache problem, as it happened the when I opened firefox for the first time. I deleted them anyway, but it did nothing. It persists in safe mode.

Helpful?

more options

I had no problem with the link.

Many site issues can be caused by corrupt cookies or cache.

   Clear the Cache and 
   Remove Cookies 

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

   Cookies; Select Privacy. Under History, select 

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

   Cache; Select Advanced > Network. Across from 

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

   Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
   Select the Advanced panel and the General tab.
   Uncheck Use hardware acceleration when available.
   Close Firefox completely and then restart Firefox to see if the problem persists. 

In Firefox 55 and above:

   Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
   Select the General panel.
   Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
   Fx55Performance-disableHWA
   Uncheck Use hardware acceleration when available.
   Close Firefox completely and then restart Firefox to see if the problem persists. 

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

   Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems 
   Upgrade your graphics drivers to use hardware acceleration and WebG

Helpful?

more options

I turned off hardware acceleration after unchecking the use recommended performance settings, and restarted Firefox, this did nothing, the problem persists.

Helpful?

more options

hello....

please follow the given link easly resolve your problem:


[https://superuser.com/questions/52316.../disable-two-finger-swipe-on-firefox]


I hope resolve your problem then reply me back.

Thank you!

Helpful?

more options

Thanks for your reply, but it does not solve the problem.

I followed the link, but it tells you how to stop it changing the webpage to one already visited by stopping left and right scrolling. That does not tell me how to stop my webpage continuing to scroll after I take my fingers off the touchpad. I have no desire whatsoever to stop 2 finger scrolling and am perfectly capable of disabling it in Fedora's settings should I wish to. I require the scrolling as I like scrolling down webpages, it's an important navigation feature.

The problem is the bizarre continuation or commencement of scrolling after I take my fingers off, and that it doesn't stop the scrolling when I put my fingers back on. It's very odd.

Thanks anyway!

Helpful?

more options

Hello ...

It was indeed the wireless mouse. Firefox is not at fault.


thank you...

Helpful?

more options

Thank you Ankit Kumar. I will immediately go out and buy a wireless mouse and be sure to let it know that it's all its fault. Currently though, I do not own one, nor is there one anywhere near here.

Back in reality, I think it's a Fedora issue that Chrome overrides with it's own scrolling behaviours, and Firefox does not. Nautilus has the same scrolling issue as Firefox. Chrome is clearly better suited to Fedora 31, despite its flaws.

Perhaps sticking to Fedora forums in future may be advisable. Now, where's that mouse???

Helpful?

more options

Were you doing anything at the time, pressing keys? Do you have a mouse pad? Go into the computer settings and have the pad disabled when a mouse is detacted.

Type about:support<enter> in the address bar. At the upper right, press the Restart With Add-ons Disabled button.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.