X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Can't add exceptions for cookies from unvisited sites

Postáilte

Hello,

I had the block cookies from unvisited third party sites checked in firefox when it upgraded. I used to be able to add an exception for certain sites. Now, when I type a website in the field at the top of this window and click on Save Changes or press Enter, nothing happens. The site is not saved in the exception list. All the articles I see say I have to visit the site to change permissions for cookies.

So I have to turn off blocking unvisited third party cookies, visit the site, learn what other site it refers to, visit that site, turn off blocking cookies, then return to settings and reenable blocking third party unvisited cookies? If I do all that every time I want to make an exception, will all my previous exceptions be saved?

Thank you.

Hello, I had the block cookies from unvisited third party sites checked in firefox when it upgraded. I used to be able to add an exception for certain sites. Now, when I type a website in the field at the top of this window and click on Save Changes or press Enter, nothing happens. The site is not saved in the exception list. All the articles I see say I have to visit the site to change permissions for cookies. So I have to turn off blocking unvisited third party cookies, visit the site, learn what other site it refers to, visit that site, turn off blocking cookies, then return to settings and reenable blocking third party unvisited cookies? If I do all that every time I want to make an exception, will all my previous exceptions be saved? Thank you.
Luaigh

Tuilleadh mionsonraí faoin chóras

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Tuilleadh Eolais

jscher2000
  • Top 10 Contributor
8516 réiteach 69578 freagra

Hi chamberlainke, could you describe the dialog where are want to create the cookie exception? Normally you would use the "Manage Permissions" button in the "Cookies and Site Data" section of the Options page. That is the one not working for you?

Note that to avoid unpredictable results, I suggest clicking either "Allow" (allows either session or persistent cookies or "Allow for Session" rather than pressing Enter just to make sure the correct permission is added to the list.

Then once it is in the list you can click Save Changes.

I don't think Firefox checks whether you have visited a site you are adding to the list. You should be able to add anything you like.

Of course, that doesn't help with figuring out what site you need to add to the list. This setting (which makes Firefox behave like some versions of Safari) still requires you to know that in order to add an exception.

Hi chamberlainke, could you describe the dialog where are want to create the cookie exception? Normally you would use the "Manage Permissions" button in the "Cookies and Site Data" section of the Options page. That is the one not working for you? Note that to avoid unpredictable results, I suggest clicking either "Allow" (allows either session or persistent cookies or "Allow for Session" rather than pressing Enter just to make sure the correct permission is added to the list. Then once it is in the list you can click Save Changes. I don't think Firefox checks whether you have visited a site you are adding to the list. You should be able to add anything you like. Of course, that doesn't help with figuring out what site you need to add to the list. This setting (which makes Firefox behave like some versions of Safari) still requires you to know that in order to add an exception.
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Thank you for your reply, jscher2000. The buttons at the top are greyed out, and when I try to save changes nothing happens. I thought it might have been a change from the upgrade. When I went searching all the articles I saw had instructions to not block per site.

I will try to reinstall FF, as last time that solved my issue (different issue last year).

If I still have the issue, I will repost here. Thank you.

Thank you for your reply, jscher2000. The buttons at the top are greyed out, and when I try to save changes nothing happens. I thought it might have been a change from the upgrade. When I went searching all the articles I saw had instructions to not block per site. I will try to reinstall FF, as last time that solved my issue (different issue last year). If I still have the issue, I will repost here. Thank you.
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.