X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Netflix videos won't play

Postáilte

For the past week or so I have been unable to play any Netflix videos in Firefox. Netflix works fine in other browsers and all other video streaming sites I've tried in Firefox still work. Initially the problem was that I would just get stuck on the red loading circle, however, after updating Firefox to the latest version (version 53), I now get an error message on Netflix telling me to check I have the latest version of Firefox, with an error code, F7702-1003. A solution posted from about a year ago involving changing the path in profiles.ini did not help, nor did removing pluginreg.dat.

I would be grateful for any assistance.

For the past week or so I have been unable to play any Netflix videos in Firefox. Netflix works fine in other browsers and all other video streaming sites I've tried in Firefox still work. Initially the problem was that I would just get stuck on the red loading circle, however, after updating Firefox to the latest version (version 53), I now get an error message on Netflix telling me to check I have the latest version of Firefox, with an error code, F7702-1003. A solution posted from about a year ago involving changing the path in profiles.ini did not help, nor did removing pluginreg.dat. I would be grateful for any assistance.

Réiteach roghnaithe

  1. Click the menu button New Fx Menu and choose Plugins.
  2. Click More or Options for the Shockwave Flash plugin
  3. Uncheck Enable Adobe Flash protected mode

Netflix should now play in Firefox 53

This solution worked for me.

Answered my own question here: https://support.mozilla.org/en-US/questions/1158044 Sorry for the duplicate as I couldn't post an answer unless I created an account.

It looks like the problem with Adobe Flash protected mode affects 32-bit Firefox based this article: https://support.mozilla.org/en-US/kb/adobe-flash-protected-mode-firefox

Read this answer in context 0

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 25.0 r0

Feidhmchlár

  • Firefox 53.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0
  • URL Tacaíochta: https://support.mozilla.org/1/firefox/53.0/WINNT/en-GB/

Eisínteachtaí

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Classic Theme Restorer 1.6.4 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Multi-process staged rollout 1.14 (e10srollout@mozilla.org)
  • Norton Security Toolbar 2017.9.1.7 ({C1A2A613-35F1-4FCF-B27F-2840527B6556})
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

Grafaic

  • adapterDescription: Intel(R) HD Graphics 520
  • adapterDescription2:
  • adapterDeviceID: 0x1916
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 09831025
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.14393.953
  • driverDate: 11-11-2016
  • driverDate2:
  • driverVersion: 21.20.16.4550
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'skia', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webgl2Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 520 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 520 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Sainroghanna Athraithe

Éagsúil

  • User JS: No
  • Inrochtaineacht: Níl
guigs 1072 réiteach 11697 freagra

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.


If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

In previous cases (Firefox 48 and earlier) It was recommended to reinstall the DRM in Firefox, which ensures the protection of online content. https://help.netflix.com/en/node/40835 The option they recommend to have checked is here: about:preferences#content

Can you please post back with your results?

Thank you!

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. In previous cases (Firefox 48 and earlier) It was recommended to reinstall the DRM in Firefox, which ensures the protection of online content. https://help.netflix.com/en/node/40835 The option they recommend to have checked is here: about:preferences#content *[[Watch DRM content on Firefox]] Can you please post back with your results? Thank you!

Úinéir na ceiste

I tried running Firefox in Safe Mode and the issue was still present. I also tried reinstalling the DRM as described in the links you provided but this also did not resolve the problem.

I did notice that the links describe a Primetime Decryption Module while I only have a Wildvine Decryption Module in my plugins list. Could this be the problem?

I tried running Firefox in Safe Mode and the issue was still present. I also tried reinstalling the DRM as described in the links you provided but this also did not resolve the problem. I did notice that the links describe a Primetime Decryption Module while I only have a Wildvine Decryption Module in my plugins list. Could this be the problem?
guigs 1072 réiteach 11697 freagra

That module is no longer automatically downloaded Firefox 52 and newer, you need to have ‘Enable DRM’ selected in about:preferences#content in order for the module to be downloaded.

Since it is not there, let's find out where it lives. In order to change your Firefox Configuration please do the following:

  1. In the address bar, type about:config and press the Enter key.
  2. The about:config "This might void your warranty!" warning page may appear.
    Click I accept the risk! to continue to the about:config page.
  3. Search for media.gmp-provider.enabled and make sure to double click it to be set to true

What is the configuration of your profile for 'Play DRM Content'?

That module is no longer automatically downloaded Firefox 52 and newer, you need to have ‘Enable DRM’ selected in about:preferences#content in order for the module to be downloaded. Since it is not there, let's find out where it lives. In order to change your Firefox Configuration please do the following: # In the [[Awesome Bar - Search your Firefox bookmarks, history and tabs from the address bar|address bar]], type '''about:config''' and press the '''Enter''' key. # The about:config "''This might void your warranty!''" warning page may appear.<br> Click '''I accept the risk!''' to continue to the about:config page. # Search for media.gmp-provider.enabled and make sure to double click it to be set to true What is the configuration of your profile for 'Play DRM Content'?
guigs 1072 réiteach 11697 freagra

Or you can go to about:plugins Click Check for Updates, and it will install manually.

Or you can go to about:plugins Click Check for Updates, and it will install manually.

Úinéir na ceiste

I checked the setting of media.gmp-provider.enabled and it was set to true. I also checked that the 'Play DRM Content' box was ticked. When I tried Check for Updates in the addons manager, I got a message saying no updates were found.

I checked the setting of media.gmp-provider.enabled and it was set to true. I also checked that the 'Play DRM Content' box was ticked. When I tried Check for Updates in the addons manager, I got a message saying no updates were found.
guigs 1072 réiteach 11697 freagra

The Primetime Content Decryption Module should download after toggling the preference in about:preferences "Play DRM Content" and waiting 15 seconds to download. The error occurs because that module is not detected.

I will try to find out why it may not be downloading, we could try a new profile to see if it downloads. Profile Manager - Create, remove, or switch Firefox profiles

The Primetime Content Decryption Module should download after toggling the preference in about:preferences "Play DRM Content" and waiting 15 seconds to download. The error occurs because that module is not detected. I will try to find out why it may not be downloading, we could try a new profile to see if it downloads. [[Use the Profile Manager to create and remove Firefox profiles]]

Úinéir na ceiste

I tried creating a new profile, but Firefox wouldn't work at all when I tried opening it. No websites load (it just says connecting) and the browser can only be closed using task manager. I had this issue just before the trouble with Netflix started, but switching on Norton Security Toolbar seemed to fix the issue on my main profile.

I tried creating a new profile, but Firefox wouldn't work at all when I tried opening it. No websites load (it just says connecting) and the browser can only be closed using task manager. I had this issue just before the trouble with Netflix started, but switching on Norton Security Toolbar seemed to fix the issue on my main profile.
cor-el
  • Top 10 Contributor
  • Moderator
17467 réiteach 157838 freagra

If you use Windows 10 and Malwarebytes then you might be experiencing a conflict between Firefox's multi-process feature and the Malwarebytes Exploit Protection feature if you see the 'connecting' message.

You can do either of these to see if that has effect.

(1) Malwarebytes: turn off Real-Time Protection -> Exploit Protection
(2) Firefox: turn off multi-process in Firefox

You can disable multi-process in Firefox by setting the related prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar.

You can accept the warning and click "I'll be careful" to continue.

<p>If you use Windows 10 and Malwarebytes then you might be experiencing a conflict between Firefox's multi-process feature and the Malwarebytes Exploit Protection feature if you see the 'connecting' message.</p><p> You can do either of these to see if that has effect.</p><p>(1) Malwarebytes: turn off Real-Time Protection -> Exploit Protection<br>(2) Firefox: turn off multi-process in Firefox</p><p>You can disable multi-process in Firefox by setting the related prefs to false on the <b>about:config</b> page.</p><ul><li>browser.tabs.remote.autostart = false</li><li>browser.tabs.remote.autostart.2 = false</li></ul><ul><li>http://www.ghacks.net/2016/07/22/multi-process-firefox/</li></ul><p>You can open the <b>about:config</b> page via the location/address bar.</p><p>You can accept the warning and click "I'll be careful" to continue.</p><ul><li>http://kb.mozillazine.org/about:config</li></ul>

Úinéir na ceiste

Thanks, switching both browser.tabs.remote.autostart to false solves the 'connecting' problem. However, Netflix videos still will not play, either on my normal profile, or on a new profile, One the new profile I first got messages saying that it was installing the necessary plugins, and once this installation was done I then got the usual error message from Netflix.

Thanks, switching both browser.tabs.remote.autostart to false solves the 'connecting' problem. However, Netflix videos still will not play, either on my normal profile, or on a new profile, One the new profile I first got messages saying that it was installing the necessary plugins, and once this installation was done I then got the usual error message from Netflix.
soljargon 1 réiteach 2 freagra

Réiteach Roghnaithe

  1. Click the menu button New Fx Menu and choose Plugins.
  2. Click More or Options for the Shockwave Flash plugin
  3. Uncheck Enable Adobe Flash protected mode

Netflix should now play in Firefox 53

This solution worked for me.

Answered my own question here: https://support.mozilla.org/en-US/questions/1158044 Sorry for the duplicate as I couldn't post an answer unless I created an account.

It looks like the problem with Adobe Flash protected mode affects 32-bit Firefox based this article: https://support.mozilla.org/en-US/kb/adobe-flash-protected-mode-firefox

#Click the menu button [[Image:New Fx Menu]] and choose Plugins. #Click ''More'' or ''Options'' for the '''Shockwave Flash''' plugin #Uncheck ''Enable Adobe Flash protected mode'' Netflix should now play in Firefox 53 This solution worked for me. Answered my own question here: https://support.mozilla.org/en-US/questions/1158044 Sorry for the duplicate as I couldn't post an answer unless I created an account. It looks like the problem with ''Adobe Flash protected mode'' affects 32-bit Firefox based this article: https://support.mozilla.org/en-US/kb/adobe-flash-protected-mode-firefox

Athraithe ag soljargon ar

Úinéir na ceiste

Excellent, that solved the problem! Thanks a lot for your help.

Excellent, that solved the problem! Thanks a lot for your help.
timR 0 réiteach 4 freagra

DCR93 said

I checked the setting of media.gmp-provider.enabled and it was set to true. I also checked that the 'Play DRM Content' box was ticked. When I tried Check for Updates in the addons manager, I got a message saying no updates were found DCR93 said
I checked the setting of media.gmp-provider.enabled and it was set to true. I also checked that the 'Play DRM Content' box was ticked. When I tried Check for Updates in the addons manager, I got a message saying no updates were found.

I cannot find 'Play DRM Content' anywhere in my 'about:config" where is it ?

''DCR93 [[#answer-960840|said]]'' <blockquote> I checked the setting of media.gmp-provider.enabled and it was set to true. I also checked that the 'Play DRM Content' box was ticked. When I tried Check for Updates in the addons manager, I got a message saying no updates were found ''DCR93 [[#answer-960840|said]]'' <blockquote> I checked the setting of media.gmp-provider.enabled and it was set to true. I also checked that the 'Play DRM Content' box was ticked. When I tried Check for Updates in the addons manager, I got a message saying no updates were found. </blockquote> I cannot find 'Play DRM Content' anywhere in my 'about:config" where is it ?
cor-el
  • Top 10 Contributor
  • Moderator
17467 réiteach 157838 freagra

You can find DRM in Options/Preferences.

  • Options/Preferences > Content: Play DRM
You can find DRM in Options/Preferences. *Options/Preferences > Content: Play DRM