Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Flash player has vanished from the "plugins" list, but I have NOT uninstalled it.

more options

Why would the Adobe Flash Player just vanish from the "plugins" list, with no obvious message that it has been "disabled" or anything (like it usually does when a flash player is found to be "vulnerable" to attack). It is simply gone, and even though I downloaded and ran the installer for the latest Flash version (21.0.0.213), for Windows - Firefox, it still does not show up in the "plugins" list, or show up on the Flash Player's version checking page ( https://www.adobe.com/software/flash/about/ ).

I'm running Windows 7 Professional, and using Firefox 46.0. Everything else works fine, so at first I thought that maybe every site has had to meet a deadline to switch to a HTML5 replacement for Flash Player or something. But I now find that this isn't the case. Anyone know what's up with this version of Flash Player and Firefox 46.0? I'm a little concerned about Flash's sudden disappearance, but my AVG Virus scan (fully updated, as always), shows no sign of anything nasty.

Réiteach roghnaithe

You probably know this, but just in case: on the Add-ons page, the Flash plugin is listed as "Shockwave Flash" rather than "Adobe Flash", although that name is used elsewhere in Firefox.

If Shockwave Flash is not listed on the Add-ons page:

Check for the Physical Presence of the Plugin DLL

On 64-bit Windows 7 that is here:

C:\Windows\SysWOW64\Macromed\Flash

and the file would be named NPSWF32_21_0_0_213.dll (unless there is a newer version with something different instead of 213).

If the file is there... and exiting and starting Firefox back up does not discover it...

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is "Shockwave Flash" finally there?

Read this answer in context 👍 2

All Replies (5)

more options

Réiteach Roghnaithe

You probably know this, but just in case: on the Add-ons page, the Flash plugin is listed as "Shockwave Flash" rather than "Adobe Flash", although that name is used elsewhere in Firefox.

If Shockwave Flash is not listed on the Add-ons page:

Check for the Physical Presence of the Plugin DLL

On 64-bit Windows 7 that is here:

C:\Windows\SysWOW64\Macromed\Flash

and the file would be named NPSWF32_21_0_0_213.dll (unless there is a newer version with something different instead of 213).

If the file is there... and exiting and starting Firefox back up does not discover it...

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is "Shockwave Flash" finally there?

more options

Is the Windows Registry key that Firefox uses to scan for the Flash plugin still present?

  • HKLM\SOFTWARE\Wow6432Node\MozillaPlugins\@adobe.com/FlashPlayer
more options

After poking around more with some of these things mentioned, I accidentally stumbled upon the fact that I had not scrolled down far enough to see that Flash Player WAS still on the list, and that it had been changed to "never activate" (which I had not changed, so that's still a mystery, and disturbing). It's status of "never activate" put it at the very bottom.

So I reset the parameter to "always activate," and after reboot it all went back to normal. I feel a bit idiotic for not scrolling down far enough, but I had always seen Flash Player listed near the top and since I had not changed it's "activate" setting, never expected it to be move to the bottom.

But I'm old, tired, and decrepit so all I can do is say thank you for your quick answers, and I'll try not to "darken the doorway" again.

more options

Make sure you have the latest version of the Shockwave Flash plugin (21.0.0.213).

You can find the latest Flash player versions for Firefox on this page:

more options

Yes, thank you. 21.0.0.213 is the version that I have. Thanks again, and I sincerely apologize for my inept bumbling for not finding Flash Player having been switched off. But yet, for the life of me I can not figure out what could have switched it to "never activate." I have never had a reason to do that, and I am certain I would have remembered if I had. Very disturbing.