Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Youtube or Firefox won't remember settings - choose your language

  • 4 fhreagra
  • 2 leis an bhfadhb seo
  • 139 views
  • Freagra is déanaí ó Rye Encoke

more options

For the last couple of days now every time I open a youtube page it will ask me to choose my language in a big blue bar across top of page. This will happen when moving to a video to watch, or returning to the main youtube page. Nothing changes. I have tried deleting cookies, clearing cache which doesn't help. The playback options also do not save. Annotations and captions can be turned off once but move to another video or main page and they have not been saved and those options go back to default. Also the autorun button on the bottom right of the video screen will not stay turned off, go to a new video or back to main page and that resets as well.

I am not sure if this is a youtube problem or a firefox problem. A community page for this problem has been opened on youtube as well, here"

https://productforums.google.com/forum/#!topic/youtube/fkxTCtDlbAg;context-place=topicsearchin/youtube/choose$20your$20language|sort:date

Any options or suggestions to help fix this problem would be appreciated

For the last couple of days now every time I open a youtube page it will ask me to choose my language in a big blue bar across top of page. This will happen when moving to a video to watch, or returning to the main youtube page. Nothing changes. I have tried deleting cookies, clearing cache which doesn't help. The playback options also do not save. Annotations and captions can be turned off once but move to another video or main page and they have not been saved and those options go back to default. Also the autorun button on the bottom right of the video screen will not stay turned off, go to a new video or back to main page and that resets as well. I am not sure if this is a youtube problem or a firefox problem. A community page for this problem has been opened on youtube as well, here" https://productforums.google.com/forum/#!topic/youtube/fkxTCtDlbAg;context-place=topicsearchin/youtube/choose$20your$20language|sort:date Any options or suggestions to help fix this problem would be appreciated

Réiteach roghnaithe

I had temporarily fixed the problem by choosing worldwide as my country. The playback settings weren't saving but at least it got rid of the bar. Now I went to check and realized it had changed me back to Canada as my location and I was getting no blue bar. Also my playback settings are now saving again.

So....no idea what happened, but I am thinking the problem must have been on youtube's end since I hadn't done anything to firefox since I changed my country to worldwide. Still, going to keep this page handy just in case it happens again.

Read this answer in context 👍 0

All Replies (4)

more options

I might first recommend reinstalling Flash Player since you have more than one install version. Second try to check your history settings to make sure you are not permanently in private mode or blocking any cookie settings: Private Browsing - Use Firefox without saving history

more options

My flash player is up to date. Not in private mode or blocking cookies.

more options

This issue can be caused by corrupted cookies or cookies that are blocked.

You can inspect the cookies for the domain in the currently selected tab:

  • click the "Site Identity Button" (globe/padlock) on the location/address bar
  • click the arrow to expand the security message
  • click "More Information" to open "Tools > Page Info"
  • click the Security tab

You can click "View Cookies" to inspect the cookies for the domain in the currently selected tab.


You can use these steps to make a website recognize and remember you:

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

If clearing cookies didn't help then it is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can use this button to go to the current Firefox profile folder:

more options

Réiteach Roghnaithe

I had temporarily fixed the problem by choosing worldwide as my country. The playback settings weren't saving but at least it got rid of the bar. Now I went to check and realized it had changed me back to Canada as my location and I was getting no blue bar. Also my playback settings are now saving again.

So....no idea what happened, but I am thinking the problem must have been on youtube's end since I hadn't done anything to firefox since I changed my country to worldwide. Still, going to keep this page handy just in case it happens again.