Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox shows incorrect bold fonts with hardware acceleration enabled

  • 13 freagra
  • 3 leis an bhfadhb seo
  • 39 views
  • Freagra is déanaí ó REiT

more options

I have a AMD GPU and last drivers (14.9). With hardware acceleration enabled firefox shows fonts a little different from the normal. Two examples:

Hardware acceleration enabled: http://alojaimagens.com/images/ps83cu73hgewe9kk6ya.png

Hardware acceleration disable: http://alojaimagens.com/images/ubvvd0d4r3ok7w6ymyb.png

Why this happens? How fix this?

Best Regards.

I have a AMD GPU and last drivers (14.9). With hardware acceleration enabled firefox shows fonts a little different from the normal. Two examples: Hardware acceleration enabled: http://alojaimagens.com/images/ps83cu73hgewe9kk6ya.png Hardware acceleration disable: http://alojaimagens.com/images/ubvvd0d4r3ok7w6ymyb.png Why this happens? How fix this? Best Regards.

All Replies (13)

more options

From Mozilla help files;

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

more options

Yes, when I disabled this function fonts back to the normal. But this a serious question because this option became enabled on default.

more options

Yes, I found out about that myself and filed a bug report. Leave Hardware turned off. Not having it should not hurt.

1031347 – Firefox Full Installer Changes User Settings

more options

But there are some open bug ticket for this issue? Is expected to be resolved?

more options

You can try to create a new Boolean pref on the about:config page via the right-click context menu with the name layout.paint_rects_separately and set the value to true and leave hardware acceleration and Direct2D enabled.

  • layout.paint_rects_separately = true

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

I tried this but don't work. I think Mozilla should consider having this option disabled by default.

I tested with Google Chrome and nothing like this happen.

more options

It is possible that Firefox uses a different font (bolder version) when hardware acceleration is used.

You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector.

more options

Really sorry for delay, but had some problems.

I see that this problem has not been solved yet. The firefox with when enabled hardware acceleration continues to "blur" the fonts.

Even in firefox TAB you can check this. Let me give an example: http://s16.postimg.org/9a2pwgm8l/firefoxblurfonts.png

The first example is with hardware acceleration enabled and second with disabled. You can see clearly the difference.

more options

The top image is pushed over one letter. Is there something invisible there?

more options

What you mean with invisible?

You can see other example:

Enable: http://s1.postimg.org/yp14ox54f/enable.png

Disable: http://s1.postimg.org/uer272pf3/disable.png

With Hardware acceleration ON fonts come blur.

more options

From Mozilla help files;

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

more options

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Yes, disabling fix this problem. But I lost the advantages of this feature.

cor-el, thank you for the suggestion. But unfortunately don't resolve and put worst: http://s18.postimg.org/6nwe739u1/ayers_offmainthreadcomposition_enabled_false.png