X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Why does YouTube on Firefox offer so few quality options even if the video can be viewed in higher quality on Chrome or when it is embeded?

Postáilte

I've noticed that YouTube only offers three quality options for some videos when viewed on the video's page (240p, 360p, and 720p) even while the offered video elsewhere is significantly higher. One example of this is the following video: https://www.youtube.com/watch?v=DvY5irWC7kA (/u/aygoman of /r/Oman); when viewed in Chrome or when embedded in a page (such as through the RES addon), the video options are more verbose: 240p, 360p, 480p, 720p, 1080p, 2160p.

While I do not typically view above 720p, sometimes I would like the option to view a video in either 1080p or 480p and cannot for some unknown reason.

I've noticed that YouTube only offers three quality options for some videos when viewed on the video's page (240p, 360p, and 720p) even while the offered video elsewhere is significantly higher. One example of this is the following video: https://www.youtube.com/watch?v=DvY5irWC7kA (/u/aygoman of /r/Oman); when viewed in Chrome or when embedded in a page (such as through the RES addon), the video options are more verbose: 240p, 360p, 480p, 720p, 1080p, 2160p. While I do not typically view above 720p, sometimes I would like the option to view a video in either 1080p or 480p and cannot for some unknown reason.

Réiteach roghnaithe

Type about:config in address bar. It will give a warning,click on button that says "I'll be careful,I promise!". Paste this in search bar of about config.

media.mediasource.enabled

and double click on the entry showed to make it true and bold. Now html5 videos will show all resolutions. If this causes any problem,double click on the entry again to make it false. Make sure you are in html trial and flash is disabled on youtube.com

Read this answer in context 9

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 13.0 r0
  • Provides information about the default web browser
  • LastPass Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • DivX VOD Helper Plug-in
  • DivX Web Player version 3.1.1.9
  • 5.1.20125.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8

Feidhmchlár

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0

Tuilleadh Eolais

cor-el
  • Top 10 Contributor
  • Moderator
17467 réiteach 157849 freagra

Freagra Cabhrach

Are you using the YouTube HTML5 media player or the Flash player? See also: *http://googlesystem.blogspot.com/2013/10/youtube-drops-support-for-1080p-streams.html *http://googlesystem.blogspot.com/2013/10/youtube-shows-if-your-browser-supports.html
philipp
  • Top 25 Contributor
  • Moderator
5304 réiteach 23419 freagra

hello, you can see this article for some background on that issue: http://www.ghacks.net/2013/10/27/youtube-videos-firefox-1080p/

hello, you can see this article for some background on that issue: http://www.ghacks.net/2013/10/27/youtube-videos-firefox-1080p/

Úinéir na ceiste

Edit: I noticed after another load on my desktop that I was once again limited to the previous options. I realized that one of my addons, SmartVideo For YouTube 0.979, was limiting my options. Initially I was unable to remove it, but after removing a few files (addons.sqlite, addons.json, pluginreg.dat, extensions.ini, extensions.json, extensions.sqlite, and extensions.log), I was able to do so. After this, I was able to view videos with all of the resolutions options intact. Removing it on my laptop furnished me with similar results.

In short, SmartVideo For YouTube 0.979 (updated 01/29/14) was creating issues.

Original: I was using the Flash player on both my desktop (Windows 7) and my laptop (OSX 10.9.2); I found there was an update for Firefox from 29.0.1 to 30.0 so I completed it. After doing so, I did not appear to gain any quality options on my laptop, though on my desktop it appears that I now have access to all of the resolutions. Switching to the HTML5 viewer limited my streaming options to 360p on my laptop, and to 360p/720p on my desktop. It's worth noting, however, that the OSX binary does not appear to support H.264.

I'm still wondering why I can view all of the quality options on my laptop if the video is embedded, but I'm still limited to the aforementioned resolutions. I've attached screenshots showing the options present.

'''Edit:''' I noticed after another load on my desktop that I was once again limited to the previous options. I realized that one of my addons, SmartVideo For YouTube 0.979, was limiting my options. Initially I was unable to remove it, but after removing a few files (addons.sqlite, addons.json, pluginreg.dat, extensions.ini, extensions.json, extensions.sqlite, and extensions.log), I was able to do so. After this, I was able to view videos with all of the resolutions options intact. Removing it on my laptop furnished me with similar results. In short, SmartVideo For YouTube 0.979 (updated 01/29/14) was creating issues. ''Original:'' I was using the Flash player on both my desktop (Windows 7) and my laptop (OSX 10.9.2); I found there was an update for Firefox from 29.0.1 to 30.0 so I completed it. After doing so, I did not appear to gain any quality options on my laptop, though on my desktop it appears that I now have access to all of the resolutions. Switching to the HTML5 viewer limited my streaming options to 360p on my laptop, and to 360p/720p on my desktop. It's worth noting, however, that the OSX binary does not appear to support H.264. I'm still wondering why I can view all of the quality options on my laptop if the video is embedded, but I'm still limited to the aforementioned resolutions. I've attached screenshots showing the options present.

Athraithe ag amberkilloran ar

Gaggi 1 réiteach 3 freagra

Réiteach Roghnaithe

Type about:config in address bar. It will give a warning,click on button that says "I'll be careful,I promise!". Paste this in search bar of about config.

media.mediasource.enabled

and double click on the entry showed to make it true and bold. Now html5 videos will show all resolutions. If this causes any problem,double click on the entry again to make it false. Make sure you are in html trial and flash is disabled on youtube.com

Type about:config in address bar. It will give a warning,click on button that says "I'll be careful,I promise!". Paste this in search bar of about config. media.mediasource.enabled and double click on the entry showed to make it true and bold. Now html5 videos will show all resolutions. If this causes any problem,double click on the entry again to make it false. Make sure you are in html trial and flash is disabled on youtube.com

Athraithe ag Gaggi ar