Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

firefox gives "crossdomain loading denied" error on pbs website, IE ok

  • 10 bhfreagra
  • 48 leis an bhfadhb seo
  • 26519 views
  • Freagra is déanaí ó guigs

more options

I tried to watch the PBS "Newshour" for June 13,2014. I got "skin could not load: Crossdomain loading denied" error. This is the first time this has ever happened. I tried it on IE and all worked fine. The last time I watched the PBS Newshour on FireFox was before the update 29.0.1. is there a fix?

Réiteach roghnaithe

Try to update your extensions, Flash, and updating to the new version 30 that launched this week. http://www.dwuser.com/flashslideshow/.../understanding_flash_player_cross_domain_loading_restrictions.html

Read this answer in context 👍 0

All Replies (10)

more options

Réiteach Roghnaithe

Try to update your extensions, Flash, and updating to the new version 30 that launched this week. http://www.dwuser.com/flashslideshow/.../understanding_flash_player_cross_domain_loading_restrictions.html

more options

All addons are alleged to be up to date, now running 31.0, get the same error on pbs site.

more options

Hi Micheal, There was an update to the certificate manager this version and there were reports of this error.

If you clear the cache of the Flash Player (right click on player, select global settngs, then storage the option is in that menu) as well as the cache for that site are there any improvements?

more options

No improvement after deleting all data. All of the video clips on the page

www.pbs.org/wgbh/pages/frontline/inside-frontline/frontline-nominated-for-11-emmy-awards/

say:

Error loading skin: Crossdomain being denied.

There are a ton of pages being loaded as the original page settles down.

more options

Michael, I did some research on the crossdomain xml file for the jwplayer: the issues were all with the file: http://support.jwplayer.com/customer/.../5496483-jw6-crossdomain-access-denied

However the site that you listed does work for me on version 32, I would recommend trying this in the meantime.

If you have access to the xml file or this file is being blocked by an add on it may need to be unblocked, though I am not sure why it would be blocked.

do you happen to have javascript.options.baselinejit enabled?

more options

"...the site that you listed does work for me on version 32..." My FF installation is 31.0 and claims to be up to date; how can I persuade it to update to 32?

"If you have access to the xml file..." Which xml file are you talking about? I should have access to anything on the machine, but do run normally with normal (i.e., non-admin) user privileges, if that's relevant. "or this file is being blocked by an addon..." Not sure what you mean by a file that's blocked. Sorry to sound stupid.

"...do you happen to have javascript.options.baselinejit enabled..." It's set to default/boolean/true; I generally don't touch anything in there.

I'm having enough problems with this FF installation, I'm beginning to suspect severe "bit rot", perhaps brought on by recent addons claiming to improve security. When I do find version 32, is there a way to update my current installation to a "pure" 32 with no addon contamination? Or can I re-install 31 that way? I've tried restarting with addons disabled with no improvement. On another computer, similarly configured, but with no addons ever installed, I don't see these problems.

more options

Hi MichaelArmstrong, I apologize for the confusion, the xml file is for a web developer using the video player on their site. This does not seem relevant and please disregard.

Version 32 is actually currently the Beta version. A clean install of Beta is available:[ https://www.mozilla.org/en-US/firefox/channel/#beta] however this is a version that is still updating on a 6 week release cycle and will come to the release channel in 5 weeks.

There is a clean reinstall and a new profile: Profile Manager - Create, remove, or switch Firefox profiles

Clean reinstall instructions are below: Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING:Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

more options

So far so good, after just reinstalling as suggested; thanks.

more options

I don't think this is "Solved", certainly not on my Ubuntu 12.04 or 14.04. After struggling with this issue for days, I copied an earlier version of Flash (11.1 r102) to /usr/lib/flashplugin-installer/ and I can now access the "Woodwright's Shop" normally. Previous version from automatic updates was 11.2 r202.

more options

Hi wb8nbs, Thank you for your comment, please consider creating a new thread containing the specific details of your issue.

Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently.

Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you.

Thank you.