Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Show Menubar using userchrome.css

  • 2 fhreagra
  • 2 leis an bhfadhb seo
  • 95 views
  • Freagra is déanaí ó eddythorn

more options

Using the userChrome.css file, I am trying to accomplish two things: 1) Hide the appmenu button; 2) Show the Menu bar. I am able to turn off the appmenu button, but I can't get the Menu bar to display.

Here is the code I am using: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

  1. appmenu-button {display: none !important; }
  2. toolbar-menubar {display: list !important; }

Please help. Thank you. Eddy

Using the userChrome.css file, I am trying to accomplish two things: 1) Hide the appmenu button; 2) Show the Menu bar. I am able to turn off the appmenu button, but I can't get the Menu bar to display. Here is the code I am using: @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */ #appmenu-button {display: none !important; } #toolbar-menubar {display: list !important; } Please help. Thank you. Eddy

Réiteach roghnaithe

Thanks cor-el. I will keep your solution in mind. I was able to figure out my problem - instead of using 'display: list', I used 'display: inline' (for the toolbar-menubar).

Read this answer in context 👍 0

All Replies (2)

more options

Why don't you make the Menu bar visible via View > Toolbars?

Note that toolbars require display: -moz-box !important;


Firefox 27 uses this code, see line 276 in this file (open via the location bar):

chrome://global/content/xul.css
toolbar[type="menubar"][autohide="true"][inactive="true"]:not([customizing="true"]) {
  min-height: 0 !important;
  height: 0 !important;
  -moz-appearance: none !important;
  border-style: none !important;
}

So you need at least set the height

more options

Réiteach Roghnaithe

Thanks cor-el. I will keep your solution in mind. I was able to figure out my problem - instead of using 'display: list', I used 'display: inline' (for the toolbar-menubar).