Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

Google images are not loading

  • 12 antwurd
  • 17 hawwe dit probleem
  • 2 werjeftes
  • Lêste antwurd fan Vikas Khunteta

more options

After upgrading Mozilla Firefox from version 37, I have been facing very irritating issue related to Google only and sometimes for other websites too. I have refreshed Firefox many times and tried disabling all the addons and started Firefox in Safe Mode to fix the issue but nothing solved this.

I have cleared cookies for all Google Accounts but that didnt' help too. I also face problem with other Google sites like Google Drive, Google Photots, Google+. Even Google reCaptcha image is not loading on others websites. Please help me to fix this issue.

After upgrading Mozilla Firefox from version 37, I have been facing very irritating issue related to Google only and sometimes for other websites too. I have refreshed Firefox many times and tried disabling all the addons and started Firefox in Safe Mode to fix the issue but nothing solved this. I have cleared cookies for all Google Accounts but that didnt' help too. I also face problem with other Google sites like Google Drive, Google Photots, Google+. Even Google reCaptcha image is not loading on others websites. Please help me to fix this issue.
Keppele skermôfbyldingen

Alle antwurden (12)

more options

If images are missing then check that you do not block images from some domains. You can tap the Alt key or press F10 to show the Menu Bar Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

Select the first image link and use the cursor Down key to scroll through the list. If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

http://kb.mozillazine.org/about:config

There are extensions like Adblock Plus (Firefox menu button/Tools > Add-ons > Extensions) and Anti-Virus software that can block images and other content.

Bewurke troch sotos op

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

more options

There were a lot of changes between Firefox 37 and Firefox 42 that could affect images. In case you haven't already seen our general support article:

Fix problems that cause images to not show

Could you test in Firefox's Safe Mode? Sorry, skimmed right over the part where you said you tried this.

Bewurke troch jscher2000 - Support Volunteer op

more options

You can see for a solution in following link if problem is stills remaining

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

Bewurke troch sotos op

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Thanks to all for your reply but nothing solved this problem. I started Windows into Safe Mode with Networking and in safe mode, all thumbnails were showing on YouTube, when I restarted Windows into normal mode, I visited YouTube again & I faced same problem but I restarted Firefox in safe mode and I was able to see all the thumbnails but when I clicked on load more button and saw new videos, there were many video thumbnails were not showing.

I visited other Google Websites like Google reCaptcha, Google Webmasters, Google Analytics, Google Drive but I faced same problem, restarting Firefox in safe mode fix the problem temporary but not always.

Other than image loading issue from Google owned domains, I also face problem accessing Google Drive. It says "You are offline" when I am connected to internet.

I have few addons installed let me point out here: 1. Evernote Clearly 2. Nimbus Screenshot 3. Firebug 4. Avast Ad-Blocker 5. Dictionary Extension 6. IDM Integration

There are few more addons but those are disabled.

I also keep history for all sites, cookies for selected websites. I keep sync data with Firefox server and I don't want to delete that. Previously I have cleared cookies for all Google Sites to fix the issue but that didn't help too.

The history I have is more than year or two year old. In case anybody thinks that clearing all history can help fixing the issue permanently than I can try refreshing Firefox once again, but I have refreshed the Firefox 4-5 times previously but that only fix the problem temporary.

I have also tried uninstalling Firefox but that didn't work too. The problem is mainly with Google owned domains. Let me know if any other users facing this kind of issues.

I have been attaching few screenshots.

more options

Vikas Khunteta said

I started Windows into Safe Mode with Networking and in safe mode, all thumbnails were showing on YouTube, when I restarted Windows into normal mode, I visited YouTube again & I faced same problem...

So something that is part of your normal startup, most likely outside of Firefox, is affecting Google-related sites. If no filtering/proxy software comes to mind, have you scanned for malware? Our support article lists free tools other Firefox users have found helpful: Troubleshoot Firefox issues caused by malware.

more options

jscher2000 said

So something that is part of your normal startup, most likely outside of Firefox, is affecting Google-related sites.

Thanks for giving me clue that something outside of Firefox affecting Google related sites, but its not malware, I have virus/malware free system. I am not 100% sure that I figured out the problem or not but when I disabled my Avast antivirus, I didn't face any problem with Google sites, even Google Drive also worked well.

I don't know why only Firefox have problem with Avast. I can't disable the antivirus too to fix the problem. Does anyone knows what settings should I change to fix the problem permanently.

I didn't change antivirus setting after Firefox upgrade, its all started suddenly without any setting changed.

I have Avast version 10.4.2233 installed on my system. I noticed one more improvement in loading Google Images when Avast was disabled, the images were loading quite fast compared to active Avast.

One more good thing happen when I disabled antivirus, I didn't have to disable and enable for every Google site, it worked for all sites once.

But still this is not right solution to fix the problem, so does anyone know how to fix the problem permanently and why its only related to Firefox.

more options

The Avast Web Shield feature intercepts and scans your browser connections. You might be able to opt Firefox out of this feature and leave it turned on for your other browsers as a workaround.

However, the usual issue users raise is that the Avast Web Shield causes numerous errors about untrusted secure connections in Firefox. Have you not encountered any of those? The reason for those errors is either that:

  • Avast did not insert its signing certificate into Firefox's certificate store (cert8.db), or
  • Avast did insert it but:
    • you used the Refresh feature during your update, which removed cert8.db (do you see an Old Firefox Data folder on the desktop?), or
    • there are other certificates in the certificate store causing site-specific problems

Unlike Chrome and IE, Firefox does not use the Windows system certificate store, so this would explain different results in Firefox from your other browsers if you have seen certificate errors since your Firefox 42 update.

more options

jscher2000 said

The Avast Web Shield feature intercepts and scans your browser connections. You might be able to opt Firefox out of this feature and leave it turned on for your other browsers as a workaround. However, the usual issue users raise is that the Avast Web Shield causes numerous errors about untrusted secure connections in Firefox. Have you not encountered any of those? The reason for those errors is either that:
  • Avast did not insert its signing certificate into Firefox's certificate store (cert8.db)

There is only one Script Scanning option in Web Shield where I can opt out for Firefox.

I didn't face any certification issue, sometimes page failed to load due to insecure connection but a refresh loads the page.

I looked the certificates section and I found "avast! Web/Mail Shield Root" certificate there, so I don't think Avast failed to insert its certificate.

I have been continuously monitoring the Google related sites, right now I am pretty happy because all sites working fine after few months. But still no settings changed by me to fix the solution permanently.

Will disabling Script Scanning option for Firefox fix the problem? and What will be disadvantage if I disable that option?

more options

Sorry, I don't use Avast and I don't know what the "Script Scanning" option does.

Is the current status that Avast is running and Google sites are working, or is Avast still disabled?

more options

Avast is running and all sites seems to be working fine. I think the issue is fixed for now and hope I don't face this problem in future. In case, if I will face the problem again then I will let you know here.