Afficher les questions étiquetées : Afficher toutes les questions

Firefox: Unable to load module (PKCS11, DNIe)

Firefox is unable to load module I've been trying to setup a smartcard reading device, and I've gotten stuck twice on the same place. When it comes to configuring the Sec… (lire la suite)

Firefox is unable to load module

I've been trying to setup a smartcard reading device, and I've gotten stuck twice on the same place.

When it comes to configuring the Security Device on Firefox, I can't access the .so file. Firefox merely shows the error "Alert: Unable to add module", but I've noticed that when I try to browse my files manually, trying to access the /usr directory returns an error (sometimes, I seem to not be able to get it consistently).

It also happens that the software I installed for the digital certificate tried to open an html with Firefox, which is located in /usr/share/, and Firefox doesn't seem to be able to load that either. It returns a "Can't open file".

Steps followed

  1. Open Firefox
  2. Settings → Privacy and Security → Security Devices → Load
  3. Insert path /usr/lib/libpkcs11-dnie.so and try to load (yes, I've checked that the file does actually exist)
  4. Receive Alert: Unable to add module error

Relevant information

   Ubuntu 22.04
   I'm on the latest snap version of Firefox: 100.0.1-1
   Trying to setup the digital certificate for my Spanish ID (DNIe)

Demandé par jana.lauco il y a 1 jour