X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

Fix for Youtube: An error occurred. Please try again later. or Youtube videos don't play.

Publié

Try this solution.

Try this solution.

Modifié le par dBrain2012

Solution choisie

  1. Disable or remove the addon 'Video DownloadHelper'. (Tools > Addons > Click Disable button or Remove button for Video DownloadHelper)
  2. Restart Firefox.

I have been trying to search for acceptable solution for many days because I had this problem. This solution worked for me. I posted the question as well as solution hoping it helps someone. Addons too can create problems.

qquito and some others, who had the same problem, were provided a workaround solutions such as downgrading the flash player version. There is no need of downgrading Flash Player. There seems to be a conflict between new version of Flash Player and Video DownloadHelper.

Thank you.

Lire cette réponse dans son contexte 59

Détails additionnels sur le système

Sites affectés

http://www.youtube.com

Plugins installés

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.4 r402
  • Google Update
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • VLC media player Web Plugin 2.0.2
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object

Application

  • Agent utilisateur : Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0

Plus d’informations

Try this solution.

Solution choisie

  1. Disable or remove the addon 'Video DownloadHelper'. (Tools > Addons > Click Disable button or Remove button for Video DownloadHelper)
  2. Restart Firefox.

I have been trying to search for acceptable solution for many days because I had this problem. This solution worked for me. I posted the question as well as solution hoping it helps someone. Addons too can create problems.

qquito and some others, who had the same problem, were provided a workaround solutions such as downgrading the flash player version. There is no need of downgrading Flash Player. There seems to be a conflict between new version of Flash Player and Video DownloadHelper.

Thank you.

# Disable or remove the addon 'Video DownloadHelper'. (Tools > Addons > Click Disable button or Remove button for Video DownloadHelper) # Restart Firefox. I have been trying to search for acceptable solution for many days because I had this problem. This solution worked for me. I posted the question as well as solution hoping it helps someone. Addons too can create problems. qquito and some others, who had the same problem, were provided a workaround solutions such as downgrading the flash player version. There is no need of downgrading Flash Player. There seems to be a conflict between new version of Flash Player and Video DownloadHelper. Thank you.

Modifié le par dBrain2012

cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 réponses

Such issues can also be caused by expired files in the cache.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"
Such issues can also be caused by expired files in the cache. Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Press and hold Shift and left-click the Reload button. *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (MAC) Clear the cache and the cookies from sites that cause problems. "Clear the Cache": *Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Tools > Options > Privacy > Cookies: "Show Cookies"

Auteur de la question

@cor-el I always clear the cache and and remove cookies, but it did not work for me. Reloading the page too didn't work. The problem reoccurred. Disabling Video Downloadhelper helped in my case.

@cor-el I always clear the cache and and remove cookies, but it did not work for me. Reloading the page too didn't work. The problem reoccurred. Disabling Video Downloadhelper helped in my case.

Modifié le par dBrain2012

Narakusmate1 0 solutions 1 réponses

I have this problem too but I find no such thing to disable. I checked in every category. There is no Video download helper.

I have this problem too but I find no such thing to disable. I checked in every category. There is no Video download helper.
Taksir 0 solutions 1 réponses

Realplayer installed? Try to disable realplayer It will help!

Realplayer installed? Try to disable realplayer It will help!
humeston 0 solutions 1 réponses

I tried everything listed and more. Firefox simply will not play videos on youtube or on news websites. Looks like I have to dump firefox until they figure out what the problem is. Youtube plays in all my other browsers fine.

I tried everything listed and more. Firefox simply will not play videos on youtube or on news websites. Looks like I have to dump firefox until they figure out what the problem is. Youtube plays in all my other browsers fine.
cor-el
  • Top 10 Contributor
  • Moderator
17540 solutions 158604 réponses

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

You can check for problems with current Flash plugin versions and try these:

  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ----- You can check for problems with current Flash plugin versions and try these: *disable protected mode in Flash 11.3 and later *disable hardware acceleration in the Flash plugin *http://kb.mozillazine.org/Flash#Troubleshooting
pradip.sharma 0 solutions 1 réponses

Réponse utile

i tried to figure out various options (1) removing addons (2) updating flash players etc. finally i came to know that google chrome that i installed recently was the cause of this error in firefox. I uninstalled google chrome, and now youtube videos working well in my firefox. please comment if this solution has worked for you.

i tried to figure out various options (1) removing addons (2) updating flash players etc. finally i came to know that google chrome that i installed recently was the cause of this error in firefox. I uninstalled google chrome, and now youtube videos working well in my firefox. please comment if this solution has worked for you.