Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

bug returning from hibernation: open firefox is ignored

  • 14 réponses
  • 0 a ce problème
  • 1 vue
  • Dernière réponse par rayandrews

more options

In case anyone's interested, under Debian 12, when I resume from hibernation, if I have Firefox running as well as Tbird, if I click on a link in an email, the existing instance of Firefox is ignored and a new instance is opened. The first instance is in fact frozen -- it looks as it should but trying to change tabs or open a new tab is inactive. Seems I have to kill the open instance of FF, then if I click on a link in an email, FF pops up as it should with a new tab for the link, but the existing tabs are all there and all functional. It feels like a bug -- Tbird seems not to know that FF is already running.

In case anyone's interested, under Debian 12, when I resume from hibernation, if I have Firefox running as well as Tbird, if I click on a link in an email, the existing instance of Firefox is ignored and a new instance is opened. The first instance is in fact frozen -- it looks as it should but trying to change tabs or open a new tab is inactive. Seems I have to kill the open instance of FF, then if I click on a link in an email, FF pops up as it should with a new tab for the link, but the existing tabs are all there and all functional. It feels like a bug -- Tbird seems not to know that FF is already running.

Solution choisie

jonzn4SUSE said

I hibernate every day and usually have Nightly, current Firefox, and Waterfox open with no issues. ... Memory: 62.1 GiB of RAM

It shouldn't be an issue if you have a lot of free RAM available.

rayandrews said

the existing instance of Firefox is ignored and a new instance is opened.

It is not possible to launch two instances of the same profile, external links may open in a new window depending on the request and browser configuration. Try changing browser.link.open_newwindow.override.external to 3 in about:config.

Does the freeze still happen if you disable hardware acceleration?

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (14)

more options

rayandrews said

The first instance is in fact frozen

Resuming from hibernation on Linux has historically had performance issues and is disabled by default on major distros like Ubuntu.

Cela vous a-t-il été utile ?

more options

I never got hibernation to work at all until Debian 12. But the above is the only problem I've detected so far. Of course I can't say where the issue lies, could be Debian itself, but it smells like Tbird simply doesn't know that FF is already running. Dunno, maybe that's Debian's job or maybe Tbird could simply 'check'? Perhaps, as you say, hibernation has been so unreliable that this issue simply hasn't come up very much.

Cela vous a-t-il été utile ?

more options

I hibernate every day and usually have Nightly, current Firefox, and Waterfox open with a few issues. see screenshot You should try the same steps on a different distro and the hardware, drivers, or kernel could also be an issue. Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

What Desktop? X11 or Wayland?

Operating System: openSUSE Leap 15.6 KDE Plasma Version: 5.27.11 KDE Frameworks Version: 5.115.0 Qt Version: 5.15.12 Kernel Version: 6.4.0-150600.10-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 PRO 6850HS with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP EliteBook 865 16 inch G9 Notebook PC

Modifié le par jonzn4SUSE

Cela vous a-t-il été utile ?

more options

Yeah, I guess the problem could be in any number of places. FF here is ver. 115.9. Mind ... if I had to guess I'd say it was Tbird, since FF by itself shows no problems, it's only when Tbird tries to open a link that the 2nd copy of FF is started. Maybe I'll do as you say and grab the latest version from Mozilla directly. Tx.

Cela vous a-t-il été utile ?

more options

Solution choisie

jonzn4SUSE said

I hibernate every day and usually have Nightly, current Firefox, and Waterfox open with no issues. ... Memory: 62.1 GiB of RAM

It shouldn't be an issue if you have a lot of free RAM available.

rayandrews said

the existing instance of Firefox is ignored and a new instance is opened.

It is not possible to launch two instances of the same profile, external links may open in a new window depending on the request and browser configuration. Try changing browser.link.open_newwindow.override.external to 3 in about:config.

Does the freeze still happen if you disable hardware acceleration?

Cela vous a-t-il été utile ?

more options

Just after saying that, I switch to 445 G9 and it was hibernating, but 2 times in a row network would not work. Had to restart and all is well.  ;-)) More ram and swap help, but i still have the occasional waking up problem, but the issues are more on the OS and hardware and rarely Firefox.


Operating System: openSUSE Tumbleweed 20240328 KDE Plasma Version: 6.0.3 KDE Frameworks Version: 6.0.0 Qt Version: 6.6.3 Kernel Version: 6.8.1-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

Modifié le par jonzn4SUSE

Cela vous a-t-il été utile ?

more options

Gentlemen:

Will try suggestions a bit latter and get back to you.

Cela vous a-t-il été utile ?

more options

We'll leave the light on for ya...

Cela vous a-t-il été utile ?

more options

> browser.link.open_newwindow.override.external to 3 in about:config.

By Jove! Seems to work :-)

Thanks guys.

Cela vous a-t-il été utile ?

more options

Ooops ... nope not fixed. I did a hibernate and resume last night and it seemed fine. But that was probably just the Quantum Observer Effect -- I was watching so it didn't misbehave. But this morning, it's back to ignoring the open instance and staring another one. I have to kill and restart FF and then everything is OK. BTW I most surely can open multiple instances of FF, I have three open right now.

Cela vous a-t-il été utile ?

more options

Does it still happen if you stay under 50% memory usage during hibernation?

Cela vous a-t-il été utile ?

more options

How can I check that? I know there's a command to check memory usage. I have 8G and my swap partition is 5G ... AFAICT that's never been insufficient.

Modifié le par rayandrews

Cela vous a-t-il été utile ?

more options

You are going to have swapping issues when resuming from hibernation with only 8GB unless Firefox has been recently started.

Cela vous a-t-il été utile ?

more options

Any possible diagnosis? Anyway, heck, it's a very small matter.

2 /boot 0 % mem

                    total        used        free      shared  buff/cache   available

Mem: 7870 3019 4386 39 802 4850 Swap: 5119 449 4670

... I'd have thought I have lots of freeboard.

Modifié le par rayandrews

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.