Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

trying to recognize FF as default on Fedora 33

  • 2 réponses
  • 1 a ce problème
  • 41 vues
  • Dernière réponse par Nick_Levinson

more options

Step to Reproduce: 1. Start the browser. You can do so directly or by opening a file that starts FF.

Actuality:

This alert appears: "Default Browser" in title bar, in body "Firefox is not currently set as your default browser. Would you like to make it your default browser?" (with "Always perform this check when starting Firefox." precheckmarked)) with buttons "Not now" (nondefault button) and "Use Firefox as my default browser" (default button). I click the default button but the problem repeats next time anyway.

FF is always my default browser. My preference is already set for it to be the default (FF > hamburger menu > Preferences > General > Startup > Always Check if Firefox is Your Default Browser is already checkmarked), my distro (Fedora 33 > Gnome 3.38.3 > Settings app > Default Applications > Web) has it as the default, ctrl-clicking a linked URL in LibreOffice Writer opens FF with that URL in the address bar, and I always approve the alert to make it my default. It still asks.

FF was my default browser. It came with Fedora 32 and I kept Fedora evergreen so that now it's F33 and still evergreen. Recently, I removed and reinstalled FF, via Fedora's Software app for both steps and setting largely the same prefs as before.

Applying https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser and https://support.mozilla.org/en-US/kb/setting-firefox-default-browser-does-not-work didn't solve it. FF > hamburger menu > Preferences > General > Startup > Always Check if Firefox is Your Default Browser is checkmarked, but exiting and restarting FF doesn't solve it. Under that, it continuously says "Firefox is not your default browser". Clicking the "Make Default…" button changes the button's shade but no dialog appears (although that's what "…" portends) and nothing else happens. Uncheckmarking the option and clicking the button recheckmarks the option, but still nothing happpens. I have Chromium 88.0.4324.150 (Developer Build) Fedora Project (64-bit) and Tor 10.0.8 but neither one is the default browser (Chromium upon starting says on the initial screen it isn't and Tor says it isn't in about:preferences) and I use them less, Favorites bar > Show Applications > "browser" (without quote marks) doesn't bring up any other browsers, and I don't think I have any other browsers on the laptop.

This happpens consistently. I don't remember when it began, but not long ago.

Possibly relevant: https://github.com/xhorak/firefox-devedition-flatpak/issues/77

Expectation: If consistent with the pref, recognize that FF is the default.

What should I try next?

Step to Reproduce: 1. Start the browser. You can do so directly or by opening a file that starts FF. Actuality: This alert appears: "Default Browser" in title bar, in body "Firefox is not currently set as your default browser. Would you like to make it your default browser?" (with "Always perform this check when starting Firefox." precheckmarked)) with buttons "Not now" (nondefault button) and "Use Firefox as my default browser" (default button). I click the default button but the problem repeats next time anyway. FF is always my default browser. My preference is already set for it to be the default (FF > hamburger menu > Preferences > General > Startup > Always Check if Firefox is Your Default Browser is already checkmarked), my distro (Fedora 33 > Gnome 3.38.3 > Settings app > Default Applications > Web) has it as the default, ctrl-clicking a linked URL in LibreOffice Writer opens FF with that URL in the address bar, and I always approve the alert to make it my default. It still asks. FF was my default browser. It came with Fedora 32 and I kept Fedora evergreen so that now it's F33 and still evergreen. Recently, I removed and reinstalled FF, via Fedora's Software app for both steps and setting largely the same prefs as before. Applying https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser and https://support.mozilla.org/en-US/kb/setting-firefox-default-browser-does-not-work didn't solve it. FF > hamburger menu > Preferences > General > Startup > Always Check if Firefox is Your Default Browser is checkmarked, but exiting and restarting FF doesn't solve it. Under that, it continuously says "Firefox is not your default browser". Clicking the "Make Default…" button changes the button's shade but no dialog appears (although that's what "…" portends) and nothing else happens. Uncheckmarking the option and clicking the button recheckmarks the option, but still nothing happpens. I have Chromium 88.0.4324.150 (Developer Build) Fedora Project (64-bit) and Tor 10.0.8 but neither one is the default browser (Chromium upon starting says on the initial screen it isn't and Tor says it isn't in about:preferences) and I use them less, Favorites bar > Show Applications > "browser" (without quote marks) doesn't bring up any other browsers, and I don't think I have any other browsers on the laptop. This happpens consistently. I don't remember when it began, but not long ago. Possibly relevant: https://github.com/xhorak/firefox-devedition-flatpak/issues/77 Expectation: If consistent with the pref, recognize that FF is the default. What should I try next?

Toutes les réponses (2)

more options

I am not sure I understand. On the General page of Preferences, unselect the setting "Always check ...."

more options

No, I want it to check. But then FF should pass the check and not alert me as if FF failed the check.

The reason for the check is in case another browser sets itself as the default and I don't find out in time. So FF should check.