Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

why after giving permission do I still get this response ''Camera not authorized. Please check your media permissions settings.''

  • 41 réponses
  • 4 ont ce problème
  • 50344 vues
  • Dernière réponse par joseph501325

more options

checking my webcam on a test webcam site -----https://www.onlinemictest.com/webcam-test/-----granting permission I get this-----

Camera not authorized. Please check your media permissions settings.

There have been times where it let me through and I was able to test it but more often it refuses. Also have the same problem

using Facebook. When I switch over to Chrome browser I don't have any problems which leads me to believe the problem is with

Firefox. I've seen other people mentioning this but I didn't see any resolutions

Solution choisie

joseph501325 said

Happy112 said
Stab in the dark, but have you checked the Settings here (see screenshot) :

Here it is


Glory over me the umteenth time I did for some reason it worked. I have no idea what is different

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (20)

more options

joseph501325 said

I get the prompt and it says that its allowed --

I don't think you're talking about the same prompt ....

The little dot on the Page Info icon (as shown in one of your screenshots) indicates that you've clicked 'Allow' under the Permissions tab, but there is no camera icon, which should show up after you've clicked 'Allow' on the Firefox prompt.

more options

Okay I pasted media*enable and they all came up default

Thank you for your help it is sincerely appreciated

more options

One other thought, in case you have more than one "camera":

If you change the permission back to Use default, do you get the permission prompt from Firefox when reloading the test page?

If you do, does Firefox list the correct camera in the panel? I mean where my screenshot shows "Integrated Camera":

more options

These two screenshots show show two different options

on the drop-down window that I can chose from

more options

joseph501325 said

These two screenshots show show two different options on the drop-down window that I can chose from

Does it work if you allow the camera you want to use but don't save the permission for the next time? The reason I ask that is I wonder if Firefox NEEDS you to select the correct camera each time when you have more than one, and if permission is saved, maybe there isn't a place to select that? I can't test that for myself, I don't have multiple cameras.

more options

Happy112 said

joseph501325 said
I get the prompt and it says that its allowed --

I don't think you're talking about the same prompt ....

The little dot on the Page Info icon (as shown in one of your screenshots) indicates that you've clicked 'Allow' under the Permissions tab, but there is no camera icon, which should show up after you've clicked 'Allow' on the Firefox prompt.


This prompt is the prompt you're referring to?

more options

jscher2000 said

joseph501325 said
These two screenshots show show two different options on the drop-down window that I can chose from

Does it work if you allow the camera you want to use but don't save the permission for the next time? The reason I ask that is I wonder if Firefox NEEDS you to select the correct camera each time when you have more than one, and if permission is saved, maybe there isn't a place to select that? I can't test that for myself, I don't have multiple cameras.


I set it to Always Ask and refresh the page and it gives me the option every time of the Logitech or the screen capture neither work

That 'screen capture' I believe is remnants of a program that I deleted.

I do have a second camera that I have had hooked up at the same time and I do believe then I get all 3 options

more options

jscher2000 said

Regarding the screenshots, I think you skipped a step:
(2) In the search box above the list, type or paste media*enable and pause while the list is filtered

Or you are looking in other places that may not be relevant. ??

Anyway, I don't have any other thoughts at the moment about why it might be blocked even with "Allow" permission.


Yes I was not on the right search. Thank you. I then did the right search media*enable and they were all default

more options

joseph501325 said

This prompt is the prompt you're referring to?

Yes, exactly - thank you  !

more options

Stab in the dark, but have you checked the Settings here (see screenshot) :

more options

jscher2000 said

One other thought, in case you have more than one "camera": If you change the permission back to Use default, do you get the permission prompt from Firefox when reloading the test page? If you do, does Firefox list the correct camera in the panel? I mean where my screenshot shows "Integrated Camera":


Yes, if you set it to Default Firefox will every time ask you to chose and I just hooked up my 2nd camera so now it gives me three options the Logitech, a Samsung and another Screen Capture Recorder which I believe is some left over software.

On the refresh Firefox will actually list the Screen Capture Recorder first and I know that isn't going to do anything for me so I chose the Logitech or now the Samsung. Both of these work on Chrome on this test page.

more options

Happy112 said

Stab in the dark, but have you checked the Settings here (see screenshot) :

Thank you, I'll give it a try, please tell me hoe to get to that page

more options

Happy112 said

Stab in the dark, but have you checked the Settings here (see screenshot) :

Here it is

more options

Solution choisie

joseph501325 said

Happy112 said
Stab in the dark, but have you checked the Settings here (see screenshot) :

Here it is


Glory over me the umteenth time I did for some reason it worked. I have no idea what is different

more options

joseph501325 said

Glory over me the umteenth time I did for some reason it worked.

Yay  ! It was about time - congrats  !

I have no idea what is different

Stephen King would love this .....

more options

joseph501325 said

jscher2000 said
Regarding the screenshots, I think you skipped a step:
(2) In the search box above the list, type or paste media*enable and pause while the list is filtered

Or you are looking in other places that may not be relevant. ??

Anyway, I don't have any other thoughts at the moment about why it might be blocked even with "Allow" permission.


Yes I was not on the right search. Thank you. I then did the right search media*enable and they were all default

I have no idea of what is different but it is working now. I sincerely appreciate the conversation. Thank you

more options

Happy112 said

joseph501325 said
Glory over me the umteenth time I did for some reason it worked.

Yay  ! It was about time - congrats  !

I have no idea what is different

Stephen King would love this .....


Thanks. I would love to mark this as solved but there isn't anything I can tell anyone concerning how it's been resolved. I know myself I wouldn't want to pull this page up for a nothing burger.

more options

joseph501325 said

I would love to mark this as solved but there isn't anything I can tell anyone concerning how it's been resolved. I know myself I wouldn't want to pull this page up for a nothing burger.

Just mark your own post (in which you say that it's working now) as the one that solved the problem - case closed.

Have fun with your camera(s)  !

more options

Happy112 said

joseph501325 said
I would love to mark this as solved but there isn't anything I can tell anyone concerning how it's been resolved. I know myself I wouldn't want to pull this page up for a nothing burger.

Just mark your own post (in which you say that it's working now) as the one that solved the problem - case closed.

Have fun with your camera(s)  !


Will do thank you

more options

Oops - you inadvertently marked my post as Chosen Solution ....

You can rectify that by clicking on the 'Undo' button and then mark one of your posts as Chosen Solution.

  1. 1
  2. 2
  3. 3