Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Quantum always starts with previous session, not with home page.

  • 4 réponses
  • 2 ont ce problème
  • 27 vues
  • Dernière réponse par jscher2000

more options

After I updated to Firefox Quantum, it no longer will start on my home page, but always starts with the tabs from my previous session. My "preferences" are set to open with my home page. I have tried several fixes that I have found on this forum and nothing works. NOTE: If I change my homepage, it still starts with the last session's tabs. If I set the preferences for "start with a blank page," it still starts with the tabs from the previous session. This problem has continued for two or three months now, beginning when Firefox updated to Quantum. NOTE: My Firefox is the latest version. NOTE: I am running Windows 10 Professional 64. Is there a fix for this problem?

Solution choisie

If it started two or three months ago, perhaps that was when you were still using Firefox 56.

Firefox 56 changed the file names of the session history files, and this caused this problem for users of CCleaner who had the default setting of cleaning browser session data. If you use CCleaner, try this update: https://www.piriform.com/news/release-announcements/2017/10

If you do not use CCleaner, two other things to investigate:

(1) Do you have an optional user.js file which contains an instruction to restore your previous session "once"? Unless the user.js file is removed, once becomes every time. There's a section on user.js files in this article: How to fix preferences that won't save.

(2) Firefox may be performing a crash recovery at startup. Does Firefox seem to be shutting down normally when you close the last window or use Exit from the menu?

You can change this setting to override automatic crash recovery at startup:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste sess and pause while the list is filtered

(C) Double-click the browser.sessionstore.max_resumed_crashes preference and lower the value from 1 to 0 (that's a zero) and click OK

Future crash recoveries should present the "this is embarrassing screen" letting you choose what windows (if any) to restore.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (4)

more options

Solution choisie

If it started two or three months ago, perhaps that was when you were still using Firefox 56.

Firefox 56 changed the file names of the session history files, and this caused this problem for users of CCleaner who had the default setting of cleaning browser session data. If you use CCleaner, try this update: https://www.piriform.com/news/release-announcements/2017/10

If you do not use CCleaner, two other things to investigate:

(1) Do you have an optional user.js file which contains an instruction to restore your previous session "once"? Unless the user.js file is removed, once becomes every time. There's a section on user.js files in this article: How to fix preferences that won't save.

(2) Firefox may be performing a crash recovery at startup. Does Firefox seem to be shutting down normally when you close the last window or use Exit from the menu?

You can change this setting to override automatic crash recovery at startup:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste sess and pause while the list is filtered

(C) Double-click the browser.sessionstore.max_resumed_crashes preference and lower the value from 1 to 0 (that's a zero) and click OK

Future crash recoveries should present the "this is embarrassing screen" letting you choose what windows (if any) to restore.

more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

After much misery I tracked down the user.js file. I was unable to open it, so I deleted it. Now Firefox opens to the home page as I want it to.

I just hope deleting the (tiny) user.js file won't do me harm down the road.

Thanks for the help.

more options

tgwWhale said

After much misery I tracked down the user.js file. I was unable to open it, so I deleted it. Now Firefox opens to the home page as I want it to.

Sorry, I should have mentioned that if you want to view its contents, you need to right-click > Edit, otherwise Windows will try to execute it.

I just hope deleting the (tiny) user.js file won't do me harm down the road.

Unless you created it yourself for a good reason, it's usually there for a bad reason...