Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

This PDF document contains forms. The filling of form fields is not supported. Using FoxIt

  • 3 réponses
  • 1 a ce problème
  • 20 vues
  • Dernière réponse par cor-el

more options

I am using Firefox 45.0.1 on Windows 7. When I open an Adobe PDF with form fields in Firefox I get the message, "This PDF document contains forms. The filling of form fields is not supported", along with a button: "Open with different viewer". If I click that button I get the option to open with FoxIt PhantomPDF 7.3; selecting that works fine.

However, I'd like not to get that message in the first place. When I go into Firefox > Options > Applications, I have 'Adobe Acrobat Forms Document', with action: 'Use Adobe Acrobat (in Firefox)'. The dropdown menu for actions does not list anything for FoxIt, nor is FoxIt listed under "Use other ...". Yet under content type 'FoxIt Phantom PDF PDDF Document' the action is 'Use FoxIt PhantomPDF Plug-in for Mozilla (in Firefox)".

So, why can't I select FoxIt as an action for PDF forms? How do I do this?

I am using Firefox 45.0.1 on Windows 7. When I open an Adobe PDF with form fields in Firefox I get the message, "This PDF document contains forms. The filling of form fields is not supported", along with a button: "Open with different viewer". If I click that button I get the option to open with FoxIt PhantomPDF 7.3; selecting that works fine. However, I'd like not to get that message in the first place. When I go into Firefox > Options > Applications, I have 'Adobe Acrobat Forms Document', with action: 'Use Adobe Acrobat (in Firefox)'. The dropdown menu for actions does not list anything for FoxIt, nor is FoxIt listed under "Use other ...". Yet under content type 'FoxIt Phantom PDF PDDF Document' the action is 'Use FoxIt PhantomPDF Plug-in for Mozilla (in Firefox)". So, why can't I select FoxIt as an action for PDF forms? How do I do this?
Captures d’écran jointes

Toutes les réponses (3)

more options

hi mark, does it make a difference when you go into the firefox menu > addons > plugins panel and set the foxit pdf plugin to "always activate"?

more options

Actually, I tried that and no, it does not make a difference. I did close and re-open Firefox after doing so.

more options

Sounds that the built-in PDF Viewer is used and not a plugin by default.

You can see on the about:plugins page what content (MIME) types a plugin supports.

If this plugin is added via an extension then try to uninstall the extension and check the about:config page for prefs used by this extension (e.g.e search for foxit).


Current Firefox versions come with a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of plugin.disable_full_page_plugin_for_types on the about:config page and remove application/pdf if present or reset the pref to the default via the right-click context menu if you want to display PDF documents in Firefox with another application (i.e. not the built-in PDF Viewer).

See also: