X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

All my pdf documents have turned into firefox html documents and will not open correctly

Publié

All my pdf documents have suddenly become firefox html docs & will not open unless I go into the folder, right click, 'open with', etc. I haven't changed any of my settings. I think firefox did an update yesterday, however, so I'm connecting it with that, possibly...

All my pdf documents have suddenly become firefox html docs & will not open unless I go into the folder, right click, 'open with', etc. I haven't changed any of my settings. I think firefox did an update yesterday, however, so I'm connecting it with that, possibly...

Solution choisie

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler...

Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader).

The other options described above and in other threads did not fix the problem for me.

Lire cette réponse dans son contexte 50

Détails additionnels sur le système

Plugins installés

  • Next Generation Java Plug-in 11.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 14.0 r0
  • Google Update
  • Picasa plugin
  • 5.1.30514.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • iTunes Detector Plug-in
  • Happy Cloud Web Plugin
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 31.0
  • Agent utilisateur : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • URL d’assistance : https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Extensions

  • Evernote Web Clipper 5.9.1 ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • Pin It button 1.1 (pinterest@robertnyman.com)
  • Pin It Button 1.32 (jid1-YcMV6ngYmQRA2w@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Youtube™ Search 1.0.5 (a000b9@wips.com)

JavaScript

  • incrementalGCEnabled : True

Accélération graphique

  • adapterDescription : Intel(R) HD Graphics 4000
  • adapterDescription2 :
  • adapterDeviceID : 0x0166
  • adapterDeviceID2 :
  • adapterDrivers : igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2 :
  • adapterRAM : Unknown
  • adapterRAM2 :
  • adapterVendorID : 0x8086
  • adapterVendorID2 :
  • direct2DEnabled : False
  • direct2DEnabledMessage : [u'blockedDriver']
  • directWriteEnabled : False
  • directWriteVersion : 6.2.9200.16571
  • driverDate : 4-18-2012
  • driverDate2 :
  • driverVersion : 8.951.9.3000
  • driverVersion2 :
  • info : {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active : False
  • numAcceleratedWindows : 1
  • numTotalWindows : 1
  • webglRenderer : Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote : False
  • windowLayerManagerType : Direct3D 9

Préférences modifiées

  • accessibility.typeaheadfind.flashBar : 0
  • browser.cache.disk.capacity : 358400
  • browser.cache.disk.smart_size.first_run : False
  • browser.cache.disk.smart_size.use_old_max : False
  • browser.cache.disk.smart_size_cached_value : 358400
  • browser.cache.frecency_experiment : 2
  • browser.places.smartBookmarksVersion : 7
  • browser.search.useDBForOrder : True
  • browser.sessionstore.upgradeBackup.latestBuildID : 20140716183446
  • browser.startup.homepage_override.buildID : 20140716183446
  • browser.startup.homepage_override.mstone : 31.0
  • dom.mozApps.used : True
  • dom.w3c_touch_events.expose : False
  • extensions.lastAppVersion : 31.0
  • font.internaluseonly.changed : True
  • font.name.serif.x-western : Calisto MT
  • network.cookie.prefsMigrated : True
  • places.database.lastMaintenance : 1406533881
  • places.history.expiration.transient_current_max_pages : 104858
  • plugin.disable_full_page_plugin_for_types : application/pdf
  • plugin.importedState : True
  • privacy.sanitize.migrateFx3Prefs : True
  • security.warn_viewing_mixed : False
  • storage.vacuum.last.index : 1
  • storage.vacuum.last.places.sqlite : 1405071539

Divers

  • JS utilisateur : Non
  • Accessibilité : Non
Sourjobraato Banerjee 14 solutions 232 réponses

First view your .pdf file with firefox. Then at opening select the "Better view" in the top the page and choose your pdf file viewer software. It is more easy then firefox pdf viewer.

First view your .pdf file with firefox. Then at opening select the "Better view" in the top the page and choose your pdf file viewer software. It is more easy then firefox pdf viewer.

Auteur de la question

sorry, it's not the pdf's in firefox/ on the internet, it's the pdfs already on my pc (in my documents, etc.). They won't open normally.

sorry, it's not the pdf's in firefox/ on the internet, it's the pdfs already on my pc (in my documents, etc.). They won't open normally.
Moses
  • Moderator
459 solutions 3608 réponses

Réponse utile

Try this:

  1. Right click your PDFs, click Properties
  2. Go to the General tab
  3. In the Opens with section, click the Change button
  4. Select Adobe Reader (or Foxit Reader/Whatever PDF viewer you use)
  5. Click Apply then OK.

Does it work then?

Try this: # Right click your PDFs, click Properties # Go to the General tab # In the '''Opens with''' section, click the ''Change'' button # Select Adobe Reader (or Foxit Reader/Whatever PDF viewer you use) # Click Apply then OK. Does it work then?

Auteur de la question

Thanks moses! that fixed it. Don't know why it did it to begin with, but it's fixed now.

Thanks moses! that fixed it. Don't know why it did it to begin with, but it's fixed now.
Pharteon 1 solutions 4 réponses

Solution choisie

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler...

Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader).

The other options described above and in other threads did not fix the problem for me.

This happened to me as well. You need to reassign Adobe Acrobat or Adobe Reader as the default PDF handler... Open up Adobe Reader (not Acrobat, if you have it on your system); go to "Edit", "Preferences", "General"; at the bottom of the General settings screen to the right "Select Default PDF Handler"; pull down and choose the PDF handler (e.g., Adobe Acrobat or Adobe Reader). The other options described above and in other threads did not fix the problem for me.
asexe 0 solutions 8 réponses

Hi. I had this problem myself two times no, it`s not a problem to fix this as I just change it to adobe reader. But why does this keep on happening? is there a way to prevent it?

Hi. I had this problem myself two times no, it`s not a problem to fix this as I just change it to adobe reader. But why does this keep on happening? is there a way to prevent it?