Modernisation de la technologie des modules pour Firefox

Les modules complémentaires vous permettent d’ajouter des fonctionnalités à Firefox, d’en modifier l’interface ou encore d’en changer l’apparence. Il existe plusieurs types de modules, mais les plus courants sont les extensions. N’importe qui peut créer une extension et la mettre à disposition des personnes qui voudraient la télécharger.

Souvent auparavant, les extensions ne fonctionnaient plus après chaque sortie d’une nouvelle version de Firefox, car les développeurs et développeuses devaient les mettre à jour toutes les six semaines pour conserver leur compatibilité. Par ailleurs, les extensions pouvant également modifier directement le code interne de Firefox, des personnes malintentionnées pouvaient inclure du code malveillant dans une extension apparemment innocente.

Pour résoudre ces problèmes, et dans le cadre d’efforts plus larges pour moderniser Firefox dans son ensemble, nous sommes passés à une nouvelle plateforme pour développer des extensions pour Firefox. Les extensions créées selon le nouveau standard sont plus sûres, mieux sécurisées et continuent de fonctionner à chaque nouvelle version de Firefox. Vous pouvez toujours personnaliser Firefox avec des extensions comme vous le faites maintenant, sauf qu’elles ne deviennent pas obsolètes dans les nouvelles versions de Firefox.

Note : depuis Firefox 57, version sortie le 14 novembre 2017, seules les extensions développées avec cette nouvelle technologie fonctionnent dans Firefox. La plupart des modules populaires sont déjà compatibles, par conséquent la plupart des utilisateurs et utilisatrices ne devraient pas constater de changements.

Si des extensions non compatibles sont installées, cela est montré dans le gestionnaire de modules complémentaires. Cliquez sur le bouton de menu New Fx Menu et sélectionnez Modules complémentaires (ou saisissez « about:addons » dans un nouvel onglet) pour ouvrir le gestionnaire de modules complémentaires. Toutes les extensions incompatibles sont listées dans le panneau Extensions obsolètes. À partir de cette page, des extensions recommandées vous sont proposées pour remplacer toutes les extensions obsolètes. panneau Extensions sous Désactivé sans l’option Activer. Vous pouvez en apprendre davantage sur cette fonctionnalité en lisant ce billet de blog à propos des modules.

// Ces formidables personnes ont aidé à écrire cet article :Goofy, Mozinet, Imen, Cécile, user1378574, YD, lala. Vous pouvez également aider — découvrez comment.

Cet article vous a-t-il été utile ? Veuillez patienter…

Devenir bénévole pour l’assistance de Mozilla