La mise à jour vers Firefox 3 m’a fait perdre mes marque-pages et d’autres données

Cet article n'est plus maintenu. Par conséquent, son contenu pourrait ne plus être à jour.

Avertissement : Cet article ne s'applique qu'aux utilisateurs de Firefox 2.0 qui ont perdu leurs marque-pages immédiatement après la mise à jour vers Firefox 3.0 ou Firefox 3.5. Si vous avez perdu vos marque-pages à tout autre moment, consultez Récupérer les marque-pages perdus ou absents.

Le suivi de la procédure ci-dessous entraînera la perte de tous les marque-pages ajoutés dans Firefox 3.0 ou Firefox 3.5.

Si vous utilisez une pré-version de Firefox 3 et que vous revenez à Firefox 2, vous pouvez trouver que vous avez une ancienne version de marque-pages ou de mots de passe quand vous mettez à jour vers Firefox 3. Firefox 3 n'importe qu'une fois vos données de Firefox 2 ; et à partir de ce moment, utilise les données en format Firefox 3. Parce que vous avez utilisez une pré-version de Firefox 3, vous avez déjà les données en format Firefox 3 ; ce qui est ce que votre dernière installation de Firefox utilisera.


Pour retrouver vos paramètres de Firefox 2 :

  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

    • Marque-pages et historique : Renommez le fichier places.sqlite en places.sqlite.bak et les fichiers .json dans le dossier bookmarkbackups en .json.bak.
    • Mots de passe : Renommez signons3.txt en signons3.txt.bak.
Note : Si l'extension de fichier .txt n'est pas affichée, renommez signons3 en signons3bak
  1. Démarrez Firefox de nouveau.

Vous devriez ainsi migrer vos données de Firefox 2 vers Firefox 3. Si cette procédure ne fonctionne pas et que vous n'arrêtez pas de perdre des données, vous pouvez les restaurer en fermant Firefox de nouveau et en renommant ces fichiers à leur valeurs précédentes.

Ces formidables personnes ont aidé à écrire cet article : lorenzoalali, scoobidiver. Vous pouvez également aider - découvrez comment.