Showing questions tagged: Show all questions

Using Node Express-Sessions to set cookie "httpOnly: true, secure: true, SameSite: "None" FF blocks authorization

My web site My web site allows user to login with .ejs Sign-up/Sign-in pages then delivers a React page. This works in Chrome and Safari. Https/SSL are provided by my ho… (read more)

My web site My web site allows user to login with .ejs Sign-up/Sign-in pages then delivers a React page. This works in Chrome and Safari. Https/SSL are provided by my host A2Hosting.

Firefox warns "Cookie “connect.sid” does not have a proper “SameSite” attribute value" when the cookie is set and then blocks the react page after login. If I enter the route that leads to the react page directly I can login and don't get the warning. In both cases the Storage tab in Dev tools shows the same settings for the cookie.
I made sure to remove any cookies for my site before testing the second scenario. I have tested this on Windows, Linux and Android versions of Firefox with the same results.

Here is my Express-Session instantiation ``` app.use(expressSession({

 store: new pgSession({
   pool: pool,
   tableName: 'session'
   // Insert connect-pg-simple options here
 }),
 secret: process.env.SECRET,
 resave: false,
 saveUninitialized: false,

cookie: {

   httpOnly: true,
   Secure: true,
   SameSite: "None",
   path: ['/'],
   maxAge: 60 * 60 * 1000 * 5
 }
 // Insert connect-pg-simple options here

})) ``` I've tried changing the path to include the react app route, I've added it to Cors white list and I converted it to open with an .ejs file instead of .html with no results.

Thanks for your support and for a great browser

Asked by rich.rhaskell 22 ساعت قبل

Last reply by jscher2000 - Support Volunteer 18 ساعت قبل

Webpage keeps saying "The page was not displayed because the request entity is too large."

Whenever I try to load up the https://edfinancial.studentaid.gov/welcome login page, I keep getting a white page with "The page was not displayed because the request enti… (read more)

Whenever I try to load up the https://edfinancial.studentaid.gov/welcome login page, I keep getting a white page with "The page was not displayed because the request entity is too large." I was wondering if anyone had any idea on how to fix it so I can look at my student loans.

Asked by Timber 2 روز قبل

Last reply by cor-el 2 روز قبل

vertical lines for some graphics

Hi. I am getting vertical lines sometimes. I have included two screen shots. I have checked browser.display.document_color_use = 0, and it was zero. I have tired this in … (read more)

Hi. I am getting vertical lines sometimes. I have included two screen shots. I have checked browser.display.document_color_use = 0, and it was zero. I have tired this in Chrome and it works fine. And I tried in Firefox safe mode, and it still does these strange lines on some websites. I am running Windows 10, and have no other graphic issues except these lines. Websites are Windy.com and google maps. Thanks very much! James

Asked by jamescollier3 5 روز قبل

Last reply by cor-el 3 روز قبل

im being redirected to the mobile site of my game.

ok what im having issues with is is kixeye.com.... instead of this site it keeps going to https://m.kixeye.com/. instead of www.kixeye.com. there is no option to chang… (read more)

ok what im having issues with is is kixeye.com.... instead of this site it keeps going to https://m.kixeye.com/. instead of www.kixeye.com. there is no option to change it to the desktop site like when im on my phone

any help rectifying this would be a great help

Asked by G G (Waspire) 6 روز قبل

Last reply by cor-el 5 روز قبل

DeveloperCommunity.visualstudio.com site not displaying content

When I try to access Developer Community from Visual Studio 2022 ('Send feedback' 'report a problem') the banner displays with selection items but no content is displayed… (read more)

When I try to access Developer Community from Visual Studio 2022 ('Send feedback' 'report a problem') the banner displays with selection items but no content is displayed. This has been a problem for several months (years maybe). I now have a problem that I cannot solve and I need to report it and I cannot if content is not displayed.

Asked by LeeRossCritchlow 5 روز قبل

Last reply by cor-el 5 روز قبل

When i click ctrl only ctrl on any tab its makes it smaller

When i click ctrl only ctrl its maeks tab smaller like ctrl + - but i only press ctrl also when i hold scroll i can smooth surf the tab now it dont work what i have to do… (read more)

When i click ctrl only ctrl its maeks tab smaller like ctrl + - but i only press ctrl also when i hold scroll i can smooth surf the tab now it dont work what i have to do?

Asked by harryharry1238 1 ماه قبل

Last reply by cor-el 5 روز قبل

mylotto.co.nz is blocking Firefox browser and has been for months

The website mylotto.co.nz has been blocking Firefox for many months now and when I rang them to find out what the problem is they just say they are having problems but it… (read more)

The website mylotto.co.nz has been blocking Firefox for many months now and when I rang them to find out what the problem is they just say they are having problems but it was obvious that the person there was reading a script and fobbing me off. This has been going for many months now a problem would have been fixed by now. I would like to know if you can bring pressure to bear on them to get reinstated again. I have attached a screenshot of the message from their site. Thanking you. Murray

Asked by murjan5 1 هفته قبل

Last reply by TyDraniu 1 هفته قبل

Videos darkened and washed out, pictures normal

I've been banging my head against a wall trying to figure this one out. Every time a video plays on youtube, reddit, etc it will show normal colors for a split second the… (read more)

I've been banging my head against a wall trying to figure this one out. Every time a video plays on youtube, reddit, etc it will show normal colors for a split second then it will darken it and wash out the colors. Not sure what is causing this.

Things I've tried: gfx.color_management.native_srgb to true in about:config Changing video settings in nvidia control panel Turning off hardware acceleration Restarting browser and PC Updating browser and video drivers, windows as well Turning off all extensions Trying with codecs both deactivated and reactivated

No other browser does this and ALSO when I run firefox in private mode it doesn't happen and videos run normally. Also when I try to record or take a screenshot of it it looks normal. Thank you for any assistance.

Asked by larrylivin1922 6 روز قبل

Last reply by jonzn4SUSE 6 روز قبل

One site blank in Linux FF but not in Windows FF

https:\\archive.org works perfectly in Firefox on Win-10, but on a new Linux Mint install, (with default Firefox as included), this particular website simply displays as… (read more)

https:\\archive.org works perfectly in Firefox on Win-10, but on a new Linux Mint install, (with default Firefox as included), this particular website simply displays as a blank white screen. Every other website I try on the Linux install works perfectly; it is only this one website which does not work.

There are no add-ons, no proxies, no security suites, nothing extra. I cleared all cookies and cache. Tried running FF in Protected Mode. Nothing seems to fix it.  There are no error messages displayed - just a blank white screen.

And, to make it worse, I am not particularly computer-literate, (I'm 82 years old...), so you will have to give me simple guidance if I need to get involved with deeper logging etc.

Asked by dmaxwell1 1 هفته قبل

Last reply by jonzn4SUSE 1 هفته قبل

126.0.1 (64-bit) so many problems

I have been using Firefox for years without any problem but 126.0.1 (64-bit) is making me to consider stopping it. I am having issues playing live cams, getting some webs… (read more)

I have been using Firefox for years without any problem but 126.0.1 (64-bit) is making me to consider stopping it. I am having issues playing live cams, getting some websites running properly, authentication issues, etc...etc..

Why?

Asked by aramartis 1 هفته قبل

Last reply by jonzn4SUSE 1 هفته قبل

Firefox Can’t Open This Page

When I try to open a what may be a link in a page, which should bring up a PDF file, I think, I get the following: Firefox Can’t Open This Page To protect your securit… (read more)

When I try to open a what may be a link in a page, which should bring up a PDF file, I think, I get the following:


Firefox Can’t Open This Page

To protect your security, api.medicare.gov will not allow Firefox to display the page if another site has embedded it. To see this page, you need to open it in a new window.

Learn more…

When I click on the Open Site in new Window button I get a new window with the following:


message "Unauthorized" context {} code null

Asked by kurt_matthys 1 هفته قبل

Last reply by jscher2000 - Support Volunteer 1 هفته قبل

website blocked by script execution error

Website loaded without any problems for months until I get this error message out of the blue; see screenshot below. Did try Java toggle on-off extension but the options… (read more)

Website loaded without any problems for months until I get this error message out of the blue; see screenshot below.

Did try Java toggle on-off extension but the options button is not displayed on the extension that would have enabled me to enter URL of site in blacklist text box.

Asked by J D 1 هفته قبل

Last reply by cor-el 1 هفته قبل

My website is shown as insecure. If I open it with Chrome, it is okay. If my girlfriend opens it from her computer with firefox, it is okay too. What is wrong here?

My website is shown as insecure. If I open it with Chrome, it is okay. If my girlfriend opens it from her computer with firefox, it is okay too. What is wrong here? … (read more)

My website is shown as insecure. If I open it with Chrome, it is okay. If my girlfriend opens it from her computer with firefox, it is okay too. What is wrong here?

Asked by smerdja 1 هفته قبل

Last reply by cor-el 1 هفته قبل

Images disappear

Images and graphical elements (even the checkmark or the confirm image at the bottom of this thread creation page) disappear when scrolling down. This started after today… (read more)

Images and graphical elements (even the checkmark or the confirm image at the bottom of this thread creation page) disappear when scrolling down. This started after today's update. I've tried creating a new profile, troubleshooting mode, disabling hardware acceleration, disabling dark reader, changing the windows override settings to NEVER - NONE OF IT WORKED!! I'm getting really ticked-off by this crap! Didn't have this problem until the newest "great" update!

Asked by Brendan R 2 هفته قبل

Last reply by cor-el 2 هفته قبل

can't access product site promoted by google due to googleadservices 'unable to connect'

Tell me why google says this: Unable to connect An error occurred during a connection to www.googleadservices.com. The site could be temporarily unavailable or too … (read more)

Tell me why google says this:

Unable to connect

An error occurred during a connection to www.googleadservices.com.

   The site could be temporarily unavailable or too busy. Try again in a few moments.
   If you are unable to load any pages, check your computer’s network connection.
   If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the web.

when I click on an advert for a product provided (I assume) by google at the top of search results. I have cleared the cache and cookies. Latest firefox on ubuntu 22.

Asked by geoff07 2 هفته قبل

Last reply by jonzn4SUSE 2 هفته قبل

Cloudflare is not allowing me to use your browser

CloudFlare is not allowing me to use Firefox for a host of sites that I routinely use, such as my bank, Credit Union 1. I have tried repeatedly and will not recognize my … (read more)

CloudFlare is not allowing me to use Firefox for a host of sites that I routinely use, such as my bank, Credit Union 1. I have tried repeatedly and will not recognize my computer so I have to use Chrome to get through.

They are locking me out as a spammer because I am using Firefox. Whats up with that?????

Asked by joyofjoe 2 هفته قبل

Last reply by cor-el 2 هفته قبل