Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with printing in Firefox web browser

  • 7 پاسخ
  • 0 have this problem
  • 1 view
  • آخرین پاسخ توسّط zeroknight

more options

Hi, i have a problem with printing pdf in firefox. I have no option with orientation (rotation) only on pdf opened in web browser. On another site i can change rotation normal. In microsoft edge for example there is option with orientation on pdfs

Hi, i have a problem with printing pdf in firefox. I have no option with orientation (rotation) only on pdf opened in web browser. On another site i can change rotation normal. In microsoft edge for example there is option with orientation on pdfs
Attached screenshots

All Replies (7)

more options

Try changing print.save_as_pdf.use_page_rule_size_as_paper_size.enabled to false in about:config then restart the browser.

more options

It still not working. The problem is only on my page. The default option with orientation is vertical on every pdf but on my site when the pdf is generated the orientation is horizontal

more options

Do you have the option to print from system dialog? see screenshots Provide a link to your page so we can try to replicate.

more options

i have only these options after clicking system dialog :/

more options

I don't see your printer. Click your printer and then maybe Preferences. I'm currently not in Windows.

more options

thats the point. When i want to change somethink in preferences the value of atribute will change but only in this session. After restarting window from browser these all settings change to default

more options

tobiasz.schoenberg said

The problem is only on my page.

Can you link to the page? Open the Style Editor (Shift+F7) and search for @page, this will dictate the page orientation.