Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Opens to Blank Page

  • 2 پاسخ
  • 0 have this problem
  • 39 views
  • آخرین پاسخ توسّط latest fashion

more options

I am running Firefox-112.0(64bit) on Debian Bullseye. When I pend Firefox I am presented with a blank page rather that my normal sign in page.

Opening a terminal window and starting Firefox with /opt/firefox/firefox generates the following errors:

comp@AbNormal:~$ /opt/firefox/firefox [GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. [ERROR glean_core] Error setting metrics feature config: Json(Error("EOF while parsing a value", line: 1, column: 0))

If I enter a URL the page opens and is usable.

How can this problem be fixed?

Thanks in advance.

I am running Firefox-112.0(64bit) on Debian Bullseye. When I pend Firefox I am presented with a blank page rather that my normal sign in page. Opening a terminal window and starting Firefox with /opt/firefox/firefox generates the following errors: comp@AbNormal:~$ /opt/firefox/firefox [GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. [ERROR glean_core] Error setting metrics feature config: Json(Error("EOF while parsing a value", line: 1, column: 0)) If I enter a URL the page opens and is usable. How can this problem be fixed? Thanks in advance.

All Replies (2)

more options

What do you have set here for new window? see screenshot What happens when you run these commands? firefox http://www.google.com firefox --new-tab 'http://www.toyota.com'

This is what I get when running from the cmd line. see screenshot

more options

The error message you provided indicates that there might be an issue with Firefox's graphics rendering. Here are a few steps you can try to fix the issue:

  • Reset Firefox preferences:

You can reset Firefox preferences to the default settings by typing "about:support" in the address bar and clicking on the "Refresh Firefox" button. This will reset all settings to their default values, including your home page.

  • Disable hardware acceleration:

Firefox uses hardware acceleration to improve the browser's performance. However, it can sometimes cause issues with certain graphics cards. To disable hardware acceleration, go to the Firefox menu, select "Preferences," then click on "General." Scroll down to the "Performance" section and uncheck the box that says "Use recommended performance settings." Then, uncheck the box that says "Use hardware acceleration when available."

  • Update graphics drivers:

Make sure your graphics drivers are up to date. Visit the website of your graphics card manufacturer to download and install the latest drivers. I believe Firefox is the king of the browsers.

  • Reinstall Firefox:

If none of the above steps work, you can try reinstalling Firefox. To do this, first, remove Firefox from your system by running the following command in the terminal:


sudo apt-get remove firefox

Then, download the latest version of Firefox from the Mozilla website and install it on your system.

I hope this helps you fix the issue.

smolnar said

I am running Firefox-112.0(64bit) on Debian Bullseye. When I pend Firefox I am presented with a blank page rather that my normal sign in page. Opening a terminal window and starting Firefox with /opt/firefox/firefox generates the following errors: comp@AbNormal:~$ /opt/firefox/firefox [GFX1-]: glxtest: VA-API test failed: no supported VAAPI profile found. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. [ERROR glean_core] Error setting metrics feature config: Json(Error("EOF while parsing a value", line: 1, column: 0)) If I enter a URL the page opens and is usable. How can this problem be fixed? Thanks in advance.

Modified by Magnolia