Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to get my videos to appear?

more options

Yesterday the videos still appear fine, but today when I turn on my computer, the websites where I watch TV shows episodes on won't appear their videos but instead of a white/black video box. Youtube videos still works fine, but others won't appear. I tried watching it on Opera, and it plays fine. Please help.

Yesterday the videos still appear fine, but today when I turn on my computer, the websites where I watch TV shows episodes on won't appear their videos but instead of a white/black video box. Youtube videos still works fine, but others won't appear. I tried watching it on Opera, and it plays fine. Please help.

All Replies (1)

more options

Do you know which plugin the sites use to display video? Usually if you click the "Lego"-like icon in the address bar, Firefox will mention which one it is and whether it is currently "allowed" or not.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?