Showing questions tagged: Show all questions
  • Archived

Firefox tries to download php files

Hi I'm running a MAMP PRO installation on my OS X 11.6 which works perfectly (Apache & MYSQL). All of a sudden Firefox asks for download when browising to a .php file… (read more)

Hi

I'm running a MAMP PRO installation on my OS X 11.6 which works perfectly (Apache & MYSQL). All of a sudden Firefox asks for download when browising to a .php file on my localhost. Could anybody give me a hint on why this happesn?

Thanks, Tom

Asked by tcgass 1 year ago

Last reply by Roland Tanglao 1 year ago

  • Archived

animate.css doesn't work in my firefox

I don't understand why animate.css doesn't work in my firefox. Where can be problem? In firefox on another pc animate.css is working. animate.css - https://daneden.github… (read more)

I don't understand why animate.css doesn't work in my firefox. Where can be problem? In firefox on another pc animate.css is working. animate.css - https://daneden.github.io/animate.css/

Asked by tomcatsk 1 year ago

Last reply by cor-el 1 year ago

  • Archived

FF keeps rendering text in BOLD instead of the font-weight set in CSS. Anyone else having this issue?

I'm having this issue in Firefox where it's rendering all of the Google fonts on two websites I've created as BOLD instead of THIN or REGULAR or whatever else they're set… (read more)

I'm having this issue in Firefox where it's rendering all of the Google fonts on two websites I've created as BOLD instead of THIN or REGULAR or whatever else they're set to in the CSS. I've found many instances online of users reporting this and similar issues over the past few years and have tried a number of solutions. Adding the following code as "extra CSS" to the Wordpress theme is the only thing that fixes it:

html { -moz-osx-font-smoothing: grayscale; -webkit-font-smoothing: antialiased; font-smoothing: antialiased; }

Yet adding this code has caused other rendering issues on the site. Both sites I'm having this issue on look fine in Chrome and Safari btw. I've troubleshooted by clearing my caches, disabling the few plugins I have installed and switched to different WP themes by different developers but the problem persists. I tried changing FF settings too... disabling plugins and add-ons, switched themes and turned off hardware acceleration to no avail. It should be noted I don't notice this on random sites I visit, just these that I've created using Wordpress. Checking another site I created by hand coding the Google fonts render fine.

Attached are two examples of the issue. First is the correct rendering, second is the incorrect BOLD rendering of the same text. Any thoughts anyone?

Asked by o-o--LOKI--o-o 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Are Firefox and Aptana divorced?

Hello. I have been trying to get the Firefox debugger to hook up with the Aptana editor. The instructions that I have are obsolete. The link http://firefox.aptana.com/upd… (read more)

Hello. I have been trying to get the Firefox debugger to hook up with the Aptana editor. The instructions that I have are obsolete. The link http://firefox.aptana.com/update/ is supposed to automatically download the extension. It just takes me to a search engine results page full of links that barely touch on the subject. I also found out the Firebug has been deprecated.

Question: Are Firefox and Aptana divorced? Is there still a way to combine the Aptana editor to the Firefox debugger?

Asked by GailRoma 1 year ago

Last reply by Shadow110 1 year ago

  • Archived

H264 video codec by cisco

Hi I am using the latest firefox version on windows 10. After the installation, I am not able to see h264 cisco codec getting enabled. I searched on the internet and fou… (read more)

Hi

I am using the latest firefox version on windows 10. After the installation, I am not able to see h264 cisco codec getting enabled. I searched on the internet and found that there were few issues in the earlier releases but later they were fixed.

But on the current release I still see the problem

Can you please help to resolve the issue?

Many thanks in advance Pankaj Hirlekar

Asked by pankajh1811 1 year ago

Last reply by James 1 year ago

  • Archived

Unable to connect to localhost aliased sites

On my dev system (windows), I have an apache server and a number of sites defined. They are listed in the hosts file and also configured in httpd-vhosts.conf. I have had … (read more)

On my dev system (windows), I have an apache server and a number of sites defined.

They are listed in the hosts file and also configured in httpd-vhosts.conf.

I have had to stay with an old version of Firefox for the last few years, as more recent versions refused to connect to the localhost sites. I have been "forced" to upgrade and am nolonger able to connect to the local sites. I precise that doing a ping to the site address will return the 127.0.0.1 address.

What do I have to do to get this important functionality working again, please ?

Asked by Simon_Giddings 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Mozilla developer docs question

Can someone tell me what Edge 14 means? What is 14? I mean Microsoft Edge version numbers are 38, 40 etc. My Edge version is 38.14393.0.0 So what exactly is Edge 14??… (read more)

Can someone tell me what Edge 14 means? What is 14? I mean Microsoft Edge version numbers are 38, 40 etc. My Edge version is 38.14393.0.0 So what exactly is Edge 14???

Asked by kenw232 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Firefox does not ask you to save your login and password.

In site: https://mbok.pgnig.pl/ Firefox not option save login and password. Not option for save. This is bug Firefox? … (read more)

In site: https://mbok.pgnig.pl/ Firefox not option save login and password. Not option for save. This is bug Firefox?

Asked by boruts 1 year ago

Last reply by cor-el 1 year ago

  • Archived

Stripping AJAX data from the browser.

Greetings, Is it possible to get data from a browser that was sent from a server that is directly connected to a Windows tablet in HotSpot mode? I purchased a BBQ temper… (read more)

Greetings, Is it possible to get data from a browser that was sent from a server that is directly connected to a Windows tablet in HotSpot mode? I purchased a BBQ temperature controller that sends temperature and alarm status to a browser via Wi-Fi. I want to trigger an audible event based on that data (which the unit does not do). I do not know how, or if it is even possible to extract that data from the browser. Would this be possible using Firefox? Thank you.

Asked by hersh01 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Border and Outline are overlapping

In my MTML code I have in the style section .RB td {outline:medium solid red;border:10px solid white;} According to the definitions the outside of the table cell sho… (read more)

In my MTML code I have in the style section

   .RB td  {outline:medium solid red;border:10px solid white;}

According to the definitions the outside of the table cell should be red and the inside should be white. However, the border seems to be on both sides of the outline. To see what is happening look at https://freedom-press-alliance.us/ For what it is worth, Edge has the same problem.

Asked by Col_Boogie 1 year ago

Last reply by cor-el 1 year ago

  • Archived

Why does my GWT application no longer work using version 67?

After upgrading to firefox 67, we sometimes have problems with our GWT based web applications. The error is listed below. The error prevents our application from starting… (read more)

After upgrading to firefox 67, we sometimes have problems with our GWT based web applications. The error is listed below. The error prevents our application from starting.

The exact same application works fine on Chrome, it works fine in older versions of Firefox and it also works fine in the latest beta of Firefox 68 (b5).

The error is:

SEVERE: Uncaught Web UI exception java.lang.NullPointerException: TypeError: a.AE is not a function at Unknown.Rvw(webui-0.js) at Unknown._4c(webui-0.js) at Unknown.M8o(webui-0.js) at Unknown.J8o(webui-0.js) at Unknown.K8o(webui-0.js) at Unknown.z8o(webui-0.js) at Unknown.F8o(webui-0.js) at Unknown.O7o(webui-0.js) at Unknown.mig(webui-0.js) at Unknown.g(webui-0.js) at Unknown.xq(webui-0.js) at Unknown.Aq(webui-0.js) at Unknown.zq/<(webui-0.js) at Unknown.cig(webui-0.js) at Unknown.anonymous(webui-0.js) at Unknown.m(https://legu-test.stibo.com/webui/webui/webui.nocache.js) at Unknown.onScriptDownloaded/<(https://legu-test.stibo.com/webui/webui/webui.nocache.js) at Unknown.d(https://legu-test.stibo.com/webui/webui/webui.nocache.js) at Unknown.anonymous(Unknown)

Asked by jtpe 1 year ago

Last reply by jscher2000 1 year ago

Firefox geolocation returns wrong coordinates

I want to build a progressive web app. This app requires the user's GPS coordinates. In order to test this functionality cross-browser, I use w3schooll geolocation implem… (read more)

I want to build a progressive web app. This app requires the user's GPS coordinates. In order to test this functionality cross-browser, I use w3schooll geolocation implementation. Link: https://www.w3schools.com/html/tryit.asp?filename=tryhtml5_geolocation

Compared to Chrome, Firefox sometimes returns the wrong coordinates. For example yesterday (13/03/2020) the coordinates were wrong all day. Today (14/03/2020) the coordinates are right. The coordinates are crucial for the success of the app. I use Firefox 74.0

Asked by Sergiu Mare 3 months ago

Last reply by cor-el 3 months ago

  • Archived

Firebox is loading old css

I am updating some css code on my Wordpress website. When I update the code I see the change on all internet browsers EXCEPT for Firefox. I know all about emptying cache … (read more)

I am updating some css code on my Wordpress website. When I update the code I see the change on all internet browsers EXCEPT for Firefox. I know all about emptying cache and cookies and history and that is not it. I have opened the website on computers that have never even been to the site and it is still pulling my old css code! Now, I was making some changes last night and Firefix wasn't updating the ocde, but when I looked at it this morning the changes were there. Does the changes take longer to reach FIrefox browsers or something? I am not the MOST savvy web designer, hence the Wordpress website, but I have changed my css code a thousand times and I always see the updates on other browsers. Please let me know if it is a "delay" thing with changes to Firefox or if I need to add some sort of special Firefox code to the css.

Appreciate the help and I apologize if I am just a missing something easy.

Asked by believememoore 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Screenshoot in responsive mode

If you use "Take a screenshoot" while debuging in responsive mode, the screenshoot ui tries to fit inside the responsive window. If you debugging a small device, the ui i… (read more)

If you use "Take a screenshoot" while debuging in responsive mode, the screenshoot ui tries to fit inside the responsive window. If you debugging a small device, the ui is to large to fit.

Asked by puggan 1 year ago

Last reply by Shadow110 1 year ago

  • Archived

What do cookie permission values mean in permissions.sqlite?

I want to export my cookie permissions either through a WebExtension or a script outside of Firefox. I'm looking at the `moz_perms` table in my permissions.sqlite, and I … (read more)

I want to export my cookie permissions either through a WebExtension or a script outside of Firefox.

I'm looking at the `moz_perms` table in my permissions.sqlite, and I see three values for `permission` for entries of `type` "cookie":

  • 1: Keep cookies permanently
  • 2: Block all cookies
  • 8: Keep cookies for session

As I review the Firefox codebase, I see the following in nsIPermissionManager.idl:

 const uint32_t EXPIRE_NEVER = 0;
 const uint32_t EXPIRE_SESSION = 1;
 const uint32_t EXPIRE_TIME = 2;
 const uint32_t EXPIRE_POLICY = 3;

Obviously, that doesn't match up at all, so I'm probably looking at the wrong thing. I've been a user of Self-destructing cookies if that makes any difference.

Where can I find code or documentation on meaning of the `permission` field for entries of `type` "cookie" in the `moz_perms` table of permissions.sqlite? Is there a better or existing means of exporting cookie settings like this?

Asked by sondrak 1 year ago

Last reply by cor-el 1 year ago

When I try to select text in a box it moves me to the next tab in my products database.

Apparently the database is built in Joomla and PHP. The developer says it must be a browser issue as it doesn’t happen for him. Also it doesn’t happen for me in Google C… (read more)

Apparently the database is built in Joomla and PHP. The developer says it must be a browser issue as it doesn’t happen for him. Also it doesn’t happen for me in Google Chrome. I am attaching a screen grab.

Asked by alex114 4 months ago

Last reply by Roland Tanglao 4 months ago

Open the payload of a HTTP error

I'm a software developer working on backend services, always juggling between Firefox and Chrome (because none of them fully satisfy my needs). What I need from them is t… (read more)

I'm a software developer working on backend services, always juggling between Firefox and Chrome (because none of them fully satisfy my needs). What I need from them is to behave the way it will be most practical for me, which isn't necessarily aligned with the majority of users.

My current problem is this. I work with APIs which in my daily work often return various HTTP errors. These errors also contain a payload which describes the problem in detail. I want to be able to see this payload easily in the browser. Yes, I can use other tools like Postman for this (which I do), but for simple GET requests without special request headers it would be much more practical to just use a browser.

Currently, when my API opens an error (for example a 400 Bad Request), Firefox decides to just silently go back into the previous page (undos the URL change). If I open the Network tab in the Web Developer view, I can however see the failing response with all of its details. Still, this is too impractical for me.

BTW, the response contains a custom Content-Type which isn't recognized by Firefox by default. But Firefox isn't downloading the payload as a file (like it would usually do for a successful page load of an unknown Content-Type), it just silently doesn't do anything. I've installed an extension to handle my custom Content-Types (called "Open in Browser"), but since Firefox isn't attempting to open this one, I can't use it in this case.

So, how can I force Firefox to stay on that URL and show the response payload in the window? If not in vanilla Firefox, any plugins? I've already kind of spent too much time on this for my liking. :/

Asked by marko.vodanovic 1 month ago

Last reply by AKASH kUMAR 1 month ago

  • Archived

taking very long time in login page of my application?

My application works on mozilla firefox 3.0.11 and i tried to install this firefox version on RHEL 7.4, since it is working fine on RHEL7.3, but now on RHEL 7.4 it is tak… (read more)

My application works on mozilla firefox 3.0.11 and i tried to install this firefox version on RHEL 7.4, since it is working fine on RHEL7.3, but now on RHEL 7.4 it is taking to long time for login page, after that it works fine, we have a ipfinder tool that works in login time, it is taking too long in ip finder, please help me.

I have installed some of RHEL libraries for running this older version on RHEL 7.3, and same i have done on rhel 7.4 but it is taking too long please provide us a solution or diagnose our problem.

Asked by divyadandotiya 1 year ago

Last reply by user633449 1 year ago

  • Archived

Update from 61.0.2 to 62.0 has broken my webrtc application

Hello, I am involved in developing an application that uses WebRTC for video calling. Prior to yesterday my FF browser was at version 61.0.2 and the application could mak… (read more)

Hello, I am involved in developing an application that uses WebRTC for video calling.

Prior to yesterday my FF browser was at version 61.0.2 and the application could make video calls between FF / Chrome and apps running on Android and iOS

Today, I was unable to make calls to/from FF 62.0. Calls made using Chrome to Chrome work fine. Two colleagues were also able to make calls with older FF 61.0.2 and then no longer, after upgrading to FF 62.0

We are using the PeerJS library

What WebRTC related changes have been implemented between 61.0.2 and 62.0?

Thank you

Asked by OliverSnow 1 year ago

Last reply by cor-el 1 year ago