Showing questions tagged: Show all questions

Update on/about 21 April 2021 broke WidevineCDM for many users, breaking Netflix/Spotify/etc. (thread of threads)

Each of the threads below is someone reporting the same problem (which I also have), with the same timing. Suddenly on 21 April 2021 all (?) major streaming sites started… (read more)

Each of the threads below is someone reporting the same problem (which I also have), with the same timing. Suddenly on 21 April 2021 all (?) major streaming sites started to give "The WidevineCDM plugin has crashed" message and ceased to work .

https://support.mozilla.org/en-US/questions/1333289 https://support.mozilla.org/en-US/questions/1333332 https://support.mozilla.org/en-US/questions/1333503 https://support.mozilla.org/en-US/questions/1333613 https://support.mozilla.org/en-US/questions/1333506 https://support.mozilla.org/en-US/questions/1333571

No suggested fix works. Reinstalling does not help, toggling DRM application does not help. It was obviously the update (at least for users on 78.10.0esr with OS X 10.9.5) that did it. Is there some way to get this registered as a bug?

Asked by pauls.filter 3 months ago

Last reply by cor-el 1 month ago

May need to install the required video codecs

# My problem When i go to some site with video (for example https://www.openproject.org/ ) i have the following message : "To play video, you may need to install the requ… (read more)

# My problem

When i go to some site with video (for example https://www.openproject.org/ ) i have the following message : "To play video, you may need to install the required video codecs".

# Spec

I run Firefox Beta in Fedora, it's installed in /opt/ folder. I have the "normal" version of firefox too and the video works well.

# Some other infos

The video seem to be a mp4 video and i have the following package installed in my fedora GStreamer Multimedia Codecs (Multimedia plauback for APE, AVI, DV, FLAC, FLX, Flash, MKV, MP4, Speex, VP8, VP9 and WAV).

Asked by bouteiller.alan 3 months ago

Last reply by cor-el 1 month ago

After 89.0.1 update on Windows, Firefox will not release the audio device, not allowing the computer to sleep.

Since the 89.0.1 update on Windows 10 21H1 (Build 19043.1055), Firefox will not let my PC sleep, unless I quit and re-open Firefox. There is no audio playing on any tabs,… (read more)

Since the 89.0.1 update on Windows 10 21H1 (Build 19043.1055), Firefox will not let my PC sleep, unless I quit and re-open Firefox. There is no audio playing on any tabs, but after a while of using Firefox on YouTube or whatnot, it will not release the audio device to let Windows put my monitors to sleep even though all playback has ended.

This can clearly be seen by running "powercfg /requests" as an administrator.

With videos playing, as expected Firefox reserves the audio device, as well as an Execution request.

Output: [ PS C:\WINDOWS\system32> powercfg /requests DISPLAY: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe display request

SYSTEM: [DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_10438581&REV_1000\4&2d156fef&0&0001) An audio stream is currently in use.

AWAYMODE: None.

EXECUTION: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe non-display request

PERFBOOST: None.

ACTIVELOCKSCREEN: None. ]

But after you stop playing the video the output becomes: [ PS C:\WINDOWS\system32> powercfg /requests DISPLAY: [PROCESS] \Device\HarddiskVolume6\Program Files\Mozilla Firefox\firefox.exe display request

SYSTEM: [DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0900&SUBSYS_10438581&REV_1000\4&2d156fef&0&0001) An audio stream is currently in use.

AWAYMODE: None.

EXECUTION: None.

PERFBOOST: None.

ACTIVELOCKSCREEN: None. ]

You can see the audio device doesn't get released, and the only resolution is to quit and restart Firefox.

This doesn't always happen, but does happen after a while.

Asked by Nabeel Rahimpour 1 month ago

Last reply by Seamus Everywhere 7 hours ago

Firefox won't load certain pages properly

Spontaneously, Firefox is now unable to load certain websites properly: Twitter won't show tweets, streaming websites won't play, and sites like Wikipedia have lost their… (read more)

Spontaneously, Firefox is now unable to load certain websites properly: Twitter won't show tweets, streaming websites won't play, and sites like Wikipedia have lost their formatting. Other websites seem completely unaffected, like YouTube, Pinterest, and news sites. This is only happening on Firefox, as my other browsers are unaffected, but Firefox is my default and I don't want to have to switch.

I've tried restarting both the browser and my PC, clearing the cache, turning off my firewall and anti-virus, disabled add-ons, and unregistered service worker... I'm out of ideas.

I've included some images to show what I mean.

Asked by swain.commission 1 month ago

Last reply by Chris Mortland 2 days ago

Input tools opens slowly

Hello! I got this issue when i am clicking on input tools (on screen keyboard) on google search page,it opens up with a 3-5 second delay and this problem started after i … (read more)

Hello!

I got this issue when i am clicking on input tools (on screen keyboard) on google search page,it opens up with a 3-5 second delay and this problem started after i installed version Firefox 90.0.02 64 bit.

My OS is Win 10 64bit. All updates except KB5004237 are installed.

I do have a couple of add-ons like Default Bookmark Folder and uBlock Origin and i even disabled them but still the issue stands with input tools delay.

I also refreshed my Firefox but that didn't help either.

Any solutions to this issue?

Asked by pilotorder 1 week ago

Last reply by FredMcD 1 week ago

Images not loading on random sites

About a day or two ago, random images stopped loading on sites I visit regularly. I haven't changed anything on the browser. In fact, I disabled add-ons to see if it woul… (read more)

About a day or two ago, random images stopped loading on sites I visit regularly.

I haven't changed anything on the browser. In fact, I disabled add-ons to see if it would fix the problem (it hasn't).

I'm already neurotic about deleting the cache and such after bold texteverybold text session every day.

It only occurs on Firefox desktop (90.0.2 64-bit); everything loads fine on mobile and on other desktop browsers.

Asked by BuddyL 6 days ago

Last reply by FredMcD 6 days ago

Removing nav-bar using userchrome.css crashes firefox

I updated the below code in userchrome.css @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); tabbrowser-tabs { visibility: collapse !impor… (read more)

I updated the below code in userchrome.css @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

  1. tabbrowser-tabs { visibility: collapse !important; }
  2. nav-bar {visibility: collapse !important;}

browser {margin-right: 0px; margin-bottom: 0px ! important;}

==================================

The firefox goes blank when opened, Resizing or maximizing the window refreshes firefox and it loads.

I deleted profile data and it works a couple of times and it happens again. A blank page.

Asked by yash292k11 6 days ago

Last reply by cor-el 4 days ago

This support said why Firefox will not "stay up" is I am on a BETA...

I did not choose a BETA VERSION. I have used FIREFOX since VERSION 1.0. IT USED TO BE THE BEST BROWSER EVER CREATED. BUT NO LONGER. WE use Firefox to accomplish things, … (read more)

I did not choose a BETA VERSION. I have used FIREFOX since VERSION 1.0. IT USED TO BE THE BEST BROWSER EVER CREATED. BUT NO LONGER. WE use Firefox to accomplish things, not to debug BETA versions all day. One day I wake up and you FORCED rel 89.0 on us and it turned the whole WEEK to crap. I had 6 consecutive crashes the other day. Today I had 5 consecutive crashes. I had to turn my PC off and give it and me a rest. I did not ask for a BETA, even to leave rel 88. YOU 'forced' it on us with your "you have no other chooses if you want to continue using FIREFOX attitude. And all you can say is: Go BACK to 'stable rel 90 AND CREATE A NEW PROFILE? DO you have any idea how hard it is for us, a USER to CREATE A NEW PROFILE FROM SCRATCH?

THIS MAKES NO SENSE, YOU CRAM A "BETA" ON US, IT CRASHES A HALF DOZEN TIMES A DAY and your answer is to go back to a stable version YOU FORCED ON US? Then we spend a day or two creating a NEW PROFILE until you force ANOTHER BETA on us to test for you? You can't let us stay on a STABLE version like rel 88 until you work out the bugs then "tell us" there is one available and advise us to INSTALL IT? THIS IS CRAZY, let alone "Professional".

Asked by jagman55 6 days ago

Last reply by cor-el 5 days ago

Google search, Gmail and other google services stop responding in Firefox

For about a month now I have had an issue with Firefox where suddenly the search bar (with Google search) stops working. I input text, press enter but nothing happens. No… (read more)

For about a month now I have had an issue with Firefox where suddenly the search bar (with Google search) stops working. I input text, press enter but nothing happens. No page is loaded. I see the google search URL that the browser is trying to reach, and I see in the network tool that the request is made but nothing appears after that. Page doesn't change and response is not registered in the network tool. Also, my GMail account tabs stop working, and trying to refresh them, GMail freezes while loading.

If I restart Firefox all starts working, until the problem starts happening again (can be minutes or hours, I guess it depends on usage)

Another colleague of mine has the exact same problem.

I tried with NO success: - Clearing all cache and data; - Disabling all extensions; - Running firefox in troubleshoot mode; - Refresh Firefox; - Complete uninstall, with profile folder removal and start from scratch; - Disabling hardware acceleration; - Setting "browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar" to false; - Disabling "network.http.http3.enabled"; - Setting Proxy to "No Proxy";

All works on another browsers.

Can someone advise on how to further troubleshoot and fix this issue?

Asked by diogomanel 6 days ago

Last reply by FredMcD 4 days ago

Videos freezing, Pages taking forever to open, what's up?

I am getting more & more frustrated and exasperated, as simple browsing has become tortuously slow, with many sites taking forever to load, or only partially load, or… (read more)

I am getting more & more frustrated and exasperated, as simple browsing has become tortuously slow, with many sites taking forever to load, or only partially load, or have to be refreshed a couple times, to finally get it to load. And videos constantly freezing up, despite lots of free RAM, and a very high-speed internet connection. I assumed whatever was causing this would've been addressed in the last update, or two, but no, it's only getting worse.

Asked by StevenCee 5 days ago

Last reply by FredMcD 1 day ago

Website not loading fully, spinning wheel / loading bar never stops

I have the issue that this website is not loading images properly in Firefox: https://www.suedmetall.com/produkt/stossgriff/stossgriff-1003/san-paolo-edelstahl-satiniert/… (read more)

I have the issue that this website is not loading images properly in Firefox: https://www.suedmetall.com/produkt/stossgriff/stossgriff-1003/san-paolo-edelstahl-satiniert/

if you click on multiple products in the navigation (icons) there are some issues in loading: http://prntscr.com/1gal22w

I dont know what is causing the issue and need help pls.

Asked by wintef 5 days ago

Last reply by FredMcD 5 days ago

My menu button dropdown is blank

Firefox has had some glitches for me lately like menu drop down is blank, engine switching to Yahoo, suddenly images telescope in and out on the page. Since the drop down… (read more)

Firefox has had some glitches for me lately like menu drop down is blank, engine switching to Yahoo, suddenly images telescope in and out on the page. Since the drop down menu is blank I cannot utilize the tips on these Firefox help pages.

Asked by straycat808 5 days ago

Last reply by FredMcD 5 days ago

Onscreen keyboard kicked of after prompted

It's been few years already with this issue, and all the posts on it have been archived without ever been solved. Wonder if anyone now has a solution. I'm on Win10. CANNO… (read more)

It's been few years already with this issue, and all the posts on it have been archived without ever been solved. Wonder if anyone now has a solution.

I'm on Win10. CANNOT use Firefox without a physical keyboard, so I seldom do... just checking for solution

Asked by nellyjr 5 days ago

Last reply by JP 2 days ago

Difficulty navigating aspects of a web page

I am using Firefox 90.0.2 (64-bit) on a iMac decktop running mac OS Big Sur Version 11.5 When I am in a particular website and I am accessing different aspects of the we… (read more)

I am using Firefox 90.0.2 (64-bit) on a iMac decktop running mac OS Big Sur Version 11.5 When I am in a particular website and I am accessing different aspects of the website and I get the following message: "400 Bad request Your browser sent an invalid request" What is happening? When I access the same website on Safari and go to do the same things, it operates fully. What is happening?

Asked by NoelWill 5 days ago

Last reply by cor-el 5 days ago

Firefox not responding/hanging on startup, unable to fully uninstall or reinstall

When I launch Firefox, if I press anything or wait for a bit, the program stops responding and I have to force close it. Firefox was working just fine until recently. I h… (read more)

When I launch Firefox, if I press anything or wait for a bit, the program stops responding and I have to force close it. Firefox was working just fine until recently. I have not updated Windows or made changes to Firefox prior to these issues occurring either.

I have tried following this thread: https://support.mozilla.org/en-US/kb/firefox-keeps-crashing-startup#w_try-a-clean-install_2

I am not able to start in Troubleshoot mode as I cannot interact with Firefox in any way.

I also have trouble with doing a clean install. When I run the uninstaller, it eventually gets stuck and I have to force close the uninstaller. After closing the uninstaller, I deleted the Mozilla folder under C:\Program Files and the Firefox folder under the %appdata% directory.

I then tried both the stub installer for Firefox and the full installer located here: https://www.mozilla.org/en-CA/firefox/all/#product-desktop-release

Both installers get stuck. I have attached an image of where the full installer gets stuck. After force closing the installers, I am still able to open Firefox, but it has the same issue of not responding.

I have also tried creating a new profile with the profile manager, but the issue persists.

If anyone has any ideas or knows of a solution, please let me know.

Thanks.

Asked by niroh488 5 days ago

Last reply by FredMcD 4 days ago

Firefox storages are broken

It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially: … (read more)

It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially:

  • QuotaManager
  • Bad: Totally Broken. (fullyBroken)
  • IndexedDB
  • Bad: Totally Broken. (fullyBroken)
  • Cache API
  • Bad: Totally Broken. (fullyBroken)

Is there any way to fix this? I'm using Firefox ESR on Linux and it seems there isn't new Firefox ESR updates.

Asked by thecowmilk 5 days ago

Last reply by cor-el 1 day ago

Scrolling ghosts

(I'm using a desktop with Windows 10 without the recent disservice pack update.) This issue is a recent development, even newer than the weird sans serif font issue that … (read more)

(I'm using a desktop with Windows 10 without the recent disservice pack update.)

This issue is a recent development, even newer than the weird sans serif font issue that began with Firefox 90. The issue is intermittent.

When I scroll down a page using the wheel on my Logitech M510, parts of the page will refresh at different speeds. Usually this is noticeable as the illusion of a diagonal line and disappears as soon as scrolling stops. Sometimes part of the prescrolling display will remain rather than changing with the rest of the screen, usually as a rectangle. I've also started getting only partial display of dialog boxes when editing in Wikipedia, in which only part of the image changes.

The rectangular area not updated is usually near the centre of the screen. The Wikipedia box issue has the opposite issue - the only part of the box that appears is in the same spot that fails to refresh when scrolling.

If I tap on an arrow key, the unrefreshed portion of the screen gets back in sync with the rest.

The issue seems unrelated to website, occurring on Wikipedia, Facebook, and Google.

I disabled the Proton interface within a week of its appearance because it wasted so much vertical screen space, if that's any clue.

Asked by OilCanHarry 5 days ago

Last reply by cor-el 4 days ago

Firefox eats 15+ GB of ram and about:perf shows NOTHING

FF regularly eats more than 15 gigs of ram. While I have dozens of tabs opened, they are not loaded (max 10 loaded at any single time). About:performance is the most usel… (read more)

FF regularly eats more than 15 gigs of ram. While I have dozens of tabs opened, they are not loaded (max 10 loaded at any single time).

About:performance is the most useless monitoring tool i have ever seen.

Asked by eric_sos_jeuxvideo 4 days ago

Last reply by cor-el 4 days ago

Firefox Mac will not open links .

When I am in an open page in Firefox 90.02 and try to open a link MOST OF THE TIME It will post the error message below and not let me proceed. I can tell from other post… (read more)

When I am in an open page in Firefox 90.02 and try to open a link MOST OF THE TIME It will post the error message below and not let me proceed. I can tell from other posts that this is not uncommon, but I cannot find a posting that is useful.

Thus far I have 1. reset/repaired Firefox 2. ensured that Firefox has full access to my computer and the internet and that the Firewall is off. 3. reset all the security and privacy settings to the lowest settings or turned them off including pop-up blocking, tracking, really all settings, cleared the cookies and caches.

What am I missing? Randy Black

Asked by Rand 4 days ago

Last reply by FredMcD 4 days ago

The new version of Firefox 90.0.2 doesn't work with many websites

Several websites I use frequently, including Facebook, the Macquarie Dictionary and even Mozilla's own support website, don't work properly with the new version of Firefo… (read more)

Several websites I use frequently, including Facebook, the Macquarie Dictionary and even Mozilla's own support website, don't work properly with the new version of Firefox. I even had to use Google Chrome to access this support page, as I couldn't get past the login page using Firefox. When I first opened the new version, Firefox told me that I had to enable cookies for it to work. I went to Preferences and checked that cookies were definitely enabled. I quit and restarted both Firefox and the entire computer, checked that cookies were still enabled and it still doesn't work. Why is this happening? I don't want to change my default browser permanently, but I need it to work for me. Can anyone help?

Asked by lordwhybro 4 days ago

Last reply by FredMcD 4 days ago