Firefox takes ~5 minutes to startup (even the Profile Manager and in every possible modes)

Firefox takes about 5 minutes to load every it launches, before working smoothly like it should. This problem occured first time yesterday morning, and I have no idea wha… (read more)

Firefox takes about 5 minutes to load every it launches, before working smoothly like it should. This problem occured first time yesterday morning, and I have no idea what could have caused it.

It happens :

  • when I launch firefox normally (whatever the profile)
  • when I launch it from the terminal (it provides no output at all)
  • when I tell it to launch the Profile Manager (5 minutes to see the Profile Manager appear, then 5 more minutes to launch firefox using the selected profile)

It does not happen :

  • when I click "New Window" inside an existing firefox process
  • when I call `firefox --help` from the terminal

Here's what I've tried :

  • First, I've seen pretty much every article from Mozilla Support, Reddit or SuperUser (writing this question is kind of my last resort)
  • I've tried removing and then reinstalling Firefox from Flatpak, from the Fedora repos (using `sudo dnf install firefox`) and using the manual install via the archive (v125)
  • I've tried downgrading firefox (when using the package manager install) from v125 to v124
  • I've also tried the Firefox Developer Edition, same problem here
  • I've tried using the "Refresh Firefox" feature and restarting in Troubleshoot Mode (both are also affected by the slow startup, which makes them particularly painful to execute)
  • I've tried manually deleting the `~/.mozilla/` folder (= manually deleting my profiles)

When firefox launches, it does not freezes my OS and does not seem to use many system ressources : CPU usage is normal, RAM as well, and it does not seem to read many things from the disk as well (I've seen some threads where this was the issue).

And here is something interesting that I discovered :

  • loading (including refreshing) `about:profiles` is also slow and this time freezes firefox (OS reports it as not responding, I can't switch tabs and I can't see my mouse). Other about pages seem to work fine (although I did not try them all)

Thanks !

PS : Even if I think it has nothing to do with the issue, I prefer to mention it here : I was messing with virtual machines yesterday when the issue occured for the first time. My disk got full at some point and I don't know but it might have messed with firefox. At this stage, I had not deleted any files that could relate somehow to Firefox, that's why I doubt it would have caused anything harmful to Firefox. (instead, I mounted an empty partition from my disk to get some space)

Asked by Martin Heywang 3 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

Youtube has stopped working suddenly

I've disabled all of my addons, cleared cache, and still youtube is broken for me. It works fine with Chrome still. Any ideas on how to fix? See attched screenshot. … (read more)

I've disabled all of my addons, cleared cache, and still youtube is broken for me. It works fine with Chrome still. Any ideas on how to fix? See attched screenshot.

Asked by gk16 2 weeks ago

Last reply by jonzn4SUSE 2 weeks ago

you tube tv

After the browser update earlier today I cannot log into 'You Tube TV'. The browser keeps asking for my email and password over and over and never signs me in. It keeps t… (read more)

After the browser update earlier today I cannot log into 'You Tube TV'. The browser keeps asking for my email and password over and over and never signs me in. It keeps telling that I am signed out and need to sign in, over and over. I cleared my cache and cookies. I changed my sign in from my yahoo email to my gmail account and it still will not work. If I use the chrome browser it works fine. Please Help.

best regards,

john loomis jr.

Asked by jloomisjr2 2 weeks ago

Last reply by cor-el 2 weeks ago

DuckDuckGo is down

I use DuckDuckGo for my basic search engine on both my laptop (Ubuntu system) and iPhone 8. It does not work today - saying "There was an error displaying the search resu… (read more)

I use DuckDuckGo for my basic search engine on both my laptop (Ubuntu system) and iPhone 8. It does not work today - saying "There was an error displaying the search results. Please try again.", needless to say...I have tried a number of times and differed the searches to no avail. I also cleared recent cache/history. Still stuck. Searching on Chrome I see on https://news.ycombinator.com/item?id=40451490 that others are also experiencing this problem and do not understand it either - just a few entries

The Sun (a rather populist newspaper in UK) has an article saying it is international and happening today, 23 May 2024, suggests no fixes. (Not exactly a reliable source in my thing)

Has anyone ideas or should I just wait and use an alternative search engine meanwhile? Thanks for any help

Asked by b17m 2 days ago

Last reply by James 2 days ago

Google Maps Street View

When the little yellow man is placed on to the map, and a direction arrow is clicked, the view just continues to spin round. Clicking on the 'X' in the top right hand cor… (read more)

When the little yellow man is placed on to the map, and a direction arrow is clicked, the view just continues to spin round. Clicking on the 'X' in the top right hand corner terminates street view. This does not happen with other browsers.

My OS is Debian 12, Firefox is the latest version 115.9.1esr (64bit).

Asked by johnh009 1 month ago

Last reply by zeroknight 1 month ago

DuckDuckGo Search not working any more ... on Firefox 126.0 ... the next day!

## Premise ## I only ask a question after I thoroughly and at my best knowledge tried various ways and also what I found in these forums an others. This is another weird … (read more)

## Premise ## I only ask a question after I thoroughly and at my best knowledge tried various ways and also what I found in these forums an others. This is another weird one for me.

Firefox 126.0 on a Windows 10 22H2

Hi I have been using Firefox maybe for 20 years... and I noticed in the last possibly 5 years has started to have problems after problems. More like bothers and I am not the only one!

Problems with YouTube videos either not loading properly or no audio and so on, tamed down at present! At some point I stopped using it years ago, then got back to it, but since I did a series of different things/work via browsers, I now have some others set to do one task/work.

Firefox is not only the ;standard browser for 'browsing' and basic shopping.

Anyway, this time from yesterday, DuckDuckGo Search not working any more.

There have not been any Windows or Security updates yesterday.

Any other search add-on works fine, but DuckDuckGo.

What I did:

1. Restarted browser - the obvious one 2. I do not really need to clear Cookies as I use an add on that does it for me as soon as I close a tab or browser 3. Downloaded 126.0 and re-installed it on top 4. No new add-ons were installed, but IU also re-started with all add-ons off 5. Cleared history - everything 6. Internet is fine, reset it - just in case, but also tested on other devices and DuckDuckGo works fine 7. My security is not blocking anything

Has Firefox 126.0 had an heart attack overnight, meaning there is a bug that comes out in certain conditions?

I just get from DuckDuckGo: There was an error displaying the search results. Please try again.

Any other Search work, even the less known such as Qwant and Mojeek. No idea. I wasted so much time... again.

Thank you M

PS I may have missed other things I did try and I may amend this post or add posts, if I cannot edit.

Asked by Mozzed 2 days ago

Last reply by James 2 days ago

Washington Post website doesn't work on Firefox

I have tried several suggested fixes to get the Washington Post website to work properly, including reloading Firefox. Links within the site fail to load, pictures are … (read more)

I have tried several suggested fixes to get the Washington Post website to work properly, including reloading Firefox. Links within the site fail to load, pictures are hazy low-resolution, sometimes content doesn't display at all, or does so briefly before going blank. The problem seemed to start after an update 2 weeks ago. I am about to give up trying to fix this, and choose another browser. I don't understand why the problem only affects the WaPo website, which runs fine on chrome or Safari.

Asked by johnsvarner 2 weeks ago

Last reply by cor-el 2 weeks ago

Firefox has done it again

The pinned shortcuts on my newtab page have all disappeared once again. I've gone to about:config > browser.newtabpage.pinned and my shortcuts are all listed. But o… (read more)

The pinned shortcuts on my newtab page have all disappeared once again. I've gone to about:config > browser.newtabpage.pinned and my shortcuts are all listed. But only blank boxes show up on the page. It will not accept a new entry when I try to enter one. It goes back to the blank white box. Why does this keep happening? Can anyone give me a Firefox for Dummies way to fix this?? Thanks!

Email removed for privacy

Asked by raydle1101 1 month ago

Last reply by zeroknight 1 month ago

My account was "used to sign in to Firefox on a MacOSX10.15 on Sunday, May 5. It was not me.

I had someone breaking into a number of my accounts. They used my account to sign into Firefox. And I got an account authorization code, but I'm afraid to use the email … (read more)

I had someone breaking into a number of my accounts. They used my account to sign into Firefox. And I got an account authorization code, but I'm afraid to use the email in case it is them getting more info!!

Asked by ccg14 2 weeks ago

Last reply by Amelia 2 weeks ago

Problem on mobiles (apple and Android) and PC (Windows)

When we enter a search query on mobiles or on PC using Firefox we get:- There was an error displaying the search results. Please try again. This started happening today… (read more)

When we enter a search query on mobiles or on PC using Firefox we get:-

There was an error displaying the search results. Please try again.

This started happening today at about 10:45 (BST+2) Using Safari or the Galaxy search engine or using Chrome on the PC works fine.

At first we thought it might be a local problem so we re-booted our router - no result. We re-set Firefox on the PC - no result (anyway it is generalised).

Curiously WhatsApp is still connected (had to re-connect after re-set). So what is going on please?

Jon

Asked by mouson 2 days ago

Last reply by James 2 days ago

Images Not Loading on Certain Websites in Firefox

I'm having trouble with Firefox where images aren't loading on some websites, even though they display fine in other browsers. I've tried clearing the cache and restartin… (read more)

I'm having trouble with Firefox where images aren't loading on some websites, even though they display fine in other browsers. I've tried clearing the cache and restarting Firefox, but the issue persists.

Is there anything else I can try to fix this problem and get images to load properly?

Asked by Robert Wolf 1 month ago

Last reply by cor-el 1 month ago

Primary pass work

I tried to delete my primary password online, but system would not allow me to do so. I have exhausted all avenues to seek help, but to no avail. Any assistance would … (read more)

I tried to delete my primary password online, but system would not allow me to do so. I have exhausted all avenues to seek help, but to no avail. Any assistance would be greatly appreciated. Tmg3842@yahoo.com

Asked by tmg3842 1 month ago

Last reply by cor-el 1 month ago

Unintended scroll to top of page

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've … (read more)

browsing website (reddit or amazon for example), the window scrolls to the top every time I move the mouse. doesn't happen all the time though, and only in Firefox. I've serached the internet and can't find anything related. Please help

Asked by myblackfrog 1 month ago

Last reply by zeroknight 1 month ago

firefox private mode language error

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok . … (read more)

I use firefox on fedora 38 and after update firefox about a month ago . i got this error when use private mode ,for thai languge it just error but in normal mode it ok .

Asked by SD SD 1 month ago

Last reply by zeroknight 1 month ago

Recent issue viewing my Shopify site

Hello. In the last few days when I visit my Shopify website, the pricing on my products is not visible. This is only for me, nobody else has this issue. I do not have thi… (read more)

Hello. In the last few days when I visit my Shopify website, the pricing on my products is not visible. This is only for me, nobody else has this issue. I do not have this issue on Safari, or on Firefox when I open a private browsing window. It is something to do with Firefox, but I don't want to have to open a private window every time I go to my store. Is there a solution? This has only been happening for the last few days. Thanks

Asked by leslie.day 1 month ago

Last reply by zeroknight 1 month ago

Facebook only halfway works on Firefox

I recently purchased a new Mac Book Pro. After migrating my data from my old one I noticed that when using Firefox my Facebook account was not working properly. I no lo… (read more)

I recently purchased a new Mac Book Pro. After migrating my data from my old one I noticed that when using Firefox my Facebook account was not working properly. I no longer could access my own page or the pages of friends. However, I could access some group accounts I'm associated with. On Safari, everything works fine. I suspect something must have been compromised during the data migration.

I deleted the Firefox app from my new computer and then reinstalled it but to no avail. When I'm in Facebook and try to access my page I get an error message. My OS system to up to date and apparently my Firefox is up to date as well. Any suggestions? Thanks!

Asked by jjenkins9 1 month ago

Last reply by zeroknight 1 month ago

Importing Bookmarks from Chrome via html

I followed instructions for adding bookmarks from html file. Got to "import from html" . I can see the html file I want to access, but when I push "open" nothing happen… (read more)

I followed instructions for adding bookmarks from html file. Got to "import from html" . I can see the html file I want to access, but when I push "open" nothing happens.

Asked by bceccoli 3 weeks ago

Last reply by cor-el 3 weeks ago