Showing questions tagged: Show all questions

Azure DevOps unusable in Firefox

Hello, I'm using Firefox as my default browser for a while now (10+ years) and I'm getting frustrated with this issue when using Azure Devops. Comments don't load at all … (read more)

Hello, I'm using Firefox as my default browser for a while now (10+ years) and I'm getting frustrated with this issue when using Azure Devops. Comments don't load at all and most pages take a long time to load if they load at all. Various features also take a long time to load or don't work at all (examples include adding a reviewer, referencing a story with #, etc.). Anyone else experience this?

It works well for maybe an hour, and after a couple of days it makes no sense anymore.

Now I'm using firefox containers with a container only for Azure Devops and seems working better but ... Curious thing is that it pops up and asks for credentials periodically every 5 or 10 minutes. Well, unless the boxes are already filled up with the credentials.

Thanks,

Asked by leo87 2 weeks ago

Last reply by leo87 11 hours ago

Mozilla / Firefox Brand

I noticed the mozilla.org website has a new favicon. I feel like that sort of thing usually alludes to some forthcoming development. Hmm... My question is. Hmm? I wonde… (read more)

I noticed the mozilla.org website has a new favicon. I feel like that sort of thing usually alludes to some forthcoming development. Hmm...

My question is. Hmm? I wonder what's going on over at Mozilla.

Asked by centRe Web Design 4 days ago

lost focus bug (when changind language)

When you switch the language in a text field, the focus on that text field is lost and the focus goes to another browser tab. This only happens if at this time a video is… (read more)

When you switch the language in a text field, the focus on that text field is lost and the focus goes to another browser tab. This only happens if at this time a video is playing in mozilla in picture in picture mode with the Always on top option enabled. How to fix it? (Ubuntu 22.04)

Asked by Лев Бреслав 4 days ago

PDFs are shown as empty pages after suspend/resume on linux

Hello, I'm using a document management system (SeedDMS for those who know) through Firefox 122.0.1 (64-bit, canonical 1.0, downloaded from packages.ubuntu.com for focal, … (read more)

Hello, I'm using a document management system (SeedDMS for those who know) through Firefox 122.0.1 (64-bit, canonical 1.0, downloaded from packages.ubuntu.com for focal, running on Debian Bookworm, kernel 6.1.0-17-amd64/Debian 6.1.69-1 x86_64, X.Org X Server 1.21.1.7, KDE Plasma 5.27.5, KDE Framework 5.103.0, QT 5.15.8, i7-5820K, GeForce GTX 1070).

Within this document management system pdf.js (v4.0.379) is being used to preview/view PDF Documents. After starting Firefox the PDF view inside the DMS works fine until I suspend (to memory) and resume my machine. Regular HTML-content looks fine but the resumed DMS session shows only blank (all white) Pages inside the PDF view. Changing to a different PDF file doesn't help. The number and size of these pages is presented correctly. I can even select and copy (invisible) text from these blank PDF pages. The problem applies to all PDFs, whether they're single or multi paged, have images inside them (like with PDFs from a scanner) or not, etc. Reloading the page/closing reopening the affected browser window doesn't help, i.e. the problem persists.

I recently found out, that this also applies to PDF files directly opened inside Firefox (which also seems to use pdf.js as a PDF viewer), that is, this is not related to a specific site like my DMS.

The problem always persists until I kill Firefox and start it over.

Pdf.js seems to use a canvas inside a div (see screenshots attached) to draw the visual PDF content and another div to make the text layer selectable/searchable etc. I don't know what's happening to canvases on a system suspend/resume cycle in Firefox on Linux, but I suspect that's where the problem originates from.

This problem already affected older versions of Firefox and pdf.js.

Please let me know, if you need further information from my side to investigate that issue.

Thanks a lot!

Asked by thomas360 3 days ago

Addon windows do not retheme automatically when toggling light/dark mode

When the system theme (light/dark) is switched globally, Firefox recognizes this and also switches its theme automatically (if configured appropriately). This should also… (read more)

When the system theme (light/dark) is switched globally, Firefox recognizes this and also switches its theme automatically (if configured appropriately). This should also retheme addons opened in the sidebar (Tab Stash or Sidebery for instance), and it does so under certain conditions, namely if either a) no sidebar was opened when starting Firefox and the addon sidebar window is opened directly, or b) the sidebar was opened with start of Firefox. Unfortunately, no retheming of the addon window occurs when some other Firefox sidebar (such as bookmarks or history) was opened after Firefox start and before system theme switch. In that case, the addon window (which is opened as the system theme is switched) does not retheme. This can be mitigated by either restarting Firefox or by opening a Firefox sidebar such as bookmarks or history, and switching back to the addon window.

So to reproduce this behaviour:

  1. Open Firefox and some sidebar addon directly (such as Tab Stash in my case, with Ctrl-Alt-S)
  2. Switch system theme globally (I do this with Night Theme Switcher in GNOME)
  3. Observe that Firefox correctly redraws the addon window
  4. Open bookmarks (Ctrl-B) or history (Ctrl-H)
  5. Reopen the addon window
  6. Switch system theme globally again
  7. Observe that Firefox does not correctly redraw the addon window
  8. Open bookmarks (Ctrl-B) or history (Ctrl-H) again
  9. Reopen the addon window
  10. Observe that Firefox redrew the addon window

This has already been reported to the addon developer, who stated that it might be a bug in Firefox, since his addon only tells Firefox which colors to use in which mode.

System details:

  • OS Version: Linux 6.7.4-arch1-1
  • Browser Version: Firefox 122.0.1
  • Desktop environment: GNOME

Asked by biloilo 5 days ago

Captive Portal remains undetected by not prompting to login to network after Hotspot session time expires

I'm using a Hotspot provided by Cisco in a library and when first connecting to the Wireless network, Firefox prompts me to login to network in order to have Internet acc… (read more)

I'm using a Hotspot provided by Cisco in a library and when first connecting to the Wireless network, Firefox prompts me to login to network in order to have Internet access (expected and works fine). However, once the time session expires Firefox will sometimes prompt again to login. When this fails and internet access is abruptly ended, I've to reconnect to the Wireless network and have Firefox prompt to login.

This is a security vulnerability as someone could advertise the BSSID of the router and have victims connect to their Hotspot instead of the true one.

Asked by alghe.global 2 days ago

Default zoom level is resetting when resistFingerprinting is enabled. Is this expected behaviour?

I have enabled privacy.resistFingerprinting in Firefox. I have also set my default zoom level to 133% When I open a website (e.g. https://github.com/), it is zoomed to 1… (read more)

I have enabled privacy.resistFingerprinting in Firefox. I have also set my default zoom level to 133%

When I open a website (e.g. https://github.com/), it is zoomed to 133% as expected. If I then navigate to a page on that website (e.g. https://github.com/pricing) using the menu at the top of the page, then the new page is still zoomed to 133%. So far, so good.

However, on the new page (https://github.com/pricing) if I increase the zoom over 133%, then navigate back to the original page (https://github.com/) using the menu at the top of the page, then my zoom level is reset to 100%.

Is this expected behaviour? I would have thought that the zoom level would be reset to 133%, not 100%.

I found this, which seems somewhat related: https://bugzilla.mozilla.org/show_bug.cgi?id=1609880

Asked by Russ 21 hours ago

Build Firefox from sources

Hi, During of build process we have an error related to auto deduction before 'auto' in dom/bindings/TypedArray.h For example the call ProcessTypedArrays() at line 128 … (read more)

Hi,

During of build process we have an error related to auto deduction before 'auto' in dom/bindings/TypedArray.h

For example the call ProcessTypedArrays() at line 128 in file ChromeUtils.cpp give the error.

Asked by kosteltsev 19 hours ago

How to disable "Open my links with Firefox"?

I'm installing a Docker service set onto a new Ubuntu system, that has Firefox installed by default. One of the services is a GUI application. However, when opening Fire… (read more)

I'm installing a Docker service set onto a new Ubuntu system, that has Firefox installed by default. One of the services is a GUI application.

However, when opening Firefox for the first time, a dialog shows up that I would like to disable (attached).

How can I disable this?

I'm running Firefox using: "/usr/bin/firefox --kiosk http://localhost"

I've already followed a lot of the suggestions in here: https://searchfox.org/mozilla-release/source/remote/shared/RecommendedPreferences.sys.mjs (and verified they are indeed set after installing my own "user.js" file), but I cannot find an about:config preference that disables what I'm still seeing.

Any help or ideas?

Asked by Devin 2 days ago