Showing questions tagged: Show all questions
  • Solved
  • Archived

Can't watch ANY videos in Firefox

I'm running Firefox 59.0.2 64-bit on my PC. I have extensions for AdBlock, Honey, and LastPass. In addition to the two plug-ins provided by Mozilla in this version of F… (read more)

I'm running Firefox 59.0.2 64-bit on my PC. I have extensions for AdBlock, Honey, and LastPass. In addition to the two plug-ins provided by Mozilla in this version of Firefox, I have added Flash Player (re-installed several times).

I can't see ANY videos at all. No YouTube, no types of video at all.

I've refreshed my Firefox totally (and don't want to do that again any time soon!).

I've looked at "solutions" provided online, and nothing has worked.

Will someone give me the exact setup that should allow me to watch videos? Right now, when they come up, I get a spinning circle until finally some type of error message appears. The error message differs depending on where I'm watching the video. For example, If I'm trying to watch a YouTube video, I see the still picture that accompanies the video. When I click on the "play" arrow, I get: "An error occurred. Please try again later. Playback ID: pcGJXEDjuz-BRuBz" If I try to watch something on, say, the Weather Channel site, I first see the still picture. When I click to "play", I see a black screen with a small blue square in the center with the Weather Channel logo.

I did have a big Microsoft update a few nights ago, but I have no idea what changed there.

Bottom line: I have no idea what has happened to my video. What has changed since Firefox 58?

Asked by brorat 3 years ago

Answered by FredMcD 3 years ago

  • Solved
  • Archived

[SOLVED]Firefox won't play any video from this domain

This problem is driving me crazy! It was working until few days ago. I can't watch any videos from this website/domain: http://redeglobo.globo.com/videos/ Things I've tr… (read more)

This problem is driving me crazy! It was working until few days ago.

I can't watch any videos from this website/domain: http://redeglobo.globo.com/videos/ Things I've tried: - private browsing - safe mode - new profile/refresh - portable version - uninstall/reinstall - older versions - uninstalled kaspersky/windows defender is disabled - HOSTS file is clean(Windows 7 x64)

The thing is, the ads load but not the video content. If the ad is long, an error message appears while the audio is still playing in the background. Another computer in the same network plays them fine. All other browsers can play these videos, this problem only happens in Firefox. I've tested a virtual machine in this same computer and then it works. Is there anything else I can do to try to fix this?

Firefox console shows these errors: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://vodstreaming02a.video.globo.com/r90_720/v7/e8/93/1e/7164945_1e25dd21ab308227e9961ad4c2a44399a4dc60ff/7164945-manifest.ism/7164945-manifest-audio_por_1=128025-video_por=1967000.m3u8?hls_client_manifest_version=4. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

[error][hlsjs: unrecoverable network fatal error.] Object { evt: "hlsError", data: {…} } player.min.js:1:1237298

[error][player_error] Object { description: "hls error: type: networkError, details: levelLoadError, response: {\"code\":0,\"text\":\"\"}", level: "FATAL", origin: "hls", scope: "playback", raw: {…}, code: "hls:networkError_levelLoadError", UI: {…} } player.min.js:1:1237298

Asked by anitoad 2 years ago

Answered by anitoad 2 years ago

  • Solved
  • Archived

Embedded Youtube videos do not work

I am running Firefox 52.9.0 (32-bit), Win XP PRO SP3 on several computers and only my desktop has this problem. Youtube videos embedded in other pages do not work and on… (read more)

I am running Firefox 52.9.0 (32-bit), Win XP PRO SP3 on several computers and only my desktop has this problem.

Youtube videos embedded in other pages do not work and only blank space is displayed but if I go to Youtube the videos play correctly. This only happens in one computer. In other computers running same Firefox 52.9.0 (32-bit), Win XP PRO SP3 this problem does not happen.

I guess it might be some configuration problem.

Asked by sail33 2 years ago

Answered by sail33 2 years ago

  • Solved
  • Archived

YouTube has new video formats not supported in the Linux version, but supported in Windows and Mac.

I saw something new in YouTube today. When I tried to watch a file (https://www.youtube.com/watch?v=mJVdiGpnH_s) the only resolution I could get was 360p. A video option … (read more)

I saw something new in YouTube today. When I tried to watch a file (https://www.youtube.com/watch?v=mJVdiGpnH_s) the only resolution I could get was 360p. A video option labeled "Missing options?" brought up a YouTube help page (screenshot attached).

Why is Linux left out of this capability? It can't be because those formats are unsupportable in Linux; Chrome supports them for all of their browsers, including Linux. Why does Firefox discriminate against Linux users?

Asked by Adamas 3 years ago

Answered by Adamas 3 years ago

  • Solved
  • Archived

Can't see any video on facebook, It shows only weird colours!

Hi, As you see In the picture, this what I see most of times when I play any video or even A gif picture on facebook 85% shows like that, and only 15% works normally.. Bu… (read more)

Hi, As you see In the picture, this what I see most of times when I play any video or even A gif picture on facebook 85% shows like that, and only 15% works normally.. But on Youtube, Almost all videos work 98% without problems!!, this problem shows more on Facebook.. I have the latest version of my video card *Nvidia GT610 2G * And also Firefox Quantum.. And also the latest version of Adobe Flash Player.. *Windows 10, 8G Ram, Processor Intel Core I5 3470T* Although when I play any video from any other Browser, It works so normally without any problems at all!, but I love Firefox the most, I used to open from this great browser, I'm suffering from this problem for almost a year! please, I need a solution to this problem, HELP ME!

Asked by DM_22 3 years ago

Answered by Happy112 3 years ago

  • Solved
  • Archived

Hulu videos will not work

So moral of the story, I can't play hulu videos because firefox likes to say that widevine will be downloaded shortly but it never downloads. I don't know what the proble… (read more)

So moral of the story, I can't play hulu videos because firefox likes to say that widevine will be downloaded shortly but it never downloads. I don't know what the problem for this can be.

Asked by Dammy 2 years ago

Answered by Dammy 2 years ago

  • Solved
  • Archived

Windows 10 - Videos play with sound only - on other Browsers other than IE

My PC runs on OS Windows 10. Process: AMD Athlon II X4 650 Processor 3.20 GHz 8.0 GB RAM 64 Bit OS I am able to watch videos, except for LIVE streaming, at Youtube....N… (read more)

My PC runs on OS Windows 10.

Process: AMD Athlon II X4 650 Processor 3.20 GHz

8.0 GB RAM

64 Bit OS

I am able to watch videos, except for LIVE streaming, at Youtube....No matter what browser I use; the live stream are having same issue as below: no picture but the sound is there.

On other sites, I can see the video and hear it only if I use Internet Explorer. If I use Firefox I only get the sound. Here is an example of a site with this problem:

http://abcnews.go.com/GMA/video/jimmy-kimmel-haunted-best-picture-mix-2018-oscars-52545828

Another Website I have this problem is at Amazon.com. I can watch the actual Movies on all browsers with no problems; but if I watch a Trailer of a Movie on Amazon.com, I get no picture, just sound.....Except both the picture and sound work on trailers if I'm using IE.

I have reinstalled browsers, Checked installs on Flash. Firefox really runs slow on OS Win 10.

Asked by cokeefe 3 years ago

Answered by FredMcD 3 years ago

  • Solved
  • Archived

Youtube, Facebook and other embedded videos never load (FF 58.0.2)

I am unable to watch videos in Firefox since the last update. There is a spinning wheel and it never finishes loading. Since I reinstalled FF, there are no external plugi… (read more)

I am unable to watch videos in Firefox since the last update. There is a spinning wheel and it never finishes loading. Since I reinstalled FF, there are no external plugings. Tried re-install, restart, nothing worked. They do play properly in Chrome.

Asked by leonardoauc 3 years ago

Answered by FredMcD 3 years ago

  • Solved
  • Archived

I keep getting this message in my twitter feed "We cannot play the video in this browser. Please try a different web browser."

I recently installed Ubuntu 18.04 LTS OS on my computer. it came with firefox installed and ive updated all software and packages. Everything seems to work fine except fo… (read more)

I recently installed Ubuntu 18.04 LTS OS on my computer. it came with firefox installed and ive updated all software and packages. Everything seems to work fine except for this one persistent problem. my twitter feed won't display gif's and videos. I keep getting this message:"We cannot play the video in this browser. Please try a different web browser."

Asked by druan 3 years ago

Answered by James 3 years ago

  • Archived

video file not found

I'm a premium member at Bill O'Reillys and receive no spin news to view. I use to be able to view the no spin news up until approximately 7 weeks ago. I can no longer vie… (read more)

I'm a premium member at Bill O'Reillys and receive no spin news to view. I use to be able to view the no spin news up until approximately 7 weeks ago. I can no longer view the no spin news and I haven't got a clue as to why. I am not tech savvy and I have spent many hours trying to locate the problem unsuccessfully.

After signing into my account to view the video it gives me hlsjs:video file not found. I am able to view the video of the day but not the no spin news. I tried google chrome and Internet explorer and it says the same thing, video file not found. I'm sure there is someone that has the solution to my issue. Help and thank you.

Asked by Cosmo736 2 years ago

Last reply by Cosmo736 2 years ago

  • Archived

Facebook/Other videos error message: No compatible source was found for this media

Hello everyone, Problem: Error message: No compatible source was found for this media. Whenever I want to watch a video on Facebook or some other sites. Youtube/Twitch w… (read more)

Hello everyone,

Problem: Error message: No compatible source was found for this media. Whenever I want to watch a video on Facebook or some other sites. Youtube/Twitch work without problems.

Setup: Windows 10 firefox (60.0.1 x64), no addons and as plugins: OpenH264 and Shockwave Flash (29.0 r0)

Asked by Zwirni 3 years ago

Last reply by Zwirni 3 years ago

  • Solved
  • Archived

Fox News Channel player does not work on Firefox 60

I have repeatedly asked this question from Firefox version 53 through Firefox version 60, and have not received help from this forum. Why will FNC embedded video player n… (read more)

I have repeatedly asked this question from Firefox version 53 through Firefox version 60, and have not received help from this forum. Why will FNC embedded video player not work on FF. Error 2 is always displayed.

Asked by loyall 3 years ago

Answered by loyall 3 years ago

  • Archived

Some (rare) videos encoded with h264 stay black

Hi, It's the second time today i see a video with this codec (as stated by VLC) : H264 - MPEG-4 AVC (part 10) (avc1), that's not visible in Firefox, while it's audible. H… (read more)

Hi,

It's the second time today i see a video with this codec (as stated by VLC) : H264 - MPEG-4 AVC (part 10) (avc1), that's not visible in Firefox, while it's audible. Here is the video url : https://web.poecdn.com/public/news/2018-05-02/VLS_news.mp4 Previous one that also didn't work : https://web.poecdn.com/public/news/2018-04-17/NewRainofArrows.mp4

Some working with the same codec, still as stated by VLC can be found here : https://www.pathofexile.com/forum/view-thread/2034078 ; Change : Different CDN, no sound in these video. For a direct video link, here's one : https://imgur.com/BySFQ45.mp4

Not sure what's the issue here, if there's something new unsupported in openh264 or if it's just an issue for some users. I know i'm not the only one experiencing it, cf. https://www.reddit.com/r/pathofexile/comments/8csmvo/skill_revamps_part_3/dxhi8f6/

Edit : Seems like Imgur uses x264 (http://www.videolan.org/x264.html) to encode their videos (ftypisom : MP4 Base Media v1 [IS0 14496-12:2003]), while GGG (poecdn) used something else (Mainconcept Video Media Handler ; ftypmp42 : MP4 v2 [ISO 14496-14]).

Edit² : Bug report.

Asked by Harest 3 years ago

Last reply by Harest 3 years ago

  • Archived

video cannot be played because the file is corrupt

Hi, When I try to play .mp4 files in my Firefox 65.0.1 I am getting error "video cannot be played because the file is corrupt". Whereas its working fine in Google Chrome… (read more)

Hi,

When I try to play .mp4 files in my Firefox 65.0.1 I am getting error "video cannot be played because the file is corrupt". Whereas its working fine in Google Chrome. I tried all possible ways to get it sort. Help will be appreciated.

Thank you

Asked by jagapathiraju 2 years ago

Last reply by jscher2000 2 years ago

  • Archived

Why can I play only Youtube videos in Facebook for months now?

In Facebook, if someone posts a Youtube video, it plays with no problem. But for months now, no other type of video will play. When I click on, a new page opens on top of… (read more)

In Facebook, if someone posts a Youtube video, it plays with no problem. But for months now, no other type of video will play. When I click on, a new page opens on top of the old one with a large viewing screen and an arrow to click to play. Every time I click on it, it simply refreshes but does not play. I just updated the newest Adobe Flash player and restarted three times. Firefox is updated. I have Windows Vista.

Asked by TerryRA 3 years ago

Last reply by FredMcD 3 years ago

  • Solved
  • Archived

Video wont play

When I open video on youtube/liveleak or any other site. It loads but it wont start playing. On youtube I get "If playback doesn’t begin shortly try restarting your devi… (read more)

When I open video on youtube/liveleak or any other site. It loads but it wont start playing. On youtube I get "If playback doesn’t begin shortly try restarting your device". It started today. I cleared cache, turned off all addons It didnt help, so I refreshed Firefox. And it still doesnt work. I need help.

Asked by Zsim 3 years ago

Answered by Zsim 3 years ago

  • Archived

Videos that are not on a major website (YouTube, Twitter, Twitch, etc.) will not play

Like the title says, videos on YouTube or Twitch or Twitter all work perfectly fine. However, videos that are hosted by my university on their page or livestreams hosted … (read more)

Like the title says, videos on YouTube or Twitch or Twitter all work perfectly fine. However, videos that are hosted by my university on their page or livestreams hosted on smaller news websites do not work. They often show the loading symbol for 30 seconds or so an then state "The media could not be loaded, either because the server or network failed or because the format is not supported." or "No video with supported format and MIME type found." I've tried safe mode (I'm in safe mode now as I type this), and I've tried uninstalling and reinstalling Adobe Shockwave and Flash. None of these have fixed this issue.

One of the websites I'm trying to access is http://live.bhrt.ba/ . Any help is gratefully accepted.

Asked by PancakeSquid 3 years ago

Last reply by cor-el 3 years ago

  • Archived

uploaded Youtube video will not play on browser.

I've started making some promotional videos for my website recently and me not being the sharpest tool in the shed when it comes to computer tech, I ask a lot of question… (read more)

I've started making some promotional videos for my website recently and me not being the sharpest tool in the shed when it comes to computer tech, I ask a lot of questions first before I plunge in.

Now the problem I have here is as seen with some other questions that my browser does not support any of the video formats etc etc, giving me an html 5 error.

My software is Camtasia Studio 8, the exact same as one of my friends use, I had to ask him what format do I use for uploading to Youtube, he said to leave it as the default which was MP4 720p, which I did. After uploading was complete on youtube I got the error message; totally bizarre really because I can see videos he has made quite well, with the same settings. Generally I can see 99% of videos on youtube. (although I cannot see any at all on Dailymotion, but that isn't an issue)

My Browser is Firefox 52.9.0, my operating system is Windows XP.

Asked by Melanie86 2 years ago

Last reply by cor-el 2 years ago

  • Archived

flash is not working on my firefox ( 60/64)

im running windows 10 / 64 and i have Firefox (60/64) , my flash is up to date and running with no issues on chrome, on firefox not all websites are working , some of the… (read more)

im running windows 10 / 64 and i have Firefox (60/64) , my flash is up to date and running with no issues on chrome, on firefox not all websites are working , some of them not working at all and some will run and have pixelation and picture distortion ( and some website works fine ) . I did update my flash , reinstall it and make sure its active and non of this works , i reinstall firefox and that didt help. i never had an issue before ver 52 ( since stoop sporting flash) . Please help fixing this issue as i really like firefox and rather keep using it ( but not for long if its not supporting the website we used , and i don't think stop sporting flash was a good idea as i mentioned all these website running with no issues in chrome.

Asked by Sam T 3 years ago

Last reply by FredMcD 3 years ago

  • Solved
  • Archived

Movie Trailers or Clips will not play on Metacritic

Movie trailers will not auto-play after the 30 second intro ad. After the ad the video remains blank. This problem also exists when Firefox is restarted in safe mode. Wor… (read more)

Movie trailers will not auto-play after the 30 second intro ad.

After the ad the video remains blank.

This problem also exists when Firefox is restarted in safe mode.

Works fine when using other browsers such as Chrome or Edge!

Please look into this!

Asked by DeanA320 2 years ago

Answered by DeanA320 2 years ago