Showing questions tagged: Show all questions
  • Solved
  • Archived

Need to change ntlmv1 settings for users

We are currently using Firefox ESR 38.2.0 with our RHEL 6.7 workstations and need to change the network.negotiate-auth.allow-insecure-ntlm-v1 from the default of TRUE to … (read more)

We are currently using Firefox ESR 38.2.0 with our RHEL 6.7 workstations and need to change the network.negotiate-auth.allow-insecure-ntlm-v1 from the default of TRUE to FALSE.

We tried putting a .js file in /usr/lib64/firefox/defaults/preferences to change it, but the change is ignored.

When we try another setting in the file, such as perf("network.negotiate-auth.allow-insecure-ntlm-v1-https", false), then the change is made, however, with the ntlm-v1 setting, it is ignored in the file.

We can change the user_perf for network.negotiate-auth.allow-insecure-ntlm-v1 on a per user bases, but as an enterprise we would like to make this change for multiple users at once and not on a per profile.

Is there any way to do this, or is creating a script and placing it in /etc/profile.d the best option?

Thanks! Joe Giles

Asked by jagiles 5 years ago

Answered by cor-el 5 years ago

  • Archived

Why are Instagram videos not now displaying in Firefox 52 ESR?

Instagram videos have stopped displaying for me in Firefox 52 ESR. It happened suddenly a day or two ago. There isn't even a placeholder there for them on the page any lo… (read more)

Instagram videos have stopped displaying for me in Firefox 52 ESR. It happened suddenly a day or two ago. There isn't even a placeholder there for them on the page any longer, just the text that goes with them with nothing where the video should be. If I try to view one from someone's IG page, it just shows as a black box. Static images are still displaying fine, just not the videos.

This is on my old Windows XP machine, where I have to use FF 52.9.0 ESR as it's the last XP compatible version. The videos are fine in FF65 on my Windows 10 machine needless to say. I've tried spoofing different user agent strings, but no difference.

The strange thing is that on Google Chrome 49, again the last version which works on XP, the videos still display fine, and that is much older than FF 52 ESR! Also, if I right click on the IG page in FF 52 ESR, and select the "View Page Info" option, the videos still appear in the list on the "Media" tab, and if selected, they still display and can be played in the preview pane below, so they're obviously not being actually blocked, and the browser can still play them, they are just not displaying inline in the pages as they should!

Anyone any idea what's happening here? There's no point in me asking Instagram, as I know they will just say that they no longer support Firefox 52 ESR! Thanks, Dave.

Asked by Dave-H 2 years ago

Last reply by Dave-H 2 years ago

  • Archived

The ESR was downloaded and installed and the firefox browser is not recognizing it. How can I make it work?

Firefox upgraded to the latest version. My organization uses cloud based applications that require the ESR. I downloaded and installed the new ESR, refreshed firefox and … (read more)

Firefox upgraded to the latest version. My organization uses cloud based applications that require the ESR. I downloaded and installed the new ESR, refreshed firefox and created a new profile and the ESR extension is still not working.

Asked by cltuma 3 years ago

Last reply by TyDraniu 3 years ago

  • Archived

Unable to change update settings

My Firefox install seems to be stuck on "Never check for updates (not recommended: security risk)" changing the setting to "Automatically install updates (recommended: im… (read more)

My Firefox install seems to be stuck on "Never check for updates (not recommended: security risk)" changing the setting to "Automatically install updates (recommended: improved security)" does not persist after closing and re-opening the browser.

Asked by lazybones 5 years ago

Last reply by FredMcD 5 years ago

  • Archived

Firefox and all browsers crash while loading

I use Firefox as my main browser (new install of the latest version on Windows XP) but this is happening in Chrome, I.E. and Opera as well. I suspect it's a bigger proble… (read more)

I use Firefox as my main browser (new install of the latest version on Windows XP) but this is happening in Chrome, I.E. and Opera as well. I suspect it's a bigger problem than simply an issue with Firefox. I hope someone can help.

Sometimes Firefox launches just fine but then it crashes when I open a new tab. Especially if I click a link to open in a new tab, then it freezes up completely. Once that happens, I get a Not Responding message in Task Manager. I kill the process but then I can't get Firefox to open again, nor will Chrome, Opera, I.E. etc. launch. It helps if I restart the computer, but not always.

Other times I click the icon to launch Firefox and nothing seems to happen at all. When I look in Task Manager it seems like something is blocking Firefox from loading. It "chokes" at 4556kb, 7872kb, 8016kb, or sometimes as much as 8020kb. Then it stops. (A healthy instance of Firefox is 250,000kb or more, depending on how long I have been using it.) So it never fully loads the program.

I get similar results with other browsers. Chrome stops loading at 9540kb, I.E. stops at 6620kb, and so on.

This started yesterday and I've been trying to solve the problem ever since. With breaks for sleep and food I've been spending all day troubleshooting. I can't even remember all the fixes I've tried at this point.

The thing that keeps stumping me is why would it affect other browsers? If Firefox is corrupt I can reinstall it and fix the problem.

Also, I can't get Adobe Acrobat Reader to launch. I uninstalled that but haven't re-installed it yet. (Adobe's site is down.)

Can anyone think of a connection between different browsers? Or between Firefox and Adobe Reader? Is there some piece of Windows code that's common to all of these? It's a mystery!

Asked by DancinDave 3 years ago

Last reply by DancinDave 3 years ago

  • Archived

How I can download firefox for organization?

Раньше был путь release - firefox for organization а теперь его найти не могу. Как скачать ESR версию? Where link for download firefox for organization? … (read more)

Раньше был путь release - firefox for organization а теперь его найти не могу. Как скачать ESR версию?


Where link for download firefox for organization?

Asked by Maxim_al 4 years ago

Last reply by FredMcD 4 years ago

  • Archived

Nothing happens when I click on website email links.

Recently, despite making no changes to Mozilla Firefox software, I lost the ability to use email links on websites. It is not website-specific and I can still send emails… (read more)

Recently, despite making no changes to Mozilla Firefox software, I lost the ability to use email links on websites. It is not website-specific and I can still send emails through AOL Mail. What could have caused this and how do I fix it?

Asked by Andrea 3 years ago

Last reply by FredMcD 3 years ago

  • Archived

<button> with no label is not clickable

I am using 60.1.0esr and try to click on a <button> element where no text has been defined between <button></button>. Using 52.2.0 esr the button is cli… (read more)

I am using 60.1.0esr and try to click on a <button> element where no text has been defined between <button></button>. Using 52.2.0 esr the button is clickable. Do I miss something?

Asked by dioeus 3 years ago

Last reply by TyDraniu 3 years ago

  • Archived

Firefox tabs keep crashing

We are facing an issue with Mozilla Firefox when we try to deliver it via Application Virtualisation where the browser tabs continue to crash. We have tried launching thi… (read more)

We are facing an issue with Mozilla Firefox when we try to deliver it via Application Virtualisation where the browser tabs continue to crash. We have tried launching this in safe mode and the issue continues. Is there anything else we can do to troubleshoot this issue? or has anyone else experienced this issue?

We are experiencing a second issue where when we try sequencing Firefox with Adobe Flashplayer via AppV, the published application will not show the flash plugin in the firefox options screen. We can see that flashplayer has successfully installed within the AppV package but it seems to be failing to acknowledge the files in the browser. Has anyone experienced anything similar to this?

Thanks

Asked by Rhodri 8 months ago

Last reply by cor-el 8 months ago

  • Archived

tell me how to change back the setting we changed yesterday

had problems with script warning and the games were running very slow and would freeze. you had change a setting that help but it will not stay on other pages on the same… (read more)

had problems with script warning and the games were running very slow and would freeze. you had change a setting that help but it will not stay on other pages on the same site

Asked by frostyos2 2 years ago

Last reply by FredMcD 2 years ago

  • Solved
  • Archived

How do I prevent frequent plugin stalls ?

I'm running XP64 pro. The scripts on Yahoo will stall FF after a few minutes. Often I get the popup message that a plugin script has stalled and asks if I want to prevent… (read more)

I'm running XP64 pro. The scripts on Yahoo will stall FF after a few minutes. Often I get the popup message that a plugin script has stalled and asks if I want to prevent seeing this again from the site. That's nice but every page on Yahoo is unique. So the stall happens on every page that isn't closed after a short while. The more stalls I get the slower my computer runs even though I use task manager to kill stalled processes. Then I have to reboot to clear out the FF remnants. Is there a way to kill remnants of stalled scripts without rebooting? Often FF crashes and asks me to send a report to Mozilla. Seems to me you guys should have a feature to enable extended logging for inclusion in crash reports. I have sent many requests to fix the problem. If you guys can't fix the root cause of the problem then can you at least provide a decent workaround so the memory doesn't get cluttered up with orphaned threads sucking up all my CPU power?

Asked by John_is_annoyed_with_FF 3 years ago

Answered by FredMcD 3 years ago

  • Archived

Files containing Japanese characters are garbled in Firefox 68.6.0esr

After upgrading to Firefox 68.6.0esr, when we open a Japanese file with [File]->[Open], it becomes garbled and unreadable. Before upgrading, we could read the Japanes… (read more)

After upgrading to Firefox 68.6.0esr, when we open a Japanese file with [File]->[Open], it becomes garbled and unreadable. Before upgrading, we could read the Japanese file. This file is a plain text file and the character code is ISO-2022-JP. The character code is not specified in the file. I tried to change the character code with Text Encoding menu of Firefox, but the menu is grayed out and we cannot select it. It seems that files with character codes UTF and EUC can be displayed without problems. Is there a way to correctly display a Japanese file in which no character code is specified?

Regards,


Regards,

Asked by HAYASHI Tomoko 1 year ago

Last reply by HAYASHI Tomoko 1 year ago

  • Archived

Website no longer supporting FIrefox access

Firefox update (about 4 weeks ago?) resulted in losing access to various accounts eg: bank, health care provider. Forced to use Chrome (blech!) Websites now state that … (read more)

Firefox update (about 4 weeks ago?) resulted in losing access to various accounts eg: bank, health care provider. Forced to use Chrome (blech!) Websites now state that I'm using an "unsupported browser". Have contacted host sites and they are unresponsive and/or unable to provide solution. Can still access bank etc from Android phone but forced to use other browsers from MacBook Pro.

Thank you for your assistance!

Asked by meganhopeross 6 months ago

Last reply by cor-el 6 months ago

  • Archived

Changing the default channel-prefs.js

Hi, i have been given task to change config for Mozilla ESR users in our company. I'm trying to change the value "security.enterprise_roots.enabled" which is disabled by … (read more)

Hi,

i have been given task to change config for Mozilla ESR users in our company. I'm trying to change the value "security.enterprise_roots.enabled" which is disabled by default in update channel "esr". Is it safe to push (mass copy) new file "channel-prefs.js" with modified preference or there is another way?

pref("app.update.channel", "esr"); /* extra code */ pref("security.enterprise_roots.enabled", true);

Asked by igic 3 years ago

Last reply by cor-el 3 years ago

Firefox removes the authentication header from request

am seeing an issue in firefox on unix with accessing a web page which uses basic http authentication mechanism. It pops up for user id and password for basic authenticati… (read more)

am seeing an issue in firefox on unix with accessing a web page which uses basic http authentication mechanism. It pops up for user id and password for basic authentication. When I enter the credentials and click submit the response received is 401 Unauthorized. Same webpage and authentication works in chrome browser on same system (so assuming no firewall issues). The Firefox and chrome is configured in a console where we test it. And both are requesting for the same host. I believe there is some configurations issue in Mozilla firefox that might be affecting it. Attaching the request and response for both.

Firefox version that has a problem : Mozila Firefox 78.4.0esr


Request and response in Chrome

Request

   GET /content/ HTTP/1.1

Host: 3.87.81.51 Connection: keep-alive Cache-Control: max-age=0 Authorization: Digest username="admin", realm="Power Xpert", nonce="16981e9013fd33c215fb54cfe5c8246b", uri="/content/", response="527760ce114bf839a9df342ba27ca352", qop=auth, nc=00000002, cnonce="572ab111183b3236" Upgrade-Insecure-Requests: 1 User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.101 Safari/537.36 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9 Accept-Encoding: gzip, deflate Accept-Language: en-US,en;q=0.9

Response -

HTTP/1.1 200 OK Content-Type: text/html ETag: "1471035255" Last-Modified: Mon, 23 Jun 2014 19:17:18 GMT Content-Length: 7452 Date: Wed, 09 Jun 2021 21:52:49 GMT Server: lighttpd/1.4.28-devel-59460


Request and response in Firefox

Request : GET /content/ HTTP/1.1 Host: 3.87.81.51 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0 Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Language: en_us,en;q=0.5 Accept-Encoding: gzip, deflate DNT: 1 Connection: keep-alive Upgrade-Insecure-Requests: 1

Response:

HTTP/1.1 401 Unauthorized WWW-Authenticate: Digest realm="Power Xpert", nonce="3743c840c84a56d1e56be155dc3284c1", qop="auth" Content-Type: text/html Content-Length: 351 Date: Wed, 09 Jun 2021 21:57:57 GMT Server: lighttpd/1.4.28-devel-59460

The difference is :

Below Authentication header is missing in firefox.

Authorization: Digest username="admin", realm="Power Xpert", nonce="16981e9013fd33c215fb54cfe5c8246b", uri="/content/", response="527760ce114bf839a9df342ba27ca352", qop=auth, nc=00000002, cnonce="572ab111183b3236"

Some setting in firefox is making this. I am not sure which one. Please help on this. Thanks in advance.

Asked by bhabani.pattanayak 3 months ago

Last reply by bhabani.pattanayak 2 months ago

  • Archived

Recent versions of Firefox not working properly under Linux (Ubuntu 14.04) when $HOME is a NFS mounted file system

I am managing a group of network booted Ubuntu 14.04 workstations at a small town (public) library and the current version of Firefox for Ubuntu 14.04 crashes. The machi… (read more)

I am managing a group of network booted Ubuntu 14.04 workstations at a small town (public) library and the current version of Firefox for Ubuntu 14.04 crashes. The machine have all of the file systems NFS mounted. Installing an older version (Firefox 52.6.0 ESR) works however. The new version of Firefox works just fine on the pair library owned laptops, that also run Ubuntu 14.04, but the laptops are self-contained -- they boot off their local disks. Why is this? I have pretty much determined that the only definable issue is that the network booted machines are using NFS for their file systems. No, the workstations are not sharing logins -- each machine auto-logins to a *different* user, each with their own *separate* $HOME directory and they are *not* trying to share firefox configuration trees ($HOME/.mozilla/firefox/...). But all of these directories are NFS mounted. Oh, the server for the /home file system is running CentOS 6.

Asked by RobertHeller 3 years ago

Last reply by cor-el 3 years ago

  • Archived

Updating Firefox esr 52.9.02 - refuses to save passwords

Got recently a notification that I must update Firefox esr 52.9.02 to new 60.x esr version. Problem is, after the upgrade only 5 of the many passwords were actually saved… (read more)

Got recently a notification that I must update Firefox esr 52.9.02 to new 60.x esr version. Problem is, after the upgrade only 5 of the many passwords were actually saved - rest were not showing up. Tried fiddling with the logins.json and key3.db (move them to replace the new ones) no help. What´s going on? How can I get the software to show all stored passwords? Oddly the size of the new logins.json implied they were in the file, but would not show up. Downgraded and - no problems, they work.

Asked by JaRiMi 3 years ago

Last reply by Shadow110 3 years ago

  • Archived

Firefox crahes on large and long xml download

I've an online service where I download large XML files. After clicking on the download button the page is loading for a long time (file is generated on demand), than a … (read more)

I've an online service where I download large XML files. After clicking on the download button the page is loading for a long time (file is generated on demand), than a new window/tab is opened with the download URL and is loading for a long time. Than Firefox crashes: "Gah. Your tab just crashed."

How do I get info what the problem is? Is the file to big for the XML renderer? Or any other?

Asked by Paul.FE 2 years ago

Last reply by FredMcD 2 years ago