Showing questions tagged: Show all questions
  • Solved
  • Archived

How to disable audio indicator icon in pinned/unpinned tabs after removal of browser.tabs.showAudioPlayingIcon ?

Hello, suddently after upgrading my Firefox Developer Edition to version 77 I noticed that my pinned tabs have sound icon again, which i previously disabled using browser… (read more)

Hello, suddently after upgrading my Firefox Developer Edition to version 77 I noticed that my pinned tabs have sound icon again, which i previously disabled using

browser.tabs.showAudioPlayingIcon = false

Now however I found that it was removed here:

https://hg.mozilla.org/mozilla-central/rev/1360dbbd2d6d

How can i disable this annoying audio icon now ?

Asked by Nikita 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Firefox doesn't play "flac" file from web page, but does play if downloaded

http://hpr.dogphilosophy.net/test/index.php This is an audio test page to see what is supported by the browser Everything plays fine. But when I tested the "flac" file, t… (read more)

http://hpr.dogphilosophy.net/test/index.php This is an audio test page to see what is supported by the browser Everything plays fine. But when I tested the "flac" file, there was an error. However, when I downloaded the file, opened my file browser, then dropped the "flac" file into Firefox, it played just fine using the VLC plugin.

So why can't Firefox play the file online, but does from a file?

Asked by FredMcD 5 years ago

Answered by cor-el 5 years ago

  • Solved
  • Archived

No sound or audio in flash.

I have: Firefox 38.0.5 Shockwave Flash 18.0.0.160 Problem is that when I watch a video that is NOT in youtube, there seems to be no sound. This happens on sites such as: … (read more)

I have: Firefox 38.0.5 Shockwave Flash 18.0.0.160

Problem is that when I watch a video that is NOT in youtube, there seems to be no sound. This happens on sites such as: twitch.com kissanime.com (In this site the have the option to play videos in HTML5, which works fine) and website with flash games like: kongregate.com

Asked by Cypherial 6 years ago

Answered by Cypherial 6 years ago

  • Solved
  • Archived

Frame skipping on any audio or video

I've recently built a desktop PC with this configuration: Ryzen 7 1800X Geforce GTX 750 Ti (driver version: 399.07) 16GB DDR4 RAM 250GB SSD + a HDD for data only, no sys… (read more)

I've recently built a desktop PC with this configuration:

Ryzen 7 1800X

Geforce GTX 750 Ti (driver version: 399.07)

16GB DDR4 RAM

250GB SSD + a HDD for data only, no system files

Windows 10 64bit

External Sound card Scarlett 2i4 1st gen. [it worked fine with my old Windows7 desktop]


Any audio (soundcloud, zophar.net/music) or video (youtube, twitch, facebook) stream has the same problem: it randomly skips frames. I mean that video nor audio are interrupted, they continue, but they skip some "frames".

This bug occurs with the current official version, the current beta version and the current Nightly.

This bug does not occur on my laptop, windows 8 running an i5 CPU and no dedicated GPU.

This bug does not occur on other apps. I've tried: VLC, Facebook app, Twitch app, Microsoft Edge, Internet Explorer, Winamp.

Asked by DeRobyJ 3 years ago

Answered by DeRobyJ 3 years ago

  • Solved
  • Archived

NO SOUND IN FIREFOX AFTER LAST WIN 7 UPDATE. OPERA WORKS

Everything worked fine until latest Win 7 update, but i have no functioning 'restore point' to rollback to, so i have to find a workaround. Sound works on the PC, i can … (read more)

Everything worked fine until latest Win 7 update, but i have no functioning 'restore point' to rollback to, so i have to find a workaround. Sound works on the PC, i can play mp3's or mp4's fine. But audio from Youtube or FaceBook or BBC Iplayer is absent when i open these sites in Firefox. (yes i've checked for volume and muting, i've cleared the cache i 've tried in safe mode, all without success) I tried one modification to the registry which worked ONCE and not afterwards.....which is of course impossible. If i open the very same sites in Opera...the audio is perfect. WHAT ON EARTH is going on and how do i put this right? Thanks in advance for any insights and fixes.

Asked by Arbuth 2 years ago

Answered by FredMcD 2 years ago

  • Archived

YouTube HTML5 audio buzzes

Hello, I have a weird problem on YouTube where it makes a loud buzzing sound and it really scares the heck out of me. I want to have this fixed ASAP, so I have a debug co… (read more)

Hello, I have a weird problem on YouTube where it makes a loud buzzing sound and it really scares the heck out of me. I want to have this fixed ASAP, so I have a debug code: {"ns":"yt","el":"detailpage","cpn":"wJMwdG7_XWmSboDD","docid":"Fg6bbj48ggw","ver":2,"referrer":"https://www.youtube.com/results?search_query=judas+priest+screaming+for+vengeance","cmt":"1861.227","plid":"AAUh7aVU9z1uzWcy","ei":"GA8cVoX2BtSuuwLrh4Bo","fmt":"136","fs":"0","rt":"37.086","of":"a-3xVZTGmL2lajGtNblYnA","adformat":null,"content_v":null,"euri":"","subscribed":null,"lact":1,"live":null,"cl":"104915008","mos":0,"osid":null,"state":"4","vm":"CAIQAQ","volume":95,"c":"WEB","cver":"html5","cplayer":"UNIPLAYER","cbr":"Firefox","cbrver":"41.0","cos":"Windows","cosver":"10.0","hl":"en_GB","cr":"CA","len":"3075.204","fexp":"9407610,9408710,9409069,9414732,9414764,9416126,9417259,9417707,9418058,9418391,9418448,9418778,9418959,9419341,9419445,9419786,9419788,9420348,9420458,9420533,9420569,9421013,9421024,9421645,9421793","afmt":"140","vct":"1861.227","vd":"3075.204","vpl":"0.000-0.101,1835.702-1835.835,1840.835-1861.227,1909.797-1913.012,2106.149-2108.741,","vbu":"0.000-3.645,1831.830-2417.359,","vpa":true,"vsk":false,"ven":false,"vpr":1,"vrs":3,"vns":2,"vec":null,"lct":"1861.227","lsk":false,"lmf":true,"lbw":"2063773.802","lhd":"0.129","ltd":"0.000","laa":"itag=140,seg=241,range=38730313-38810650,time=2412.4-2417.4","lva":"itag=136,seg=482,range=82639376-82833051,time=2412.4-2417.4","lar":"itag=140,seg=244,range=39173552-39333713,time=2440.0-2450.0","lvr":"itag=136,seg=498,range=85390880-85592739,time=2492.5-2497.5","lvh":"r5---sn-5aanugx5h-tfbe","lab":"0.000-3.645,1830.011-2417.359,","lvb":"0.000-10.010,1831.830-2417.415,","ismb":7760000,"debug_videoId":"Fg6bbj48ggw","cgr":true,"debug_playbackQuality":"hd720","debug_date":"Mon Oct 12 2015 14:51:22 GMT-0500 (Central Standard Time)"}

Asked by sabbath99 6 years ago

Last reply by sabbath99 5 years ago

  • Archived

Audio stops playing after 2-3 seconds

The issue: on all sites, whenever media with audio plays (either automatically, or when I click), the audio stops after 2-3 seconds. If it is video, the video continues t… (read more)

The issue: on all sites, whenever media with audio plays (either automatically, or when I click), the audio stops after 2-3 seconds. If it is video, the video continues to play without sound. When it is audio-only, such as bandcamp, the timestamp stops. Audio resumes playing if I rewind or manually move the timestamp handle (scrubber?) back. This must be repeated each time the media is paused. Audio does not resume playing if play and pause are pressed, or if the site is refreshed.

Troubleshooting steps attempted so far:

  • Tried a different browser. Microsoft Edge works just fine.
  • Allowed autoplay for both audio and video
  • Cleared cache, and ensured that cookies were allowed
  • Turned off all adblockers
  • Uninstalled flash
  • Refreshed firefox settings

I'm at a loss!

Asked by juniper.mitchell 11 months ago

Last reply by FredMcD 11 months ago

  • Solved
  • Archived

when opening a second TAB, the first TAB will stop streaming a Podcast

Hello to All: I need some help. About 15-20 days ago, I had to re-install my Windows 7 (32-bit) OS and all software including Mozilla Firefox Quantum (32-bit). Since in… (read more)

Hello to All: I need some help. About 15-20 days ago, I had to re-install my Windows 7 (32-bit) OS and all software including Mozilla Firefox Quantum (32-bit). Since installing Mozilla Firefox Quantum 67.0 (32-bit) - when I use a "TAB" to listen to streaming: Live internet radio or Podcast, all is good. The problem is when I open a second "TAB" to surf or view info. When I start to click on anything (ex: next page), the first "TAB" playing the Podcast will stop playing and return to the beginning of the Podcast. This only happen when opening a second "TAB". This never happen before. Can it be the new update to level "67.0" or a bad installation of Firefox? Should I un-install Firefox and then re-install Firefox?

Asked by String-One 2 years ago

Answered by cor-el 2 years ago

  • Archived

Audio is muted invisibly at seemingly random intervals.

Audio randomly stops. Mostly noticed on youtube. Audio cuts out after 2-30 minutes so testing is difficult. Videos will continue to play but the audio cuts out. The volum… (read more)

Audio randomly stops. Mostly noticed on youtube. Audio cuts out after 2-30 minutes so testing is difficult. Videos will continue to play but the audio cuts out. The volume setting on the video is not effected, the mute icon on the tab is not indicated. Other audio sources on the PC continue when the audio in firefox stops. Stopping and starting the video can make the audio play again but not always right away. This can happen on all videos, the audio is not missing from the videos, clicking back to where the audio stopped after getting the audio to play again reveals the audio is in the video.

I tried giving permission in firefox for youtube to autoplay with audio and video, the problem still occurred.

I have not seen this happen in chrome. Testing playing the same video at the same time resulted in the firefox audio eventually cutting out and the chrome audio continuing.

It happens even when nothing else is running and when I am not doing anything else on the computer so I'm reasonably confident this is an issue in firefox.

It still happens after "restarting firefox with add-ons disabled".

First noticed on version 74.1 but it has continued to happen on 75.0

Asked by Matt 1 year ago

Last reply by Matt 1 year ago

  • Archived

Firefox does not respect macOS system audio playback routing

I am using the latest Firefox 65 on macOS 10.13.6. Issue: No audio playback can be heard through the browser. I am using a Soundcraft Signature 22 MTK multi-channel inter… (read more)

I am using the latest Firefox 65 on macOS 10.13.6.

Issue: No audio playback can be heard through the browser. I am using a Soundcraft Signature 22 MTK multi-channel interface where audio playback is routed through channels 21/22 through Audio Midi settings in macOS.

It seems that Firefox is hard coded (and incorrectly assumes) all systems will default to channels 1-2 for audio playback.

I can tell it's defaulting to 1-2 because if I route audio to those channels in macOS and then us the USB return on those channels on my console, I can hear sound.

It should be respecting how audio is routed at the system level.

Asked by zerodistraction 2 years ago

Last reply by WestEnd 2 years ago

  • Archived

Firefox audio issues

Firefox is not playing in any external audio device(Bluetooth speaker or headphones). But it is audible directly from my laptop. The audio devices play from all other app… (read more)

Firefox is not playing in any external audio device(Bluetooth speaker or headphones). But it is audible directly from my laptop. The audio devices play from all other applications like vlc.

Asked by anamika1311 2 years ago

Last reply by anamika1311 2 years ago

  • Archived

No Audio when using My Firewire Mixer with Firefox.

Folks - I have an issue - I've tried all the threads I can find about Audio, and tried so many solutions - but they don't work. Here are the facts: 1 - Firefox Audio wor… (read more)

Folks - I have an issue - I've tried all the threads I can find about Audio, and tried so many solutions - but they don't work. Here are the facts: 1 - Firefox Audio works fine on my Mac and internal Speakers. 2 - Firefox Audio does NOT work when I'm using my Firewire Presonus 16.0.2 Mixer for sound. It is always connected to this mixer cause I use this MacBook pro for recording. 3 - All "Drivers" - which aren't really a thing for Macs - are up to date for the hardware path from Mac to Mixer. Goes MBPro -> OWC Thunderbolt 3 Dock (with a thunderbolt 3 cable) -> Firewire 800 cable out to Presonus Mixer. 4 - all other system Audio and the same websites sites work on other browsers like Chrome, safari...etc.

So I need help figuring out where the breakdown happened - this stopped working sometime over the summer. It had worked perfectly up till then. I can't understand why all other sounds on my system work great through my Audio interface, and even Firefox Audio works fine when going through the system speakers. It just seems like at some point Firefox decided to specifically reject my Audio interface.

Please look for solutions that are more advanced to start with - I've done every simple trouble-shooting tip one could think of. and I'm only reaching out at this point for support because this seems like an error in the code. Either Firefox is no longer supporting Firewire devices, or no longer supporting Pre-sonus devices, or thunderbolt docks? Dunno...

Asked by EddieShredder 3 years ago

Last reply by Shadow110 3 years ago

  • Archived

autoplay options have effect - cnn.com, etc

I have never been able to get autoplay options to prevent blasting out audio when stumbling onto a malicious website like CNN. This is a major privacy problem as perhaps … (read more)

I have never been able to get autoplay options to prevent blasting out audio when stumbling onto a malicious website like CNN. This is a major privacy problem as perhaps you don't want the world to know you are studying how to seek legal or medical help etc with audio blasting out at max level.

I don't know why this is so hard to manage since detecting loud audio isn't that difficult and it seems like browsers have all sort of hooks into media features of the operating systems they run on.

Can't firefox take samples of the audio (we don't need advanced signal processing here), determine that it is blasting out, and kill it?

In any case I have never been able to get any impact from autoplay settings other than to screw up my browsing experience so bad I have to reset to defauts to even manually play a video.

Addins like no script are so restrictive they render browsing impossible.

Asked by Robert 1 year ago

Last reply by Robert 1 year ago

  • Archived

facebook Audio distortion

MacBook Pro, OSX 10.7.5, Firefox 46.0.1 Facebook audio is distorted. Sounds like it's on a wave or the volume is going up and down, up and and down. I've ran in SafeMode… (read more)

MacBook Pro, OSX 10.7.5, Firefox 46.0.1

Facebook audio is distorted. Sounds like it's on a wave or the volume is going up and down, up and and down.

I've ran in SafeMode with all add-ons off, still get that distorted audio.

Thank you for you time.

Tim.

Asked by tschafer521 5 years ago

Last reply by FredMcD 5 years ago

  • Archived

How to go back to old behavior where browser needed to be closed before a different audio device would be used?

I found it useful to have Firefox stick to a certain sound device until it was closed. This allowed me to set my audio output to speakers, open a new window, put on Netfl… (read more)

I found it useful to have Firefox stick to a certain sound device until it was closed. This allowed me to set my audio output to speakers, open a new window, put on Netflix and switch that window to the projector. Now that the audio output changes as soon as I click the "set default" button, this is no longer possible! Firefox does not have an option to set the preferred sound output either.

https://support.mozilla.org/en-US/questions/1043172

I can see in the above link that this was a "bug" fixed in a beta and later on, a full release. How can I get this old behavior back?

Asked by jesh462 6 years ago

Last reply by jesh462 6 years ago

  • Archived

Cracking in Youtube audio in firefox

Sometimes when I'm watching a longer youtube video and do stuff in other tabs or windows (even checking something in the taskbar the audio goes all cracky and I remember … (read more)

Sometimes when I'm watching a longer youtube video and do stuff in other tabs or windows (even checking something in the taskbar the audio goes all cracky and I remember a solution once (that involved closing any intel programs via the task manager) but I checked and those programs weren't open.

I have windows 8.1 and the latest version of firefox

Please someone help me this is really annoying.

Asked by maswartz 4 years ago

Last reply by Wesley Branton 4 years ago

  • Archived

Audio breaks up in YouTube and other videos?

Recently all the audio breaks up badly on YouTube and ssome other videos that I play (the other videos may be a YoouTube sorce). I have tried reloading the mozilla updat… (read more)

Recently all the audio breaks up badly on YouTube and ssome other videos that I play (the other videos may be a YoouTube sorce). I have tried reloading the mozilla updates, gone back to older versions and tried the "reset" and nothing seems to work. All my downloaded vidoes, DVD's and programs seem to be working just fine so I don't think I am having hardware issues. It doesn't even happen every time but when it does it happens on everything on YouTube.

Asked by tag78 6 years ago

Last reply by tag78 6 years ago