Showing questions tagged: Show all questions
  • Solved
  • Archived

On playing online videos screen flashes, goes blank until site / video is closed

So, for awhile now when I go to some sites, the screen suddenly starts flashing, then it jitters and turns some light color (like a light green; not blue screen, not blac… (read more)

So, for awhile now when I go to some sites, the screen suddenly starts flashing, then it jitters and turns some light color (like a light green; not blue screen, not black). If I guess where the "X" is to shut down the tab that has the video, I can end this. Often, like on youtube, I find the problem is some ad video that was playing. The rest of the site is ok. But not always.

One site I wrote down a few days where it happened: https://www.nbcsports.com/philadelphia/eagles/eagles-face-giants-2022-playoff-opener?cid=sm_npd_rsn_phi_fb_mn&fbclid=IwAR3rGUEa0W8fElrzCWANSIUpti9VKlbn0iHyvcFsviajYExo5tcRSyWBJXA

scroll down to video and everything blinks, becomes unuseable

It happens in lots of places, though. It is not per se a YouTube problem or just a problem at NBCSports. I shell out to MS Edge, and it seems to handle everything fine, so I'm assuming at this point it is a browser issue.

One last point: after this happen the screen display is degraded even after I manage to shut down the offending tab or video. It takes a Log off/log back in or reboot to fix everything. The degradation takes the form of making the screen look a bit like a pointilist painting, although that's an exaggeration.

FF 109.0.1 64 bit Windows 11 NVidia GeFORCE RTX 3060 running studio driver 526.98 (I have switched periodically from / to their gaming driver, which doesn't seem to matter)

Any help, appreciated.

Asked by monsieurms 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Bypass Microsoft Teams block

I'm trying to use Microsoft Teams in Firefox because the native app for Linux is abandoned and crashes, and at first sight the app is blocking Firefox on purpose. Buttons… (read more)

I'm trying to use Microsoft Teams in Firefox because the native app for Linux is abandoned and crashes, and at first sight the app is blocking Firefox on purpose. Buttons to make calls are disabled, stating that audio and video are not supported in my browser, but everything works normally if join to existing calls using e.g. links.

Is it possible to trick Teams to think I'm using Chrome? I found the "User-Agent Switcher and Manager" add-on, but I can't figure out how to possibly use it.

Asked by Álvaro González 7 months ago

Answered by TyDraniu 7 months ago

  • Solved
  • Archived

Firefox doesn't display the font Helvetica correctly

The attached image shows Firefox (on the right) not displaying Helvetica correctly. It appears jagged and not pleasant to look at. The browser on the left is Edge and a… (read more)

  • The attached image shows Firefox (on the right) not displaying Helvetica correctly. It appears jagged and not pleasant to look at. The browser on the left is Edge and all Chromium based web browsers seem to render it as it should.
  • I've tried to look into (about:preferences#general) and the option that says (Allow pages to choose their own fonts, instead of your selections above) is ticked.
  • I've also tried reinstalling the browser, clearing the website cache and also, removing my profile from it. None of these seemed to fix the issue.
  • It's been persistent for quite some time now, however I didn't really find any articles regarding this issue.
  Any help would be greatly appreciated!

Asked by CircuitMoon 1 year ago

Answered by TyDraniu 1 year ago

  • Solved
  • Archived

Cloudflare hosted site complains about Firefox but works with Chrome

This site, Costco Instacart, worked perfectly with Firefox as recently as April 15, 2023 but today fails (see attached image): https://sameday.costco.com/store/costco/sto… (read more)

This site, Costco Instacart, worked perfectly with Firefox as recently as April 15, 2023 but today fails (see attached image): https://sameday.costco.com/store/costco/storefront?zipcode=11021

Cloudflare believes it is protecting itself from online attacks when accessed by Firefox. The same site worked perfectly today, on the same computer, using Google Chrome.

Cloudflare is a major CDN and many important commercial sites, like Costco Instacart, have their content delivered by Cloudflare so this is a major issue with Firefox. For the moment there is a work-around, use Chrome instead, but it would be better to have Firefox address issues with Cloudflare.

Asked by em2jacks 11 months ago

Answered by em2jacks 11 months ago

  • Solved
  • Archived

Firefox logging me out of all sites when I "delete history"

Hello, this problem started happening around 3 or 4 days ago. Usually, at the end of the day or before I close Firefox, I "delete browsing history" BUT only the "today"… (read more)

Hello,

this problem started happening around 3 or 4 days ago.

Usually, at the end of the day or before I close Firefox, I "delete browsing history" BUT only the "today" history. I know it's a weird habit (lol), but at least it logs me out of all recent browsing while keeping my sessions with older websites active (typically these older websites include stuff that I use frequently like Outlook, Google/Youtube, Twitter & other social media, Spotify, and a few other sites).

The other reason I do this is that I like my "recent history" to be ordered the way I like, so I can use it kind of like a "bookmark list".

The problem: Since about 4 days ago, each time I "delete history", ALL my accounts are signed out. Note that I don't have the option to delete cookies upon closing checked, and whenever I close Firefox without deleting history the sessions appear to be active.

I think 3 or 4 days ago there was a Firefox update? I remember at the time I was shown the extra tab with the release notes, but I didn't pay much attention. However when I noticed the issue, which was the day after, I assumed it was a new feature of the update that caused all these websites not to recognise my browser and thus ask me to log in again.

So just before going to bed, I tried 1) clearing my history for the day as I usually do, except 2) instead of closing directly after, I would go to the sites I want to remain logged in (in this case I just did Outlook, Youtube, Twitter, Facebook, Tiktok and Spotify), log into my accounts, and then close the browser.

So the following day, it worked "as usual"... almost... that is because when I deleted my history of the day, it logged me out of everything again. But in the "recent history" list, it showed the updated list (with the websites I re-logged into the day before).

So I can't guess what is happening, other that something is messing with my cookies each time I delete history. I even went to check manually to see if I still had the session cookies stored in Firefox and it appears to be the case.

Yesterday I also tried logging into a Google, waiting a few hours, and only deleting the history of the past hour, but the same thing happens, I instantly get logged out.

Additional info: when I "delete history" I only check the first five options (those under history) and not the lower two (under data).

Thanks for your help, and sorry for my English !

Asked by Mooray 1 year ago

Answered by AliceWyman 1 year ago

  • Solved

Spotify webplayer on Firefox is unuseable after updating to latest version

Majority of the songs do not play and I'm given with a pop-up, "Spotify can't play this right now. If you have the file on your computer you can import it." I will play … (read more)

Majority of the songs do not play and I'm given with a pop-up, "Spotify can't play this right now. If you have the file on your computer you can import it."

I will play a song from a playlist and is given that pop-up, it will continue skipping to the next song until it plays, but only for 9-10 seconds until the song mutes, to specify, the dot (when hovered on the progress bar) will still move, indicating that "it's playing".

Some clarifications: 1. I use Spotify Desktop app (windows), Spotify App (android), and Spotify Webplayer on Chrome and Firefox. Everything works just as fine on all of these, except for Spotify Webplayer on Firefox. 2. Skipping to a later timestamp does not unmute the song. 2. I have Spotify Premium 3. I have no VPN 4. I am running Firefox with an ad blocker 5. I am running Chrome with an ad blocker (same ad blocker in Fifefox) 6. I am running Firefox to the latest version (Firefox 119.0.1 (20231106151204))

What I've done so far: 1. Cleared caches and data. 2. Updated my Windows to the latest update available - Win10 v.22H2 3. Signed-out of Spotify for all my devices, then logging-in first on Spotify Desktop (this automatically redirects to Firefox webplayer) 4. Ran Firefox on "Troubleshoot Mode" 5. Un-checked and re-checked "Play DRM content" setting. 6. Disabled and re-enabled the plug-in "Widevine Content Decryption Module by Google Inc". (this plug-in is last udpated on November 17, 4.10.2710.0

I'm including this link from Spotify's Community page.. where two other users, who commented it is only with Firefox (webplayer), are experiencing the same problem as I am. https://community.spotify.com/t5/Desktop-Windows/Spotify-can-t-play-this-right-now-If-you-have-the-file-on-your/m-p/5679914#M123192

Asked by kit 4 months ago

Answered by zeroknight 4 months ago

  • Solved
  • Archived

Youtube Constantly Buffering after Pausing and Resuming

I've been watching and following along with a Unreal Engine 4 Course on Youtube for some time now (mentioning in case the resource usage has something to do with it), and… (read more)

I've been watching and following along with a Unreal Engine 4 Course on Youtube for some time now (mentioning in case the resource usage has something to do with it), and in the past couple days I've noticed a pretty serious and annoying bug. When I pause the video, tab (Cmd + Tab on MacOS) into Unreal Engine, do some things, then tab back and resume the video, it will play for one frame and then stop and buffer, but the audio will continue playing. The only way to get the video to resume is to skip forward/backward in the video (either with the arrow keys or the progress bar). I've also tried Troubleshooting/Safe mode and the issue still persits.

Asked by beatzoid 9 months ago

Answered by beatzoid 8 months ago

  • Solved
  • Archived

Unicode Missing Characters

Expected: Firefox displaying all known Unicode characters. Result: Many characters missing. Failure page as an example: https://en.wikipedia.org/wiki/Religious_and_poli… (read more)

Expected: Firefox displaying all known Unicode characters.

Result: Many characters missing.

Failure page as an example: https://en.wikipedia.org/wiki/Religious_and_political_symbols_in_Unicode

Description: I tried going through a Unicode list Unicode list and the extensive set of characters displayed correctly. However, when reaching further into character sets as shown in the failure page page, many are missing which are not new.

  • "Repair encoding. . ." button was not active.
  • An encoding switch extension was not able to resolve the issue.
  • Troubleshooting mode did not show changes.
  • Switched fronts available such as Noto Sans and Roboto Sans without success. Possibly a font failure?

Asked by mistry01 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Error 3000 in twitch

Hello guys, I just got a new M2 SSD and I just decided to reinstall Windows and everything on it. However, when I installed Firefox I started getting this exact error me… (read more)

Hello guys,

I just got a new M2 SSD and I just decided to reinstall Windows and everything on it. However, when I installed Firefox I started getting this exact error message on all twitch streams: "Your browser encountered an error while decoding the video. (Error #3000):. Keep in mind I have tried most if not every "fix" I've found. I've disabled the hardware acceleration, cleared cookies and cache, I've disabled the extensions, I've tried Incognito mode, I do not have a third-party anti-virus and I do not have a VPN. This works on all other browsers and it used to work on Firefox before I wiped my PC, so that I can install Windows again. I really do not want to use a different browser, I love everything about Firefox right now.

Any suggestions will do, thank you very much.

Asked by ae.dimitar 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Discord media not working

media like .gif files and .mp4 files are used very frequently in the Discord servers I'm in and for some reason whenever those specific file types are used won't load/fun… (read more)

media like .gif files and .mp4 files are used very frequently in the Discord servers I'm in and for some reason whenever those specific file types are used won't load/function. I noticed that while the DRM icon was present in the discord tab, that those two file types worked just fine; but I have no clue how to set it to always turn on for specific sites.

Asked by Fleur 8 months ago

Answered by Paul 8 months ago

  • Solved
  • Archived

Secure Connection Failed

Hello. On some of my sites that i try to get onto with Firefox its says performing TLS handshake then it goes to Secure Connection Failed and says PR_End_Of_File_Error. I… (read more)

Hello. On some of my sites that i try to get onto with Firefox its says performing TLS handshake then it goes to Secure Connection Failed and says PR_End_Of_File_Error. I am totally updated with Firefox, plus i cleared out everything in my history. That did not help. When i tried to get onto these websites with Chrome web browser i do not have this problem at all. Why is this? I have BitDefender Total Security newest version for home. My firewall is through them along with virus protections. So can you help me out with this ongoing problem getting on some websites?

Thanks Firefox [email removed from public]

Asked by raftman111 1 year ago

Answered by Bithiah 1 year ago

  • Solved
  • Archived

i can't play some (but not all) youtube videos with firefox 106.0.3

i can't play some (but not all) youtube videos. they do play on other web browsers. the message is "an error occured, please try again later. playback ID is ... " i'… (read more)

i can't play some (but not all) youtube videos. they do play on other web browsers.

the message is "an error occured, please try again later. playback ID is ... " 

i'm using firefox 106.0.3 on linux suse tumbleweed. Before I upgraded to both of these the same videos were playing ok.

Asked by ruthtoby 1 year ago

Answered by ruthtoby 1 year ago

  • Solved
  • Archived

Expired cookie breaks Azure AD B2C auth (with Blazor and MSAL)

Hi all, is expired cookies management changed lately? Authentication doesn't work anymore in following use case. Question is all about FF for windows, while usually I'm o… (read more)

Hi all, is expired cookies management changed lately? Authentication doesn't work anymore in following use case. Question is all about FF for windows, while usually I'm on FF Android, Edge and Chrome for Windows and all these browsers are working correctly.

My working web app (static blazor wasm standalone) is interactively authenticating in Azure AD B2C using Microsoft.Authentication.WebAssembly.Msal library (like MSAL.js), API is an Azure Function protected through AAD B2C.

Login request successfully invokes Signin/Signup B2C flow with popup to myb2ctenant.b2clogin.com but breaks navigating to auth protected pages or backend apis.

From DevTools I see that every request to following b2c endpoints sets an expired cookie (expired 10 years before, year is now 2012):

When user clicks login: GET /myb2ctenant.onmicrosoft.com/b2c_1_sinsup/v2.0/.well-known/openid-configuration

Returning from login confirmation: GET /myb2ctenant.onmicrosoft.com/B2C_1_SInSUp/api/CombinedSigninAndSignup/confirmed?rememberMe=false&csrf_token=xxx

for example: Set-Cookie: x-ms-cpim-trans=; domain=myb2ctenant.b2clogin.com; expires=Fri, 14-Sep-2012 12:46:46 GMT; path=/; SameSite=None; secure; HttpOnly

FF registers this warning in console:

Cookie “x-ms-cpim-trans” has been rejected because it is already expired

Following when MSAL execute a request to /myb2ctenant.onmicrosoft.com/b2c_1_sinsup/oauth2/v2.0/authorize?xxxx

Response always contains:

Location: https://blazorapp.xx.web.core.windows.net/authentication/login-callback#error= interaction_required&error_description=AADB2C90077%3a+User+does+not+have+an+existing+session+and+request+prompt+parameter+has+a+value+of+%27None%27.%0d%0a

All other browsers are working... Thanks in advance for any help

Asked by croma 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Login not possible anymore on Letterboxd.com and other websites since update to FF 104

Hello, This issue might or might not be related to [other issue] I have since I updated Ubuntu 20.04 to 22.04 and therefore updated my Firefox to 104. I can't login anym… (read more)

Hello, This issue might or might not be related to [other issue] I have since I updated Ubuntu 20.04 to 22.04 and therefore updated my Firefox to 104. I can't login anymore on Letterboxd since the update. It's not a problem of username or password. When I click "Sign in", nothing happens except a page refresh, but I'm still not logged in. Other strange behaviour on that site since the update: most of the images don't appear. For example on this page : https://letterboxd.com/films/# all the movie covers are just blank.

The website does work properly when using Firefox in private mode though (both login and images work fine), so this makes me think it's related to my other issue mentioned above.

OS: Ubuntu 22.04 Firefox 104.0.2

EDIT after posting this question: I just found out that I can't login on Google either. I enter my username, password, then it asks me to validate on another apparel that it's really me, which I do, and nothing happens so I can't login. It works normally in private mode.

Asked by vanecx 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

Cannot use firefox when vpn is on

When I use a vpn with firefox (not the firefox vpn), I cannot open normally blocked websites such as twitter or youtube, and instead they open in a sort of half-loaded st… (read more)

When I use a vpn with firefox (not the firefox vpn), I cannot open normally blocked websites such as twitter or youtube, and instead they open in a sort of half-loaded state (see image). I don't face this problem with other browsers. I have tried deleting and reinstalling firefox, but it doesn't seem to work. Can anyone help out?

Asked by formod 8 months ago

Answered by Paul 8 months ago

  • Solved
  • Archived

Yahoo mail menu buttons not working, can't delete or anything

None of the menu buttons work at the top of yahoo mail in firefox when an e-mail is open, I am able to use these in Microsoft Edge. Until the last update of firefox they … (read more)

None of the menu buttons work at the top of yahoo mail in firefox when an e-mail is open, I am able to use these in Microsoft Edge. Until the last update of firefox they worked so something broke in the latest release 103.0.1 is my guess. I restarted without extensions and still broken.

Asked by jfelber 1 year ago

Answered by jfelber 1 year ago

  • Solved
  • Archived

Google search pages not showing text after Mac OS 12.6 Monterey upgrade

Since upgrading to Monterey, Google search pages show almost no text in Firefox. Google searches in Safari and Google Chrome are completely fine. Only Firefox is showing … (read more)

Since upgrading to Monterey, Google search pages show almost no text in Firefox. Google searches in Safari and Google Chrome are completely fine. Only Firefox is showing the problem. The blank text includes dropdown menus too - all options inside them are blank. Currently on Firefox v107.0, but the same problem happens with older versions.

If I go into Troubleshoot mode, the Google searches are working fine. I have refreshed Firefox, Cleared the startup cache. But the problem persists. I uninstalled Firefox from the machine, restarted the computer. Did a fresh download and install, haven't signed in so there are no addons/extensions to cause problems.

This is happening on both an Intel Mac and an M1 Mac running Mac OS 12.6 Monterey.

I attach one screenshot showing the same page with and without troubleshoot mode on. The second screenshot shows another page of results including what looks like weirdly encoded characters.

I've followed all the suggestions in the support page but nothing has helped. I'd really appreciate any advice on further troubleshooting. Thanks in advance for any help.

Asked by Pavi 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Making Card Payments Issues

Hi, I use Firefox daily, but since the last update I'm unable to make card payments on websites and I'm having to use Chrome as a backup. Up until the update everything … (read more)

Hi,

I use Firefox daily, but since the last update I'm unable to make card payments on websites and I'm having to use Chrome as a backup. Up until the update everything was fine and there were no issues making payments on the Royal Mail and Asda websites. When I click the pay button on these sites, the payment window does not open up.

I've tried disabling all addons/extensions to no avail.

Regards Andrew

Asked by fair-trickit 11 months ago

Answered by fair-trickit 11 months ago

  • Solved
  • Archived

Twitch.tv multiple issues after updating to Firefox ESR115.1 from Firefox ESR 102.1

Since yesterday (Sep 26 2023), Twitch.tv has been having multiple issues related to basic functionality of the website, and this has happened before but I did not report … (read more)

Since yesterday (Sep 26 2023), Twitch.tv has been having multiple issues related to basic functionality of the website, and this has happened before but I did not report it because I was able to fix it. I can not purchase or use bits despite Twitch having a stored payment method on file that I have confirmed has sufficient funds, I can not subscribe or gift subscriptions despite Twitch having that same sufficiently funded payment method on file, I can not redeem or earn channel points, I can not send or receive Twitch Whispers (a form of DM), I can not follow or unfollow channels, and I am convinced that if I was to log out, I would not be able to log back in. I can chat in stream chat, and I can watch streams, that's all I can do. But I enjoy using the other features that are currently blocked, I am over 18, and I am the only person that uses this computer, so there should be no parental controls problems either. Yesterday, I restarted my browser, which did NOT alert me that it had updated, and all of this functionality was broken. Roughly 6 months ago I was having the exact same issues, but I was able to fix it by disabling many of the anti-tracking protections on my browser (had to disable them universally except for blocking cryptominers, not just with the shield icon). However, now, even with those settings unchanged, roughly 75% of the features of the website Twitch.tv are nonfunctional. I have included a cropped screenshot of me attempting to redeem something using channel points, the purple box is the button, and the spinner icon stays there for over a minute with nothing happening, which is not how that is supposed to work.

I enjoy watching streams and interacting with people on Twitch.tv, and I wish to continue doing so in the way I am accustomed to. However, it would appear that Firefox has other plans. If this continues, I will be forced to switch to a less secure browser for specifically that site, which is an idea I do not look forward to.

Asked by scinrd 6 months ago

Answered by scinrd 6 months ago