Showing questions tagged: Show all questions
  • Solved

missing print "page setup" in Mozilla v85

With the new v85 of Firefox... for Microsoft Print to PDF... the defaults for print headers & footers has changed and is no longer available to edit or even view. It … (read more)

With the new v85 of Firefox... for Microsoft Print to PDF...

the defaults for print headers & footers has changed and is no longer available to edit or even view. It seems as though my settings remain in place for other printing options like my physical printer but even there the options are not editable or viewable.

There used to be a "page setup" option but I have not be able to find this anywhere anymore.

I'm assuming that it has to do with the bug fix for pdf printing but doesn't seem that it should be an intended outcome of the fix.

Any work arounds anyone knows about or has found?

Asked by Cobalt TiNor 2 months ago

Answered by jscher2000 2 months ago

  • Solved

About opening a tab in a new tab (not new window) conveniently

I found when pressing Alt+Enter in the address bar, the link will open in a new tab, which is nice. But if I press Alt+click a link in the page, the link does not open in… (read more)

I found when pressing Alt+Enter in the address bar, the link will open in a new tab, which is nice. But if I press Alt+click a link in the page, the link does not open in a new tab (while Shift+click can open in a new window as expected). I'm not sure if it's a problem, but I hope Firefox can have this feature so that opening a link in a new tab can be more convenient.

Besides, in some browsers, drag a link to a nearby place will open in a new tab. However, in Firefox, this manner does not work, unless I drag a link to the tabs bar.

Asked by SolidBlock 3 months ago

Answered by cor-el 3 months ago

  • Solved

Bookmarks Toolbar "Only Show on New Tab" option not working

If i set Bookmarks Toolbar option to Always Show, everything works fine, the toolbar is displayed all the time. Now, if i set Bookmarks Toolbar option to Only Show on New… (read more)

If i set Bookmarks Toolbar option to Always Show, everything works fine, the toolbar is displayed all the time. Now, if i set Bookmarks Toolbar option to Only Show on New Tab the toolbar is not displayed anywhere. You can't see it in the new tab or the current tab.

I tested it with FF 85.0.2 (64-bit) and with FF Developer Editition 86.0b9 (64-bit)

I am attaching a VideoGIF to show the problem

Asked by dev/null 1 month ago

Answered by TyDraniu 1 month ago

can't sign in to one of my google accounts, but I can on another

one of my google accounts, which I have been able to sign in through firefox for years, suddenly started giving me an error message after entering my email address on the… (read more)

one of my google accounts, which I have been able to sign in through firefox for years, suddenly started giving me an error message after entering my email address on the google sign in page. I have another google account and I'm able to sign i using firefox just fine. The error message given is:

This browser or app may not be secure. Learn more Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.

I'm using a windows 7 box and Firefox 85.0.2.

I'm able to sign in just fine when I use google chrome. I've cleared cache and data in the browser. I'm not sure what else to try. Any suggestions? Any other information I can provide to help identify the problem?

Asked by vseavello 1 week ago

Last reply by jonzn4SUSE 2 days ago

  • Solved

Running Firefox on read-only file system

I'm trying to run Firefox on headless mode through Selenium in AWS Lambda. Since Lambda marks the root file system as read-only except /tmp/. I pointed the geckodriver to… (read more)

I'm trying to run Firefox on headless mode through Selenium in AWS Lambda. Since Lambda marks the root file system as read-only except /tmp/. I pointed the geckodriver to write the logs to /tmp but still Firefox is not starting up and it's failing with the following error.

Any guidance on how to get it working?

firefox_driver = webdriver.Firefox(firefox_profile=ff_profile, firefox_binary='/opt/firefox/firefox', options=firefox_options, service_log_path='/tmp/geckodriver.log')

 File "/var/lang/lib/python3.8/site-packages/selenium/webdriver/firefox/webdriver.py", line 170, in __init__
   RemoteWebDriver.__init__(
 File "/var/lang/lib/python3.8/site-packages/selenium/webdriver/remote/webdriver.py", line 157, in __init__
   self.start_session(capabilities, browser_profile)
 File "/var/lang/lib/python3.8/site-packages/selenium/webdriver/remote/webdriver.py", line 252, in start_session
   response = self.execute(Command.NEW_SESSION, parameters)
 File "/var/lang/lib/python3.8/site-packages/selenium/webdriver/remote/webdriver.py", line 321, in execute
   self.error_handler.check_response(response)
 File "/var/lang/lib/python3.8/site-packages/selenium/webdriver/remote/errorhandler.py", line 242, in check_response
   raise exception_class(message, screen, stacktrace)

Asked by Prakash P 2 months ago

Answered by Prakash P 1 month ago

FF repeatedly wants permissions to Install Helper Tool on startup.

Version 85.0.2 (64-bit) Upon every startup, FF asks for my system login permissions to install a helper tool, to which I have reluctantly done but it seems to not install… (read more)

Version 85.0.2 (64-bit) Upon every startup, FF asks for my system login permissions to install a helper tool, to which I have reluctantly done but it seems to not install anything different yet continues each time to prompt the Helper Tool install. What is the Helper Tool? I can't find any info about it. How do I turn off the prompt?

Asked by ksmith6 4 weeks ago

Last reply by ksmith6 5 days ago

  • Solved

Sync is not working completely (logs included)

I have reinstalled the OS on my lap top and after a successful login to my account I am unable to sync everything from the account. The logs can be found in: https://cont… (read more)

I have reinstalled the OS on my lap top and after a successful login to my account I am unable to sync everything from the account. The logs can be found in: https://controlc.com/8afabe84

I have the same account set on two different devices (My desktop PC and my android phone, this device I am trying to sync is the third one) and both those device were synced long time ago.

I tried with another profile which I am using for my work related stuff, still no success. First I tried syncing on Ubuntu 20.10 and then installed on Ubuntu 20.04(currently) but it is without success.

I need to sync to this device the bookmarks, extensions, saved logins, etc... Currently I do not have my other PC to export this stuff, please help.

Some of the thing in the logs:

1618133031444 Sync.Service DEBUG Exception calling WrappedLock: LockException: Could not acquire lock. Label: "service.js: login".(resource://services-sync/util.js:62:5) JS Stack trace: LockException@util.js:62:5 throwLockException@util.js:148:11 WrappedLock@util.js:162:15 WrappedCatch@util.js:133:27 login@service.js:1049:66 sync/<@service.js:1327:26 WrappedCatch@util.js:133:27 sync@service.js:1335:7


1618133047237 Sync.Resource WARN GET request to https://sync-1-us-west1-g.sync.services.mozilla.com/1.5/167262145/info/collections failed: [Exception... "The connection has timed out" nsresult: "0x804b000e (NS_ERROR_NET_TIMEOUT)" location: "<unknown>" data: no] No traceback available 1618133047237 Sync.Service DEBUG verifyLogin failed: [Exception... "The connection has timed out" nsresult: "0x804b000e (NS_ERROR_NET_TIMEOUT)" location: "<unknown>" data: no] No traceback available 1618133047238 Sync.Status DEBUG Status.login: success.login => error.login.reason.network 1618133047238 Sync.Status DEBUG Status.service: success.status_ok => error.login.failed 1618133047238 Sync.Status DEBUG Status.login: error.login.reason.network => error.login.reason.network 1618133047238 Sync.Status DEBUG Status.service: error.login.failed => error.login.failed 1618133047238 Sync.ErrorHandler ERROR Sync encountered a login error 1618133047239 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score. 1618133047241 Sync.SyncScheduler DEBUG Next sync in 3600000 ms. (why=schedule) 1618133047242 Sync.Service DEBUG Exception calling WrappedLock: Error: Login failed: error.login.reason.network(resource://services-sync/service.js:1038:15) JS Stack trace: onNotify@service.js:1038:15 1618133047242 Sync.Service DEBUG Not syncing: login returned false.

Asked by Nikola Lozanovski 1 week ago

Answered by Nikola Lozanovski 6 days ago

Amazon Prime Video not loading

Hi, I'm not sure what has happened but my Firefox browser no longer plays Amazon Prime Videos; quite simply the "play video" links don't work. I've played with the DRM s… (read more)

Hi,

I'm not sure what has happened but my Firefox browser no longer plays Amazon Prime Videos; quite simply the "play video" links don't work. I've played with the DRM settings, refreshed Firefox via the support options, and have installed the latest version of the browser. I'm running a Win10 desktop. Netflix works fine and Amazon Prime Video works fine through MS Edge, but I can't figure this one out. Does anyone have any suggestions that I could try?

Thanks and Regards

Matt Whitehead

Asked by mwhitehead87 2 months ago

Last reply by Hithills 6 days ago

On Screen Keyboard will not open, Surface Pro 7

I'm using a Surface Pro 7, running Win10H. Firefox had a brief period when I first installed it where the on screen keyboard would appear and work, that stopped after a f… (read more)

I'm using a Surface Pro 7, running Win10H. Firefox had a brief period when I first installed it where the on screen keyboard would appear and work, that stopped after a few hours and has not worked since. I fiddled with the settings on both Firefox and my surface, though nothing has changed. Un/re-installing did not help, thought it could reset something. Any fixes or advice would be greatly appreciated.

For clarification, the Accessibility Menu on-screen keyboard does work, but the tablet-specific larger keyboard does not function. It does open and type in other applications.

Asked by Big Daddy 1 month ago

Last reply by Madmitch 6 days ago

Autofill Causes Firefox To Crash

When you are presented with a text field, sometimes when you type, a small list of words you entered previously will drop down. You can then select one of those previous … (read more)

When you are presented with a text field, sometimes when you type, a small list of words you entered previously will drop down. You can then select one of those previous words, or continue with what you were originally typing. This is the Autofill feature for Firefox.

Lately, it has been a pain. After an hour or so of use, the instant I click on a text field to type something (usually for searching), the autofill box would partially drop down, only for Firefox to completely hang up. Once you recover from the initial crash, the autofill bug would not appear until at least an hour later. I tried turning off Autofill, but it cost me access to my History, so I was forced to do a complete browser reset. This issue has been with me for about a couple of weeks, and I have no idea why it's doing this.

Asked by no1wammy 2 months ago

Last reply by cor-el 1 week ago

  • Solved

Why do you archive threads before fixing the issue???

I here refer to my thread https://support.mozilla.org/en-US/questions/1285212 in which the problem were not even answered by any of your tech people, but archived - why?… (read more)

I here refer to my thread https://support.mozilla.org/en-US/questions/1285212 in which the problem were not even answered by any of your tech people, but archived - why?

I find it really bad, if i post a bug and you just archive without even try to fix the problem! It makes me extremely angry! Bad behavior!

Please stop that and re-open the case.

Jan Ps. same system (Lenovo Thinkpad X300 with Xubuntu 16.04LTS 64bit (account A) )now running Firefox 85.0.1 64bit can now print, I can't find any mentioning in release notes to how previous version 75.0 and now this one is different and why this one now can print.

It would be nice to get this solved, since other people here has had this one too and it seems to jump between versions and OS(linux an windows).

edited broken link

Asked by insomniacno1 2 months ago

Answered by insomniacno1 2 weeks ago

Firefox 8.6.0 upgrade disables Firefox browser...

Firefox 8.6.0 upgrade disables Firefox browser I utilized "System Restore" through the process of elimination I determined that it is the 8.6.0 upgrade that is causing th… (read more)

Firefox 8.6.0 upgrade disables Firefox browser I utilized "System Restore" through the process of elimination I determined that it is the 8.6.0 upgrade that is causing the problem. So, turned off the automatic upgrade option and installed any Windows 8.1 upgrades and my Firefox is working great. Now I have a "nag" screen that is constantly trying to upgrade Firefox browser might there be some way to disable this upgrade notice?

Asked by DJ 2 weeks ago

Last reply by DJ 2 weeks ago

Magnets

I wish to know how to fix this issue (magnet links) ? I've installed bittorrent, but not showing on d.a.s page, after refreshing Firefox. Error msg: This file does not ha… (read more)

I wish to know how to fix this issue (magnet links) ? I've installed bittorrent, but not showing on d.a.s page, after refreshing Firefox. Error msg: This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings page.

Asked by jamesrichmond2005 2 months ago

Last reply by jscher2000 2 weeks ago

Getting Twitch Error Code 2000 While Streaming?

A few days back out of nowhere I started getting network error 2000 on Twitch while streaming. I tried all possible ways to fix it on my own. But sadly I failed miserably… (read more)

A few days back out of nowhere I started getting network error 2000 on Twitch while streaming. I tried all possible ways to fix it on my own. But sadly I failed miserably. Then, I started searching for other alternatives to fix this issue. While going through different forums and discussions website, I found that I am not the only one who is getting this error. So, I decided to post this thread on this forum site so that I can help other going through the same problem. After searching and trying lots of foolish ways mentioned by some articles, I finally hopped into the savior. I found this guide on web that has some really amazing working solutions - Twitch Error 2000 I hope it will help others to get this issue fixed on Firefox.

Asked by dikshasinghh708 2 weeks ago

My laptop location in Firefox is Old data

My laptop location in Firefox is using my former home location. But when I do the same Weather Google Search or Google Map website in Chrome, the location is my current … (read more)

My laptop location in Firefox is using my former home location. But when I do the same Weather Google Search or Google Map website in Chrome, the location is my current location in North Carolina. This true whether I'm logged into my Google account or not Signed in to my Google account.

In Firefox I've checked Tools/Options/Privacy & Security/Permissions/Location/Settings. It lists 3 sites that have asked for access to my Locations: google, home depot and BedBathBeyond. Yet when I use Google to search "weather", it gives me Wayne NJ. This section will not let me add Google Maps.

In Security I changed Block Pop-ups to continue to have a checkmark but added google.com and maps.google.com as exceptions and restarted Firefox. Google Maps still shows Wayne NJ and weather sometimes shows North Carolina but mostly shows Wayne NJ

Are there any other settings in Firefox I need to update? Or are there settings in Windows I need to update.? I'm using Windows 10 and Firefox 85.0

Asked by emdwayne20 2 months ago

Last reply by delius1967 2 weeks ago

YouTube.com on Release 86 of Firefox/Win64 and newer is causing huge CPU spikes in the Firefox process handling the respective tab when navigating to a different page (in the same tab) on YouTube while a video plays

You can work around the issue by stopping the video currently playing in the YouTube tab before navigating away from its page. I suspected the usual problem of hardware a… (read more)

You can work around the issue by stopping the video currently playing in the YouTube tab before navigating away from its page.

I suspected the usual problem of hardware acceleration / video drivers and Firefox not playing nice, but thanks to the PortableApps.com Firefox builds and their version archive, I was able to confirm that it only happens on Release 86 and newer.

Since it's reproducible with the PortableApps builds, settings/profile/cookies etc., it seems pretty clear it's an issue with Firefox proper.

I've downgraded my main Firefox installation to 85.0.2 for the time being and am enjoying snappy YouTube without hangs again.

Anybody happen to know if that bug is already known / under triage or should I get comfortable with the idea of having to downgrade to and using Firefox ESR for a while?

Asked by cybasheep 2 weeks ago

Last reply by cybasheep 2 weeks ago

Pegged CPU at 100% when skipping ads on YT

I have recently updated my browser to version 87...unfortunately I had to revert to version 85.0.2 because the browser pegs CPU every time there is an advert on Youtube. … (read more)

I have recently updated my browser to version 87...unfortunately I had to revert to version 85.0.2 because the browser pegs CPU every time there is an advert on Youtube. Doesn't matter whether I let it play in its entirety or skip it after the mandatory 5-second mark. I have tried running FF without addons, did not make a change. I tried opening a single window with a single tab...no result. Can you fix it in some kind of micro patch? I'm running W8.1 on i5 6600K clocked at 4 GHz with 8 Gb RAM in a dual channel.

Asked by spioh72 2 weeks ago