Showing questions tagged: Show all questions
  • Archived

GPO Search Engine: spaces replaced with pluses instead of %20

Good day. I have created a custom Search Engine via a GPO. The search engine is added to Firefox without issue. However, when a user enters in a search with a space,… (read more)

Good day.

I have created a custom Search Engine via a GPO.

The search engine is added to Firefox without issue. However, when a user enters in a search with a space, Firefox replaces the space with a "plus" instead of a %20. The search engine does not know how to interpret a "plus," so the search engine returns 'no results found.' I use the same search string in a Chrome GPO, and it works as Chrome replaces a space with a %20. Is there a way I can tweak the Search engine GPO to use %20 instead of a "plus" for a space?

Thanks.

Peter

Asked by peterc5 10 months ago

Last reply by Mike Kaply 5 months ago

  • Solved
  • Archived

How to disable Quic protocol in Windows with MS Intune

Hello I am looking for a way to disable the QUIC protocol in Firefox through Intune. tried by below value but its not working, anyone did the settings in MS Intune for W… (read more)

Hello

I am looking for a way to disable the QUIC protocol in Firefox through Intune. tried by below value but its not working, anyone did the settings in MS Intune for Windows? <enabled/> <data id="JSON" value=' {

 "network.http.http3.enable": {
   "Value": 0,
   "Status": "user"
 },

{

 "network.http.http3.enable_0rtt": {
   "Value": 0,
   "Status": "user"
 }

}'/>

Thanks

Asked by Shri Sivakumaran 6 months ago

Answered by Shri Sivakumaran 6 months ago

  • Solved
  • Archived

How to disable Quic protocol in Mac with Jamf

Hello I am looking for a way to disable the QUIC protocol in Firefox through Jamf Pro. tried by below value but its not working, anyone did the settings for Mac? <… (read more)

Hello

I am looking for a way to disable the QUIC protocol in Firefox through Jamf Pro. tried by below value but its not working, anyone did the settings for Mac?

<plist version="1.0"> <dict> <key>Preferences</key> <dict> <key>network.http.http3.enable</key> <dict> <key>Value</key> <false/> <key>Status</key> <string>user</string> </dict> <key>network.http.http3.enable_0rtt</key> <dict> <key>Value</key> <false/> <key>Status</key> <string>user</string> </dict> </dict> </dict> </plist>


Thanks

Asked by Shri Sivakumaran 6 months ago

Answered by Mike Kaply 6 months ago

Disable Firefox Password Manager Completely via plist

Attempting to disable FF Password manager completely for my org via a plist. Currently have the password manager itself disabled but can't figure out how to disable the … (read more)

Attempting to disable FF Password manager completely for my org via a plist.

Currently have the password manager itself disabled but can't figure out how to disable the Auto-fill settings with previously saved passwords prior to the password manager being disabled?

Is this possible? Or is this disabled already when the password manager itself is disabled?

Currently have this set via a plist:

<key>PasswordManagerEnabled</key> <false/>

Asked by Matthew L 3 months ago

Last reply by Mike Kaply 3 months ago

  • Archived

ESR: downloading via website still delivers old version for macOS (Firefox 91.13.0esr) instead of 102.2.0

When downloading Firefox ESR via the website for macOS (https://download.mozilla.org/?product=firefox-esr-latest-ssl&os=osx&lang=en-US) one still receives the old… (read more)

When downloading Firefox ESR via the website for macOS (https://download.mozilla.org/?product=firefox-esr-latest-ssl&os=osx&lang=en-US) one still receives the old 91.13.0 version instead of the current release 102.2.0. Can you please fix this?

Asked by contact711 1 year ago

Last reply by thecapcut15 1 year ago

  • Archived

Automatic redirect in pac files doesn't work

Hello, I have a problem with a pac file in our org. We download it from a server. The basic functionality is applied and it does redirect the desired traffic to the prox… (read more)

Hello,

I have a problem with a pac file in our org. We download it from a server. The basic functionality is applied and it does redirect the desired traffic to the proxy. The problem occurs when the proxy goes down, it then should automaticaly start making direct connections, but the connections fail. We want to proxy only http and https and event that with some exceptions.

It was done according to https://developer.mozilla.org/en-US/docs/Web/HTTP/Proxy_servers_and_tunneling/Proxy_Auto-Configuration_PAC_file#example_6

Is there any problem with PAC file or does the browser have issues with the config?

Thanks for any help.

function FindProxyForURL(url, host) {

   /* Our proxy list */
   OURPROXY = "PROXY 172.22.59.X:3128; DIRECT"
   INOUR = "ourgroup.internal"
   /* Normalize the URL and HOST for pattern matching */
   url = url.toLowerCase();
   host = host.toLowerCase();
   /* Our Network Entry */
   if (isResolvable(INOUR)) {
       /* Don't proxy local services */
       if (isInNet(host, "10.0.0.0", "255.0.0.0")
       ) {
           return "DIRECT";
       }
       /* Proxy only http & https */
       if (url.substring(0, 5) == "http:" || url.substring(0, 6) == "https:") {
           /* Don't proxy local hostnames (without dots) */
           if (isPlainHostName(host)) {
               return "DIRECT";
           }
           /* END: Don't proxy local hostnames */
           /* START: Internal systems */
           if (shExpMatch(host, "*.example.com") ||
               shExpMatch(host, "example.com") ||
               /* END: Internal systems */
               /* START: Split VPN tunnel */
               shExpMatch(host, "*.example2.com") ||
               shExpMatch(host, "example2.com") ||
               /* END: Split VPN tunnel */
           ) {
               return "DIRECT";
           }
           /* END: Don't proxy to internal systems */
           return OURPROXY;
       } else {
         return "DIRECT";
       }
       /* END: Proxy only http & https */
   } else {
     return "DIRECT";
   }
   /* END: Our Network Entry */
   return "DIRECT";

}

Asked by piotr.jakub.kaczmarzyk 1 year ago

Last reply by Mike Kaply 1 year ago

  • Solved
  • Archived

Unable to set Homepage via Intune configuration profile for MacOS

Hi everyone, I'm trying to standardize the homepage for the browser which enrolled with Intune on MacOS. I have imported the .plist file as below with the preference doma… (read more)

Hi everyone, I'm trying to standardize the homepage for the browser which enrolled with Intune on MacOS. I have imported the .plist file as below with the preference domain name as "org.mozilla.firefox". After applied, it returned error and nothing has been changed on the browser. Thanks.

<key>Homepage</key> <key>URL</key> <string>http://example.com</string> <key>StartPage</key> <string>homepage</string>

Asked by thomas1881 1 year ago

Answered by Mike Kaply 1 year ago

  • Solved
  • Archived

Firefox GPO: Add Custom Search Engine

We would like to install a custom search engine using Firefox policies. We have the latest version of Firefox installed. We have the latest admx files installed on our … (read more)

We would like to install a custom search engine using Firefox policies. We have the latest version of Firefox installed. We have the latest admx files installed on our Domain Controllers. In the Policy, I go into the User -> Administrative Templates -> Mozilla -> Search and setup a search engine using Search Engine One. I then go into Default Search Engine and configure our custom search to be default. What we find is that the custom search engine never installs, so the custom search engine is not set at the default. If I manually add the custom search engine using the Search Engine Helper Add-on, I can verify that the custom search settings do indeed work. With that said, does anyone have thoughts on how to troubleshoot this issue? First, need to figure out why the custom engine isn't installing at all. Thanks.

Asked by peterc5 11 months ago

Answered by peterc5 11 months ago