Showing questions tagged: Show all questions
  • Solved
  • Archived

captive portal detection fails with redirect from detectportal.firefox.com to mymodem.modem, which does not resolve

My Firefox Developer Edition just required manual help to upgrade to 73.0b2 because the auto-upgrade failed. Not sure if that is important. All new tabs and windows had … (read more)

My Firefox Developer Edition just required manual help to upgrade to 73.0b2 because the auto-upgrade failed. Not sure if that is important. All new tabs and windows had the "You have to connect to the internet" captive-portal bar across the top, but I'm on a home network without captive portal. Clicking the "go to login page" button went to a "can't find that page" error page.

I tried curl from the command-line of my Mac (10.15.2) and got this:

% curl -v http://detectportal.firefox.com/success.txt

  • Trying 2600:1415:1c00::17c0:6c92...
  • TCP_NODELAY set
  • Connected to detectportal.firefox.com (2600:1415:1c00::17c0:6c92) port 80 (#0)

> GET /success.txt HTTP/1.1 > Host: detectportal.firefox.com > User-Agent: curl/7.64.1 > Accept: */* > < HTTP/1.1 302 Moved Temporarily < Server: nginx < Date: Wed, 08 Jan 2020 10:07:46 GMT < Content-Type: text/html < Content-Length: 154 < Connection: keep-alive < Location: http://mymodem.modem < X-Frame-Options: SAMEORIGIN < Content-Security-Policy: default-src 'self';script-src 'self' 'unsafe-eval' 'unsafe-inline';style-src 'self' 'unsafe-inline' < Cache-Control: public, max-age=31536000 < <title>302 Found</title>

302 Found


nginx

I'm prepared to believe that this is ISP-related, rather than Firefox, but on the off-chance that it's somehow down to a misconfiguration of the captive-portal detection servers right now, I thought that I'd report it here.

I've stopped this from happening by setting about:config network.captive-portal-service.enabled to false, but would ideally prefer that this not recur on the next profile reset.

Asked by andrew 7 months ago

Answered by andrew 7 months ago

  • Solved
  • Archived

Firefox Developer Edition (version 73.0b2, 64-bit) - Autoplay persists despite turning it off via options...

So I was looking at a Facebook group this morning and saw something that was posted in the group's feed that decided to autoplay on it's own despite "Block Audio and Vide… (read more)

So I was looking at a Facebook group this morning and saw something that was posted in the group's feed that decided to autoplay on it's own despite "Block Audio and Video" being the default within the "Settings - Autoplay" screen.

I don't understand why this is constantly an issue with Firefox. Every single time, every update, every install, it always and continually becomes an issue with websites that I visit with Firefox. Even a completely fresh install with that above-mentioned setting, it's still an issue--nothing to do with customization of any kind, it's just that Firefox isn't doing what it's supposed to do.

What's going on here with this? Why isn't Firefox able to stop autoplay of videos within Facebook? I shouldn't have to rely on website settings to turn something like that off when it's the browser that allows the playback. I'm clearly missing something (I guess) so I'd appreciate if someone can shine some light on this because it's infuriating.

Asked by Wolf_22 7 months ago

Answered by TyDraniu 7 months ago

  • Archived

Request to Santander Bank Logon Crashes

The following request: https://retail.santander.co.uk/LOGSUK_NS_ENS/BtoChannelDriver.ssobto?dse_operationName=LOGON&dse_processorState=initial&redirect=S Causes: … (read more)

The following request: https://retail.santander.co.uk/LOGSUK_NS_ENS/BtoChannelDriver.ssobto?dse_operationName=LOGON&dse_processorState=initial&redirect=S Causes: Bad Request

Your browser sent a request that this server could not understand. Size of a request header field exceeds server limit.

This used to work and works in Google Chrome but not in Firefox.

Asked by Mike 7 months ago

Last reply by crankygoat 7 months ago

  • Archived

How to disable TLS 1.0 and 1.1 support which Firefox did in recent update but I accidentally enabled it while visiting a site

I know Firefox disabled TLS 1.0 and 1.1 support in recent update. But while visiting site with TLS 1.0 support, Firefox asked me to enable it. I accidentally clicked to e… (read more)

I know Firefox disabled TLS 1.0 and 1.1 support in recent update. But while visiting site with TLS 1.0 support, Firefox asked me to enable it. I accidentally clicked to enable it. But now I want to disable it again. How to do that?

Asked by langalia.kartik 7 months ago

Last reply by McCoy 7 months ago

  • Archived

Weird Things Happening Firefox for Developers (blocklist.xml ?)

Hey all, Going to keep this short - but, pretty sure devices have been compromised. Firefox has been acting strange lately. Opened up the package contents of the app (on… (read more)

Hey all,

Going to keep this short - but, pretty sure devices have been compromised. Firefox has been acting strange lately. Opened up the package contents of the app (on macbook pro 2012) and saw a chrome manifest folder that seemed to be blocking web access on certain sites. Using a similar computer (with ff installed) and decided to look in the app folder. I saw a blocklist.xml sheet. Wondering if this is something that should be in there by default? Some of the things on the list, are things that i'd more likely need than not need. Here is a list of blocked sites and ip addresses. Any help is greatly appreciated.

Thanks,

<blocklist xmlns="http://www.mozilla.org/2006/addons-blocklist" lastupdate="1578526685310">

 <emItems>
   <emItem blockID="i334" id="{0F827075-B026-42F3-885D-98981EE7B1AE}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i576" id="newmoz@facebook.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i326" id="/^((support2_en@adobe14\.com)|(XN4Xgjw7n4@yUWgc\.com)|(C7yFVpIP@WeolS3acxgS\.com)|(Kbeu4h0z@yNb7QAz7jrYKiiTQ3\.com)|(aWQzX@a6z4gWdPu8FF\.com)|(CBSoqAJLYpCbjTP90@JoV0VMywCjsm75Y0toAd\.com)|(zZ2jWZ1H22Jb5NdELHS@o0jQVWZkY1gx1\.com))$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i258" id="helperbar@helperbar.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="1.0" severity="1"/>
   </emItem>
   <emItem blockID="i692" id="/^(j003-lqgrmgpcekslhg|SupraSavings|j003-dkqonnnthqjnkq|j003-kaggrpmirxjpzh)@jetpack$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i218" id="ffxtlbr@claro.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i1137" id="/^({d50bfa5f-291d-48a8-909c-5f1a77b31948}|{d54bc985-6e7b-46cd-ad72-a4a266ad879e}|{d89e5de3-5543-4363-b320-a98cf150f86a}|{f3465017-6f51-4980-84a5-7bee2f961eba}|{fae25f38-ff55-46ea-888f-03b49aaf8812})$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i515" id="/^({bf9194c2-b86d-4ebc-9b53-1c08b6ff779e}|{61a83e16-7198-49c6-8874-3e4e8faeb4f3}|{f0af464e-5167-45cf-9cf0-66b396d1918c}|{5d9968c3-101c-4944-ba71-72d77393322d}|{01e86e69-a2f8-48a0-b068-83869bdba3d0})$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i722" id="{9802047e-5a84-4da3-b103-c55995d147d1}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i433" id="{c95a4e8e-816d-4655-8c79-d736da1adb6d}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i816" id="noOpus@outlook.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i818" id="contentarget@maildrop.cc">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i590" id="{94cd2cc3-083f-49ba-a218-4cda4b4829fd}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i746" id="{58d2a791-6199-482f-a9aa-9b725ec61362}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i238" id="/^pink@.*\.info$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3">
       <targetApplication id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
         <versionRange minVersion="18.0" maxVersion="*"/>
       </targetApplication>
     </versionRange>
   </emItem>
   <emItem blockID="i1414" id="/^new@kuot\.pro|{13ec6687-0b15-4f01-a5a0-7a891c18e4ee}|rebeccahoppkins(ty(tr)?)?@gmail\.com|{501815af-725e-45be-b0f2-8f36f5617afc}|{9bdb5f1f-b1e1-4a75-be31-bdcaace20a99}|{e9d93e1d-792f-4f95-b738-7adb0e853b7b}|dojadewaskurwa@gmail\.com$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i690" id="{55dce8ba-9dec-4013-937e-adbf9317d990">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i840" id="{4889ddce-7a83-45e6-afc9-1e4f1149fff4}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i168" id="flashX@adobe.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i1012" id="wxtui502n2xce9j@no14">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i516" id="/^({3f3cddf8-f74d-430c-bd19-d2c9147aed3d}|{515b2424-5911-40bd-8a2c-bdb20286d8f5}|{17464f93-137e-4646-a0c6-0dc13faf0113}|{d1b5aad5-d1ae-4b20-88b1-feeaeb4c1ebc}|{aad50c91-b136-49d9-8b30-0e8d3ead63d0})$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i491" id="{515b2424-5911-40bd-8a2c-bdb20286d8f5}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i136" id="Adobe@flash.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i504" id="aytac@abc.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i848" id="bcVX5@nQm9l.org">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i680" id="jid1-bKSXgRwy1UQeRA@jetpack">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i582" id="discoverypro@discoverypro.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i846" id="PDVDZDW52397720@XDDWJXW57740856.com">
     <prefs>
       <pref>browser.startup.homepage</pref>
       <pref>browser.search.defaultenginename</pref>
     </prefs>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i922" id="{34712C68-7391-4c47-94F3-8F88D49AD632}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3">
       <targetApplication id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
         <versionRange minVersion="39.0a1" maxVersion="*"/>
       </targetApplication>
     </versionRange>
   </emItem>
   <emItem blockID="i142" id="{a3a5c777-f583-4fef-9380-ab4add1bc2a8}">
     <prefs/>
     <versionRange minVersion="4.2" maxVersion="4.2" severity="3"/>
     <versionRange minVersion="2.0.3" maxVersion="2.0.3" severity="3"/>
   </emItem>
   <emItem blockID="i578" id="jid1-XLjasWL55iEE1Q@jetpack">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i535" id="/^ext@WebexpEnhancedV1alpha[0-9]+\.net$/">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i1077" id="helper@vidscrab.com">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i566" id="{77BEC163-D389-42c1-91A4-C758846296A5}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i778" id="{f2456568-e603-43db-8838-ffa7c4a685c7}">
     <prefs/>
     <versionRange minVersion="0" maxVersion="*" severity="3"/>
   </emItem>
   <emItem blockID="i1024" id="{458fb825-2370-4973-bf66-9d7142141847}">
     <prefs>
       <pref>app.update.auto</pref>
       <pref>app.update.enabled</pref>
       <pref>app.update.interval</pref>
       <pref>app.update.url</pref>
     </prefs>
     <versionRange minVersion="0" maxVersion="*" severity="1"/>
   </emItem>
   <emItem blockID="i856" id="/^({94d62e35-4b43-494c-bf52-ba5935df36ef}|firefox@advanceelite\.com|{bb7b7a60-f574-47c2-8a0b-4c56f2da9802})$/">

Asked by MacBook1212 7 months ago

Last reply by crankygoat 7 months ago

  • Archived

Video not starting play

Hello, videos doesn't start on coub.com. Sound is able, but there is no animation of the picture, I see only a preview and it's works this way only for specific coub - in… (read more)

Hello, videos doesn't start on coub.com. Sound is able, but there is no animation of the picture, I see only a preview and it's works this way only for specific coub - in main page i can see all popular videos without broblems. What diagnostic files should I attach to my request? The cache of browser was cleared, autoplay in the site settings (in the addressbar) also had to be turned on

Asked by alive.corpse 7 months ago

Last reply by alive.corpse 6 months ago

  • Archived

Firefox won't start and the process id keeps changing

Occasionally when I click Firefox, it won't start properly. If I check the windows task manager, there is a lone Firefox process but it's ID keeps changing. If I click t… (read more)

Occasionally when I click Firefox, it won't start properly. If I check the windows task manager, there is a lone Firefox process but it's ID keeps changing.

If I click the icon a few more times, Firefox will spawn hundreds of instances and crash Explorer. At this point I can right-click and close all windows. Then Firefox can be started properly.

Any clue what's going on or how I can fix it?

Asked by M W Sasser 7 months ago

Last reply by M W Sasser 7 months ago

  • Archived

Export console xhr responses

I'm trying to automate a part of my daily work on a website I'm using (not developping). I have to crawl several lists on the website, dig an item in the list, to check s… (read more)

I'm trying to automate a part of my daily work on a website I'm using (not developping). I have to crawl several lists on the website, dig an item in the list, to check some values, and do it again and again ...

Im used to developping in Powershell and python, not with a web browser. I have admin rights on the machine I'm working on. I'd like to use this to catch the json answers of the website (all of them), parse the answers for some values, and automate some kind of popup "Hey, This item in the list is between 90 and 100 !"

No code to show yet, that's what i'm looking for : basic solution for json interception while i'm crawling. I have good knowledge of json parsing using python/powershell, the hard part for me is catching the answers ...

A real time export of all json answers of the network console will be a perfect basis for this ... How can this be done with firefox extension ? I just need a base to start.

Thank you very much for any help you can give. And apologies for my average english ...

Asked by oudin.manuel 7 months ago

Last reply by oudin.manuel 6 months ago

  • Archived

Account locked because account verification email issue/bug

I just recently began migrating my accounts to new emails using a custom domain that I got, prepending the domain with different names/addresses, based on the types of ac… (read more)

I just recently began migrating my accounts to new emails using a custom domain that I got, prepending the domain with different names/addresses, based on the types of accounts I use to filter my mail and help my inbox stay organized (ie. email addresses like `spam@domain.com`, `work@domain.com`, `important@domain.com`, etc.). When creating my Firefox account I used one of these email addresses, and received a notification saying the verification email failed to send and was returned, and my account was locked out. Then I realized I forgot to enable the specific email address for my domain before trying to create the account, so I went and activated the correct address, tested it, and then tried logging in / creating my account again, but was just given the same 'locked out' error.

Can you guys unlock my account? I have the login information and the email address is working now, but the site just keeps saying that the verification email failed to send, instead of trying to send a new one or something. If you guys can't just unlock it, then it is fine if you can just reset it or completely remove it, so I can create it again with the same email, since the account was brand new and didn't have anything on it yet.

Asked by gege 6 months ago

Last reply by gege 6 months ago

  • Archived

Unexpected behavior with "jump to end of word" keyboard shortcut on macOS

I often use the "Option+Left/Right Arrow" keyboard shortcut to navigate through text. In Chrome and other programs, this works how I would expect it: using this site, th… (read more)

I often use the "Option+Left/Right Arrow" keyboard shortcut to navigate through text.

In Chrome and other programs, this works how I would expect it: using this site, the first press of the right arrow will move the cursors after "https" and before the ":" character. A second will move it to the end of "support" before the "." character.

However, Firefox will jump to between the "//" characters" and "support" on the first press, and will jump over the period after "support," before the word "mozilla."

This applies to the address bar, but also anywhere text is present, such as a form text area.

Strangely, moving the other direction does not skip past punctuation.

The behavior exhibited does not match that of the native operating system (moving to the end of a word, excluding punctuation) so I find it somewhat jarring. Is this something that could potentially be changed by a config and/or fixed at the application level?

Thanks.

Asked by Dave Powers 6 months ago

Last reply by crankygoat 6 months ago

  • Archived

Is it possible to disable the JSON Viewer in Firefox Developer Edition?

Hi, I really love everything about Firefox Developer Edition, except the JSON viewer. I'm used to looking at plain formatted JSON like the JSON Formatter plugin provide. … (read more)

Hi, I really love everything about Firefox Developer Edition, except the JSON viewer. I'm used to looking at plain formatted JSON like the JSON Formatter plugin provide. But, even thought I have installed JSON Formatter (https://addons.mozilla.org/en-US/firefox/addon/json-formatter/?src=recommended), it only shows this tree/table-ish viewer that comes with Firefox Developer Edition. Is there any way to disable this feature and use a plugin for this, just as in Firefox ?

Asked by jakobvadnielsen 6 months ago

Last reply by d.mattera 6 months ago

  • Solved
  • Archived

Firefox not functioning beyond the opening screen in Windows 10 - January 2020

A week ago, when starting Firefox, the message 'updating Firefox . . . ' appeared before the progrom loaded. I've seen this before and it has always continued to load Fi… (read more)

A week ago, when starting Firefox, the message 'updating Firefox . . . ' appeared before the progrom loaded. I've seen this before and it has always continued to load Firefox. This time, after some hard-drive activity, the program did not load. I started looking for support and chose to uninstal v72 - shut down my laptop and restarted it. I downloaded the latest version and at the end of install - where 'run firefox' is expected - nothing happened. I have since uninstalled and downloaded the latest beta version (73) - and now, when I ask to run the program, it opens a window but all the tabs are 'dead' and no matter what I type, the program does not connect to the internet (i.e. Google search or direct to a known web address). If I select settings, I can see the drop-down list - but if I select 'Add-ons' (for example) - nothing happens. I attempted to run my laptop in safe mode, but I have no recall of the password needed to get past the login screen. Is there anything simple I can do to bring my Firefox back to life?

Asked by SteveC 6 months ago

Answered by SteveC 6 months ago

  • Archived

Page is reverted to start page a few seconds after I start Firefox

After starting Firefox. If I navigate to a page to soon it jumps back to the start page again (about:blank for me). Like it's restaring again somewhat. Just before the pa… (read more)

After starting Firefox. If I navigate to a page to soon it jumps back to the start page again (about:blank for me). Like it's restaring again somewhat. Just before the page is reste there seems like a windows opening in the bottom right but it closes before I manage to see content. Only add-on I have i uBlock Origin. Do you have any idea why this is happening. Is there some log I can look at or enable to see what is really happening? 73.0b7 x64 on Windown 10

Asked by Lars-Erik 6 months ago

Last reply by cor-el 6 months ago

  • Archived

400 ERROR happens always in regular browsing, Never happens with private mode.

The Symptom: 1) In case of browsing https://stock.adobe.com/ only, 2) httpd returns 400 Error (cf. attached image). 3) when I use private mode, everything works perfect. … (read more)

The Symptom:

1) In case of browsing https://stock.adobe.com/ only,

2) httpd returns 400 Error (cf. attached image).

3) when I use private mode, everything works perfect. I can browse, login and any other things.

4) Happens only in one Windows10 PC.


What I have checked:

1) Erased all cookies of *.adobe.com -> 400 Error

2) Browse with firefox on other PC -> IT WORKS!

3) Browse with Chrome on the same/other PC -> IT WORKS!

4) Launch firefox in safemode and disabled all add-ons -> 400 Error

5) Browse the site in Private mode-> IT WORKS!

6) Tried to read http headers by Dev. Tools (see the attached figure)-> No Idea! (unfortunately)

7) When I requested favicon.ico and roborts.txt, the both always returned 200 status code and they are fine.


Question:

According to my troubleshooting, It must be clientside problem. I did everything I can think of, but 400 httpd error persists, only in one PC, this firefox only. What is the possible cause?

Asked by mishiki 6 months ago

Last reply by cor-el 6 months ago

  • Archived

How do I change password suggestion options?

At every login screen where Firefox suggests saved logins, old out of date logins are included. I wish Firefox could just offer me 1 last used option. Or at least keep th… (read more)

At every login screen where Firefox suggests saved logins, old out of date logins are included. I wish Firefox could just offer me 1 last used option. Or at least keep the last used login on top of the list. Now the last used and older logins just appear randomly in a list.

Asked by td540 6 months ago

Last reply by cor-el 6 months ago

  • Solved
  • Archived

remove tracker detection & amazon verification icons in address bar? Dev bld

Hello: FF dev build 73.0b7 w10p. (No stable on this mac - yes mac). I want to remove from the address bar, the 2 icons taking up space in the address bar, that I never us… (read more)

Hello: FF dev build 73.0b7 w10p. (No stable on this mac - yes mac). I want to remove from the address bar, the 2 icons taking up space in the address bar, that I never use. Do I need to create a user file .css? I can if nec. The 2 icons are to the L of the addr. bar 1- "no trackers known..." & 2- "verified by amazon". The "remove" context menu item is grayed out. -What I really want is to SEE the address I'm typing into the address bar, when FF is NOT in full monitor pg mode. 23" W monitor & I often have FF in only 1/2 of the full monitor (so I can see another non-related window at same time). But only the down carot is visible in this "1/2 mode' status & I can't see anything of what I type, nor anything in the address bar already. I use the address bar search like 99% of the time & I really like this shortcut! (If it was fully useful, in 1/2 mode, even more). My guess is that removing those unused icons will allow more space in addr. bar to see what I'm typing -- right? Thank you.

Asked by linusr 6 months ago

Answered by cor-el 6 months ago