Showing questions tagged: Show all questions
  • Archived

Flash videos hang the entire browser, killing plugincontainer.exe wakes Firefox up again

I need help! :) Disclaimer: I'm actually trying to help a friend of mine, and I personally spent over an hour at my friend's apartment trying to fix his Firefox. I'm pos… (read more)

I need help! :) Disclaimer: I'm actually trying to help a friend of mine, and I personally spent over an hour at my friend's apartment trying to fix his Firefox. I'm posting here so I can hopefully get some more tips from all experts here.

Symptom: Firefox completely hangs when playing back Flash videos (eg. Youtube). You can usually still hear the audio in the background, but the video freezes, and indeed the entire UI freezes. You can't even click the red [X] button to close the window at that point.

Workaround: Getting the Windows Task Manager up and killing plugincontainer.exe makes Firefox respond again, showing the "Plugin crashed" box in place of the video, and you can finally interact with the browser again.

I've tried the following:

  • Ensuring that he's running the latest Firefox (8.0.1)
  • Upgrading Flash to latest version - same problem before and after
  • Upgraded the graphics card drivers to the latest version (it's a ATI Radeon HD 3200) - same problem before and after
  • Created a new Firefox profile - still the same problem
  • Made a clean install of Firefox by wiping the program folder - still the same problem
  • Created a new Windows login account - still the same problem
  • Tried in IE - it works fine!
  • Tried in Chrome - it works fine!

I'm suspecting that this is some sort of graphics driver/flash issue, but what really boggles my mind is that it works fine in Chrome, which (I think?) uses the same non-ActiveX version of the Flash plugin.

Another piece of evidence that I think points to the device driver: running Windows in Safe Mode actually makes the video play fine (although very very low fps).

Any clues, anyone? I feel like I've tried all possible troubleshooting steps!

Asked by David Tenser 8 years ago

Last reply by cor-el 8 years ago

  • Archived

Why does Firefox turn my video when it plays? It does not happen in other browsers.

I have a situation where I am trying to play a video in portrait mode and it does well in Safari, IE, & Chrome. When I try to play it in Firefox it turns it landscape… (read more)

I have a situation where I am trying to play a video in portrait mode and it does well in Safari, IE, & Chrome. When I try to play it in Firefox it turns it landscape mode.

This works for people who like to lay their heads on their desks, but not for the rest of us.

the video is located at: http://www.dearsuccessseeker.com/WOP_Meeting_050715/WOP_050715_Video.mp4

Any ideas?

Thanks in Advance

Asked by katheevz 4 years ago

Last reply by cor-el 4 years ago

  • Archived

Why can't I view this video in Firefox 40?

https://twitter.com/i/cards/tfw/v1/637249573279412224?cardname=__entity_video&native=true&earned=true I receive an error msg saying 'Deze browser ondersteunt het … (read more)

https://twitter.com/i/cards/tfw/v1/637249573279412224?cardname=__entity_video&native=true&earned=true

I receive an error msg saying 'Deze browser ondersteunt het afspelen van video's niet.' Meaning the browser doesn't support playing video's. This is the only video that doesn't play, however.

IE and Chrome show no problem.

Switching off add-ons didn't help.

Asked by Damrak 4 years ago

Last reply by user1241316 4 years ago

  • Archived

Unity web player causing Firefox to become unresponsive

I installed the unity web player plugin ages ago, to play online games, but since earlier today, Firefox becomes unresponsive (or occasionally, Unity crashes) when trying… (read more)

I installed the unity web player plugin ages ago, to play online games, but since earlier today, Firefox becomes unresponsive (or occasionally, Unity crashes) when trying to play those games. I never had this problem before. I have restarted my computer, I have tried opening firefox in safe mode, I have done a virus scan, and I've tried reinstalled both firefox and unity, and my problem still persists. I have no idea what I can do to fix the problem.

Asked by georgethewanderer 4 years ago

Last reply by FredMcD 4 years ago

  • Archived

What prevents you (Firefox developers) from making Firefox use codecs already installed on the system without solely relying on Media Feature Pack?

Why is Firefox not capable of using codecs installed on the system directly without asking for Windows Media Feature Pack? My request is that you make Firefox compatible … (read more)

Why is Firefox not capable of using codecs installed on the system directly without asking for Windows Media Feature Pack?

My request is that you make Firefox compatible with existing codecs without it asking specifically for Windows Media Feature Pack (because I don't need it; Firefox does).

Asked by bp2017 2 years ago

Last reply by Shadow110 2 years ago

  • Archived

I cannot get flash player to work. I am on the latest version.

I have install the latest version of flash play for Firefox, version 27.0.0.170. When I try to play a video from a web page I get the following message "We're sorry but… (read more)

I have install the latest version of flash play for Firefox, version 27.0.0.170. When I try to play a video from a web page I get the following message "We're sorry but your browser does not support this video. Please install Adobe Flash version 10 or later".

Asked by clkelley255 2 years ago

Last reply by FredMcD 2 years ago

  • Archived

Video issue on twitch/youtube

Hello, i have a problem with Firefox, i watch many stream / video while gaming, the video start shaking back and isn't smooth at all . It usually start happen when i laun… (read more)

Hello, i have a problem with Firefox, i watch many stream / video while gaming, the video start shaking back and isn't smooth at all . It usually start happen when i launch a game and the cpu have a big load. I haven't this issue with chrome or edge. It happen on twitch and YouTube. I love Firefox but i can't use it for that issue, very frustrating for me.

I recorded the issue: https://vimeo.com/268910891

Asked by M4dDan 2 years ago

Last reply by FredMcD 2 years ago

  • Archived

Video playback awful after most recent update. Switching to Chrome.

My FireFox just updated after closing and reopening it, and the videos would play, as in there'd be sound and the progress bar would be moving, but the picture would be b… (read more)

My FireFox just updated after closing and reopening it, and the videos would play, as in there'd be sound and the progress bar would be moving, but the picture would be black. I got an extension to enable switching between Flash and HTML5, but at best it just makes the playback really choppy and having to stop every 3 or so seconds, for about 2 seconds at a time, making videos unwatchable.

And no, this isn't a problem with my computer. The videos were working just fine this morning, literally just before the update, and had these problems afterward. Videos play fine on both IE and Chrome, which I just downloaded (had been using it off and on). When IE outperforms a browser in something, you know there's a problem. It is absolutely not my computer's problem since I'm enjoying the normal video playback that I was before, only on Chrome. With internet speeds of 20 Ping, 92.96 Mbps download, and 15.82 Mbps upload, I know it's not suddenly my connection. The videos are playing choppier on FireFox than when I had 8 Mbps download speed and about 0.1 Mbps upload.

I don't wanna go through a whole lot of rigamarole to get something to work, when I now have a perfectly working browser in the form of Chrome. I'm just gonna wait for FireFox to get its s*** together, and fix something that IT broke. I'm perfectly fine not using it until then. I'm not gonna put myself through tons of hassle for problems that FireFox itself has caused. This is just to maybe bring it to their attention that this is an issue that's occurring, and if I sound a bit annoyed, this is more civil than I originally felt.

Asked by ShinkuNoYami 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Random crashes when i listen to youtube music in the background.

Hello guys! I'm having some periodic crashes when i listen to youtube music in background. It happenes randomly, maybe once a week or sometimes twice a day. I tried remov… (read more)

Hello guys! I'm having some periodic crashes when i listen to youtube music in background. It happenes randomly, maybe once a week or sometimes twice a day.

I tried removing some unnecessary plugins but it didn't help.

Here are my logs in pending folder (or is there any way i can upload them in some readable form?)

https://drive.google.com/open?id=1nSkZKb2SSgUYPoNvrrBBYXNmoCugthPI

Asked by Dzinsham 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Disable video preview/preroll on websites

I have recently noticed that various websites (Washingon Post etc.) have an auto-roll preview of video articles, which I find annoying. The videos themselves don't autopl… (read more)

I have recently noticed that various websites (Washingon Post etc.) have an auto-roll preview of video articles, which I find annoying. The videos themselves don't autoplay, just the preview. Is there a way to disable this? (I'm running FF 63.0.1on Mac but also have it installed on a Windows machine.

The attached image is from the WaPo today (Nov.8). Thre are two previews for this article, about 5 secs. each.

Asked by oldbrownhat 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

.webm files and Ogg will not play in browser, and Plugin Container crashes each time Firefox is closed.

For the last month or so, I have had a problem in the recent stable version in which the media types listed above would not play or even load, giving me a "Video Format o… (read more)

For the last month or so, I have had a problem in the recent stable version in which the media types listed above would not play or even load, giving me a "Video Format or MIME type not supported" error. None of the .webm or Ogg files I have tried on websites such as http://www.quirksmode.org/html5/tests/video.html or http://www.webmfiles.org/demo-files/ have worked, and when I downloaded the Nightly the tab would crash whenever I loaded up such a format.

Coincidentally, when that problem started, I would get error messages whenever I quit Firefox with a "plugincontainer.exe has crashed" sort of message and a crash report window popping up. I think these problems may be related with a faulty plugin, as I have reinstalled Firefox multiple times to no avail. I may be wrong in that regard, however. Here are a few crash reports, too: bp-cff44b03-58f8-4386-98ca-0ec612150104 bp-44d0d7ba-76de-41d1-a7fb-4d0d92150104 14c02ff0-bae1-4abb-9e71-d27815ea49bb bp-dbbd168b-86cc-4e33-aff6-00a3a2150104 bp-edc00b5e-b127-4a24-a48b-149912150104

If anybody has any experience or suggestions to offer, that would be greatly appreciated. Thanks!

Asked by Slymax 5 years ago

Last reply by FredMcD 5 years ago

  • Archived

Video makes fans run obnoxiously compared to Safari

Using firefox to watch video such as amazon prime content causes the fans on my macbook to run obnoxiously compared to Safari for some reason. I don't get it. Why? Same v… (read more)

Using firefox to watch video such as amazon prime content causes the fans on my macbook to run obnoxiously compared to Safari for some reason. I don't get it. Why? Same video in both browsers using the same plugin causes very different results.

I use XRG app to watch the temps and stuff like fan speed.

Safari running the videos uses a good amount of CPU (~70% - 90%) and CPU die temp of 71C, where Firefox will run the CPU clear up to the 150%+ range and a die temp of 85+C. The second I stop the video, I see the case temps (sensor1,2,3) start to drop pretty quickly. Is there a different version of Silverlight for firefox that is different from Safari's? I'm stuck with Silverlight for the Amazon Prime stuff.

Pretty much, video in Firefox sends the case temps to somewhere around 39-42C, nothing crazy, but with the die temps, enough to kick the fans up to the 3500-4000 rpm range watching the videos.

Safari on the other had shows case temps around 30-32C and fans that sit steady at 1999- 2048 rpm watching the videos.

Asked by TimeDilation 5 years ago

Last reply by guigs 5 years ago

  • Archived

Facebook videos seem to cause Firefox to lose connection, other browsers work fine.

While on facebook, if I watch one or 4(Random number) videos using facebooks own player, not youtube, or scroll down my frontpage wich usually have a large number of vide… (read more)

While on facebook, if I watch one or 4(Random number) videos using facebooks own player, not youtube, or scroll down my frontpage wich usually have a large number of videos, firefox connection to the net seem to be lost. When this happends, whatever webpage I try to access in Firefox just gets a "Loading" status in the tabs bar.

Only fix so far is to close and relaunch Firefox.

When doing that, I also find that XMark Sync has lost connection and can't sync up.

While this happends, I have tried IE, Chrome and several chat softwares, like Skype, and these function as supposed to. So the issue is somewhere in Firefox.

The reason I point towards Facebook videos(html5?) doing something to Firefox, is that so far this has only happened while on Facebook, and while watching, stopping, switching to HD, skipping forward/back or scrolling past videos on the frontpage(These autostart when they are "front").

This happends at random, but alot, so much I have pretty much stopped scrolling the front page or looked at videos posted on facebook.


I am stumped.

Asked by ralpgalland 4 years ago

Last reply by guigs 4 years ago

  • Archived

Webcam is not working, only black image

Hi I have a problem with my new bought hp pavillion 10-k000ng with windows 8 1. The camera is working just fine outside firefox, but using it for firefox hello is not wor… (read more)

Hi I have a problem with my new bought hp pavillion 10-k000ng with windows 8 1. The camera is working just fine outside firefox, but using it for firefox hello is not working. No error message is shown, it only goes to a black image. I also do not get the media symbol beside the url field. I also tried other webpages for testing the webcam and on non it is working. Therefor, I think it must be a problem of firefox and not hello. Thank you very much for your help! cheers Evchen

Asked by evchen 4 years ago

Last reply by cor-el 4 years ago

  • Archived

html5 full screen video is choppy in Firefox only

When making videos full screen (from all sites I've tried so far, but specifically YouTube, Vimeo and some of the news outlets), the video gets choppy, like it's using a … (read more)

When making videos full screen (from all sites I've tried so far, but specifically YouTube, Vimeo and some of the news outlets), the video gets choppy, like it's using a much slower framerate.

I've tried this on all resolutions from 4K on down to 240 with the same results.

Flash works fine. The videos play just fine in the Echo browser. The videos play just fine in the small in window player, in Firefox.

I'm using FF 43.0.4. I've tried it in safe mode with the same results.

This is on a Dell XPS15, Windows 10 (1511), 16GB RAM, Intel 4600 and NVIDIA GeForce GT 750M video adapters. Hardware acceleration is disabled.

Again, Flash goes full screen just fine. HTML5 does not. What do I need to do to be able to enjoy full screen videos in HTML5?

Thank you.

Asked by skiahh 4 years ago

Last reply by Will Holden 4 years ago

  • Archived

How to rid the huge green line on videos on Firefox 59.0b6 (64-bit) + Windows 10?

I see there are known issues on "some Windows 8 configurations" with a huge green blob/line going down videos and maybe a shade of pink here and there, but I didn't see t… (read more)

I see there are known issues on "some Windows 8 configurations" with a huge green blob/line going down videos and maybe a shade of pink here and there, but I didn't see that this was known about on Windows 10. Please, have a screenshot and some diagnostic info! Thanks in advance!

Asked by anoncat 2 years ago

Last reply by Happy112 2 years ago

  • Archived

video downloaded with latest video downloadhelper is jerky and not smooth when playback

Hi, I am running the latest version of the Firefox and Video DownloadHelper. Since the Video DownloadHelper was updated with companion app, all videos downloaded are very… (read more)

Hi, I am running the latest version of the Firefox and Video DownloadHelper. Since the Video DownloadHelper was updated with companion app, all videos downloaded are very jerky and not smooth when playback. This issue has persisted for quite some time and no update of it has every resolved the issue. Could anybody offer help and suggestion how can I mitigate the problem? Thanks.

Asked by entphy 2 years ago

Last reply by FredMcD 2 years ago

  • Archived

youtube video formats not recognized

I'm receiving the error that the firefox 62 version that I have does not "recognize any of the video formats available" on youtube and I have also been having trouble wit… (read more)

I'm receiving the error that the firefox 62 version that I have does not "recognize any of the video formats available" on youtube and I have also been having trouble with being unable to open other webm formats. I have as the other solutions asked refreshed firefox to it's factory state but that has still not solved the problem. I have checked the plugins page and it does show that the openh.264 plugin is there. Not sure why this could be happening. Ubuntu Linux 18.04

Asked by quinnkjones 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Video playback (e.g. Youtube) slow, drops frames - VLC runs URL OK

On an older laptop running Ubuntu 16.04 LTS, with latest production Firefox version as of 24 Sep 2018, Youtube and other videos play poorly, loosing many frames or freezi… (read more)

On an older laptop running Ubuntu 16.04 LTS, with latest production Firefox version as of 24 Sep 2018, Youtube and other videos play poorly, loosing many frames or freezing video entirely, though audio continues. Restarting in Safe mode, all add-ons disabled, did not help at all.

Enabling and disabling Hardware acceleration and changing the maximum number of processes from 4 to other values (1, 2 and others) also did not improve display.

The Youtube HTML5 player verification, https://www.youtube.com/html5, shows all items checked, i.e. supported.

In contrast, copying the URL for thew video and pasting it into VLC (VideoLAN) network stream runs the video perfectly, so this is strictly a Firefox issue.

Google Chromium for Ubuntu was installed and played videos a bit more smoothly than did Firefox, though not as smoothly as VLC.

This appears to be a buffering issue. Increasing media.cache_readhead_limit and media.cache_resume_threshold did not force buffering for uninterrupted playback, though.

Asked by MoisheP 1 year ago

Last reply by Shadow110 1 year ago