Have thunderbird reindex mailboxes instead of compacting

I'm running Thunderbird 115.12.0 64-bit on Ubuntu 22.04. I recently had a hard drive crash. I've had to put together my email data from two separate backups to restore … (read more)

I'm running Thunderbird 115.12.0 64-bit on Ubuntu 22.04. I recently had a hard drive crash. I've had to put together my email data from two separate backups to restore everything. The problem is I reorganized the mailbox folders between the backups, so the metadata thunderbird maintains about the data storage will be wrong in my new setup. I have my imap and pop mailboxes restored correctly now under my profile storage and would like Thunderbird to just leave them alone. The problem is, every time I start thunderbird, it automatically wants to compact my mailboxes and free up 5.7 GB of space, which means it will delete some of the newly copied emails it doesn't recognize.

Is there a way to tell thunderbird to start over and reindex the mailboxes that are there? I've tried deleting the global-messages-db.sqlite file, but that does not fix the problem. This is a common problem as I've had it happen in the past as well when reorganizing the folder structure. It seems there should be a way to tell thunderbird to reset its indexes and leave the mailboxes as-is.

Any help would be appreciated.

Asked by wgadsby 4 hours ago

Last reply by david 8 minutes ago

Thunderbird "not responding" on Windows 10

Thunderbird takes forever to do anything and often it says it is not responding. My husband was the computer tech and he recently passed away. I try and delete extra em… (read more)

Thunderbird takes forever to do anything and often it says it is not responding. My husband was the computer tech and he recently passed away. I try and delete extra emails and empty the trash on all our email accounts regularly. what can be the problem?

Asked by GinnyandSteve 1 hour ago

Last reply by Wayne Mery 8 minutes ago

Infinite redirects

I am unable to login to a single microsoft service on firefox with my school account. It infinitely redirects to a different link and says "Sorry we're unable to sign you… (read more)

I am unable to login to a single microsoft service on firefox with my school account. It infinitely redirects to a different link and says "Sorry we're unable to sign you in" and I cannot even access the login page for microsoft office 365. I cleared all cookies and cache and even recreated my account 3 times and reinstalled fresh firefox 5 times. Nothing works.

Asked by jiunhan930 21 minutes ago

Last reply by cor-el 11 minutes ago

Dismissing Shortcuts on New Tabs Page

I used to be able to dismiss unwanted Shortcuts on the New Tabs Page, but now the three dots that popped up the menu for that are gone. Is there still a way to get rid … (read more)

I used to be able to dismiss unwanted Shortcuts on the New Tabs Page, but now the three dots that popped up the menu for that are gone. Is there still a way to get rid of them to make room for others? Also would like to have the option to choose shortcuts to place on the page.

Asked by moryock 17 minutes ago

Last reply by cor-el 12 minutes ago

Configure email account failure

I have an issue trying to configure a secondary email account, for a non-profit I do some work for. It was ok in the past, though I recall was tricky to set up on TB a co… (read more)

I have an issue trying to configure a secondary email account, for a non-profit I do some work for. It was ok in the past, though I recall was tricky to set up on TB a couple of years ago. But now it has ceased to function after I migrated TB profile (successfully apart from this issue) no matter what I try. I’d be grateful for any suggestions. As is the case with many non-profits, there’s little tech support, but others can use the email account ok. I think it may be a TB issue as I have been able to set up the account ok with MS new Windows Outlook app (lame, but better than Mail…low bar). I’d rather have this account on my TB client along with the others I use. And the issue is replicated on two of my PCs. TB account set up reports “can’t detect settings from host server”. I found a support thread link text, which says “The failure to detect settings is rather common where hosted domains are concerned. Mostly because everything is done to a price and most of the things around encryption are done in a halfhearted manner. As is the server setups for mail. However by faithfully copying the settings from the provider as to domains server name and ports it should work.” So I did manual configuration – copied the settings from the successful Outlook set up, but no dice – all I get is server time out message. Settings are: IMAP server: mail.XXXX.org.uk Port 993 Security SSL/TLS [earlier working settings were STARTTLS port 143] SMTP server: mail.XXXX.org.uk Port 465 Security SSL/TLS [[earlier working settings were STARTTLS port 587] And using Normal Password for both; I tried Autodetect too but no good. I’ve see a suggestion that turning off the firewall (Norton) might work, but I’m reluctant to do that and doesn’t seem to make sense that would cause the issue. I found another suggestion that apparently works for some people - leaving password blank on setup. https://support.mozilla.org/en-US/questions/1399690. Before I try, are there any other suggestions or ideas? Trivial matter in the long run, but bugging me. Thanks

Asked by hectorio 1 month ago

Last reply by Wayne Mery 13 minutes ago

clicking on links to emails won't bring up a new email message form

When I go to a website and click on an email address the New Message form does not come up. I have gone to Windows and made sure Thunderbird is set up as my default email… (read more)

When I go to a website and click on an email address the New Message form does not come up. I have gone to Windows and made sure Thunderbird is set up as my default email address. Chatgpt said: Check Thunderbird Settings

   Open Thunderbird.
   Go to Tools > Options (or Preferences on macOS).
   Click on the Advanced tab, then General tab.
   Ensure Thunderbird is set as the default mail client.

But when I go to tools I cannot find an options link.

Please advise. Thanks!

Asked by contact1073 3 hours ago

Last reply by david 17 minutes ago

Unable to access a financial account.

The latest Firefox update has made it impossible for me to log into https://www.discover.com/ I consistently receive the following error message: "Your account cannot cu… (read more)

The latest Firefox update has made it impossible for me to log into https://www.discover.com/ I consistently receive the following error message: "Your account cannot currently be accessed. Outdated browsers can expose your computer to security risks. To get the best experience on Discover.com, you may need to update your browser to the latest version and try again. For questions, please contact us at 1-800-347-7769. We're always available 24 hours a day, 7 days a week."

Pop up blocker in the address bar has been manually turned off and antivirus VPN has been manually turned off. Discover has told me the problem is with the browser not their website. I can access the account via one of the less secure browsers (edge) but am not comfortable with that company and would prefer this glitch being fixed if possible. Firefox info is version 128.0 and it automatically updated earlier this week. Thank you. Enjoy your weekend. Laurie

Asked by lnbg 2 hours ago

Last reply by cor-el 17 minutes ago

Nebula folder view

Just installed TB Nebula on new PC. I may be missing something but I can't make either Apply columns to... or Apply view to... work for child folders. The last time I tri… (read more)

Just installed TB Nebula on new PC. I may be missing something but I can't make either Apply columns to... or Apply view to... work for child folders. The last time I tried this was a while ago, probably on an early release of Supernova, but my recollection was that it was easy and quick. Anyone else found this? If not I'll keep trying. Otherwise Nebula looks v smart so far

Asked by hectorio 3 hours ago

Last reply by david 24 minutes ago

Is this the right way to add keyboard shortcuts to a WebExtensions Manifest V3 add on?

Raindrop.io add-on keyboard shortcuts are currently broken. I created a Pull Request to fix the issue, and would like someone in the know to check my code. TIA! … (read more)

Raindrop.io add-on keyboard shortcuts are currently broken. I created a Pull Request to fix the issue, and would like someone in the know to check my code. TIA!

Asked by Judah Richardson 26 minutes ago

Want to install v91.1.2 - v115 is buggy

Tried installing v115 latest on Ubuntu. Hangs when I try to set up email acc and it tries to log into the Gmail server. "Danger ahead" displayed on page with no option … (read more)

Tried installing v115 latest on Ubuntu. Hangs when I try to set up email acc and it tries to log into the Gmail server. "Danger ahead" displayed on page with no option to force it to proceed.

Thus please dispense with any solutions for this and just inform how I can install v91.1.2 using apt-get

I see you list the versions but I see no where on how to specify which version to install.

Asked by sales434 23 hours ago

Last reply by sales434 40 minutes ago

Thunderbird says it's retrieving emails but the panel is entirely blank

Hi, When trying to implement the OAuth for a live.com account the Thunderbird system seemed to lose everything. There was no sign of any emails the view was as the imag… (read more)

Hi,

When trying to implement the OAuth for a live.com account the Thunderbird system seemed to lose everything. There was no sign of any emails the view was as the image. The help page we used

https://support.mozilla.org/en-US/kb/microsoft-oauth-authentication-and-thunderbird-202

There were no errors or information.

On going back to the conventional settings of using a password we got information that emails were arriving via app poppups etc but still the view we get is the same as in the picture. Nothing at all in the view.

We have uninstalled and reinstalled Thunderbird and are now on v 128

Asked by peterkerner 50 minutes ago

Cox Changed my E-Mails to Yahoo- When Yahoo App Password is Entered, It is Not Saved by Thunderbird

Cox just transferred all customers' email systems to Yahoo. After my e-mails were transferred to Yahoo, Yahoo tried to help me when I was getting error messages saying th… (read more)

Cox just transferred all customers' email systems to Yahoo. After my e-mails were transferred to Yahoo, Yahoo tried to help me when I was getting error messages saying that log in to server smtp.mail.yahoo.com with my user name (my e-mail address) failed. The Yahoo rep told me that my problem is that "Whenever the generated app password from Yahoo is entered, sending emails works, but it only stays like that until the computer gets restarted. The app password is not saved." The rep told me that many Thunderbird users who had their email systems transferred to Yahoo are having the same problem. Has anyone had this problem and been able to resolve this problem? Thank you! Cyd

Asked by cgilman1 23 hours ago

Last reply by cgilman1 56 minutes ago

Thunder security exceptions for icloud

I cam getting constant and continuous multiple security exceptions for p53-caldav.icloud.com saying it's the wrong site. I have made not changes to the thunderbird setup… (read more)

I cam getting constant and continuous multiple security exceptions for p53-caldav.icloud.com saying it's the wrong site. I have made not changes to the thunderbird setup except for normal updates. i've confirmed these multiple times but they still keep coming. Any help would be great

Asked by Sharon Dankwardt 1 day ago

Last reply by Sharon Dankwardt 57 minutes ago