Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Context menu missing items

  • 5 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 50 προβολές
  • Τελευταία απάντηση από Kosal

more options

I'm having this exact problem from here , but browser.taskbar.lists.tasks.enabled has always been set to true. Toggling it does nothing in itself in between restarting my machine. I am certain it's not a jump menu thing because this isn't about shortcuts (and besides the point, enabling the jump shortcuts from my OS side of things does not display it either way). I just want the stuff that the user in the above link listed.

Coincidentally, I had this exact problem a short while before, and I think it may have had to do with an update, because I remember Firefox updating at least twice fairly recently and it is in this time I've noticed this issue. The first time around it resolved itself, but this time it has not and I do not know the cause.

Unpinning/pinning the icon on the task bar does not resolve this either. It seems none of the conventional solutions in the past work, so unless I am missing something, something broke.

I'm having this exact problem from [https://support.mozilla.org/en-US/questions/1180247 here] , but browser.taskbar.lists.tasks.enabled has always been set to true. Toggling it does nothing in itself in between restarting my machine. I am certain it's not a jump menu thing because this isn't about shortcuts (and besides the point, enabling the jump shortcuts from my OS side of things does not display it either way). I just want the stuff that the user in the above link listed. Coincidentally, I had this exact problem a short while before, and I think it may have had to do with an update, because I remember Firefox updating at least twice fairly recently and it is in this time I've noticed this issue. The first time around it resolved itself, but this time it has not and I do not know the cause. Unpinning/pinning the icon on the task bar does not resolve this either. It seems none of the conventional solutions in the past work, so unless I am missing something, something broke.

Επιλεγμένη λύση

cor-el said

Note that this new Windows taskbar jump list feature is behind browser.taskbar.lists.legacyBackend that got set to false by default in 124.

This didn't solve the problem even after a restart. It's still disabled even when enabling that to true.

EDIT: Maybe I spoke too soon. Enabling it did nothing, but disabling it back again brought it back to normal.

None of that is making much sense to me, unless the changes to that update somehow disabled it when I went from false, to true, to false again, with the last step having no effect on the update's changes. Mind boggling.

Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (5)

more options

What do you see in the context menu?

You can check these prefs in about:config about Private Browsing mode:

  • browser.privateWindowSeparation.enabled
  • browser.privacySegmentation.createdShortcut

Χρήσιμο;

more options

It's what I don't see. All I have is to open a Firefox window. That is it. None of the options as listed from that link.

Both of those prefs are enabled as true.

(I should clarify, I am missing the options listed on that page from the pinned icon on my taskbar. I am trying to restore that back to the context menu as I did nothing to remove it and I'm trying to get it back on the context menu.)

Τροποποιήθηκε στις από το χρήστη Kosal

Χρήσιμο;

more options

Update: I think I might have a source of the problem, but have not been able to go very far.

What may be relevant to this was the update (one of the two that I had while I noticed the issue first began) in about 124.0, with the note saying that "Firefox now populates the Windows taskbar jump list more efficiently, which should allow for a smoother overall browsing experience." without any further elaboration, which got carried over a few days later in the next, current update.

That gives me some ensurance that this does not fall into a sudden conflict with third party apps or features alone. It was deliberately manipulated (for whatever reason where I didn't need a QoL improvement). So, I was not going crazy, it was actually happening!

Either this gets fixed in another update, or I'll have to fix it on my own - but I know not how. It's a critical selling point for me, because right now it's identical to the other browsers I use where they have that look by default, and I'm loathe to use workarounds too often that would change how I use my system, which one of them would force me to use a pinned link to the private browser to use it in one click when I could have just had it in the context menu in the first place without adding the extra icon.

Τροποποιήθηκε στις από το χρήστη Kosal

Χρήσιμο;

more options

Note that this new Windows taskbar jump list feature is behind browser.taskbar.lists.legacyBackend that got set to false by default in 124.

Χρήσιμο;

more options

Επιλεγμένη λύση

cor-el said

Note that this new Windows taskbar jump list feature is behind browser.taskbar.lists.legacyBackend that got set to false by default in 124.

This didn't solve the problem even after a restart. It's still disabled even when enabling that to true.

EDIT: Maybe I spoke too soon. Enabling it did nothing, but disabling it back again brought it back to normal.

None of that is making much sense to me, unless the changes to that update somehow disabled it when I went from false, to true, to false again, with the last step having no effect on the update's changes. Mind boggling.

Τροποποιήθηκε στις από το χρήστη Kosal

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στον λογαριασμό σας για να απαντήσετε σε δημοσιεύσεις. Ξεκινήστε μια νέα ερώτηση εάν δεν διαθέτετε ακόμα λογαριασμό.