Αναζήτηση υποστήριξης

Αποφύγετε τις απάτες υποστήριξης. Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου, ή να μοιραστείτε προσωπικές πληροφορίες. Παρακαλούμε αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής “Αναφορά κατάχρησης”.

Learn More

How do I disable the EME icon animation every time I open a tab with DRM content?

  • 17 απαντήσεις
  • 1 έχει αυτό το πρόβλημα
  • 297 προβολές
  • Τελευταία απάντηση από Jelle Z.

more options

Each and every time I open up a tab with a website loaded that uses DRM, the EME logo shakes. When I switch to another tab and then switch back to the previous tab, it shakes again. Is there some way to disbale this animation, perhaps in about:config? I'm aware that I am using DRM and I do not need to be informed about it again and again.

Perhaps make it so the icon only shakes once or only when you first visit a site that uses DRM content for the first time in a future update of Firefox? I can imagine this will be very annoying for other Firefox users.

Επιλεγμένη λύση

Note that this code should be in userChrome.css.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#eme-notification-icon[firstplay=true] {
  animation: none !important;
}

So you still see the animation when the pref is set to true?

  • browser.eme.ui.firstContentShown = true
Ανάγνωση απάντησης σε πλαίσιο 👍 1

Όλες οι απαντήσεις (17)

more options

What is EME  ?

more options

Hi, never seen it before. I can play anything. Provide a URL please where you are having problems.

If Adobe EME is installed I have not heard about it as it is Google Wildvine

more options

Download :

Backup :

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData

Please let us know if this solved your issue or if need further assistance.

more options

The little icon in the site identity area --

-- it shakes on yours? Side-to-side, or ???

You can use custom style rules to selectively hide icons from that area which you don't ever want to see. For example:

/* Hide EME icon from site identity area */
#eme-notification-icon {
  display: none !important;
}

Custom style rules are applied using a userChrome.css file, so when you have 10 minutes to set that up, you can start here:

https://www.userchrome.org/how-create-userchrome-css.html

more options

I see this style rule:

#eme-notification-icon[firstplay=true] {
  animation: emeTeachingMoment 0.2s linear 0s 5 normal;
}

@keyframes emeTeachingMoment {
  0% {transform: translateX(0); }
  25% {transform: translateX(3px) }
  75% {transform: translateX(-3px) }
  100% { transform: translateX(0); }
}

Τροποποιήθηκε στις από το χρήστη cor-el

more options

Seems to be triggered by this pref on the about:config page. So make sure that this pref is true to prevent the animation.

  • browser.eme.ui.firstContentShown = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Τροποποιήθηκε στις από το χρήστη cor-el

more options

cor-el, that's interesting! So if Firefox does it every time, perhaps it's an example of a problem covered by this article: How to fix preferences that won't save. Or maybe for some odd reason the preference is locked.

more options

I’m not looking to remove the item, just the animatiom that tries to grab your attention. The animation does indeed seem to be tied to browser.eme.ui.firstContentShown, but it seems to be broken/have no effect.

I think it’s possible to stop the animation from happening, perhaps with overwriting the animation with a static instantinious one. I’ll try later this day to see whether it fixes anything.

But... is this animation supposed to play everytime you open the tab? It seems that it was only meant to play only once to notify the user about DRM, not every time. Perhaps it’s a bug?

I’ve tried reinstalling Firefox, but it still doesn’t fix the issue. I’ve played around with a bunch of other preferences in about:config and in the browser settings and they all did save.

Τροποποιήθηκε στις από το χρήστη Jelle Z.

more options

@jshjscher2000 said

-- it shakes on yours? Side-to-side, or ???

Yes, it shakes from side to side every time I open the tab, regardless of whether I’ve seen it before or have clicked on the icon to learn more about DRM.

more options

jelle619 said

But... is this animation supposed to play everytime you open the tab? It seems that it was only meant to play only once to notify the user about DRM, not every time. Perhaps it’s a bug?

As far as I know, "first time" means "first time ever" and it shouldn't animate over and over.

Maybe:

#eme-notification-icon[firstplay=true] {
  animation: none !important;
}
more options

Επιλεγμένη λύση

Note that this code should be in userChrome.css.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#eme-notification-icon[firstplay=true] {
  animation: none !important;
}

So you still see the animation when the pref is set to true?

  • browser.eme.ui.firstContentShown = true
more options

Yes, I do indeed still the animation when set to true. I will try to add the code to my userChrome.css later today. Thanks for helping me out everybody!

more options

Pkshadow said

Download : Backup : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Please let us know if this solved your issue or if need further assistance.

Hi, what was wrong with the Firefox EME Free, I thought this is what you wanted.

more options

Pkshadow said

Hi, what was wrong with the Firefox EME Free, I thought this is what you wanted.

You can't play DRM-protected video in Firefox without EME.

more options

Applying the code to the userChrome.css seems to have helped. jscher2000, thanks a lot for your code suggestion. Cor-el, thanks a lot for explaining how to use userChrome.css. Also a lot of thanks to everybody else who tried to help. :-)