Hilfe durchsuchen

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

FF often doesn't load pages, or takes ages to load them (not slow loading)

  • 10 Antworten
  • 26 haben dieses Problem
  • 5152 Aufrufe
  • Letzte Antwort von BarbMeek

more options

Hi! I've readed many topics about this, but nothing helped. Last solution I've found on this site is about the "No Proxy" setting, but that didn't help too. I have no problems at all with FF 3.6, and I'm still using it most of the times, but I can't keep doing this for much longer, and some sites already won't work with it. I didn't like FF 4\5 so I've never used them "online", but since I've started trying out newer version, I've always had this problem (FF 12+, up to 21.0). 3.6 never had such problem, I can open 20 bookmarks from the same site at once and it does it flawlessly. I use Windows XP and Sandboxie, and I install FF directly into the sandbox. Tried disabling or not installing any plugin at all, nothing changes. Tried installing it over the working 3.6, tried with clean installs and with the reset function. Sometimes it loads pages without any prolem, but most of the times it takes ages and it's stuck at the blank page with the spinning weel for 30+ seconds. Sometimes, if i open two new tabs from te same site within a second, one of them loads, the other doesn't. Sorry for the long post and for my bad English. Thank you! :)

Alle Antworten (10)

more options
more options

Thank you, Tylerdowner, but it's not firewall's fault. I don't even use a template for FF, just "allow all" on KIS. FF 3.6 never has\had such problem, while every newer version has it. I must say I use a modified version of Windows XP, but I just removed some components with nLite, didn't add anything except drivers and a few other essential programs. I am using a clean install of Windows, and tried on many other installations in the past, FF is the only application having this problem, but I remember I've tried Opera once, because of this, and it was having the same problem as FF, just not that bad. Will try Opera again to see if anything changed. Still, FF 3.6 works without any problem. :(

more options

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

Thank you, cor-el!

Both FF and the plugin-container have the "allow all" rule set. The profile is "new", the whole sandbox and the installation are clean, I've tried it many times in many different ways, without any plugin at all, with and without installing the new version over the working 3.6 installation. I've even tried with a clean installation, without changing any option. Maintenance Service isn't installed, automatic updates are disabled.

I've tried these solutions, found on other topics about the same problem:

Setting network.http.keep-alive to "false". I had to create that entry.

Create and set network.dns.disablePrefetch to "true".

Disabled hardware acceleration.

Network connection set to "No Proxy".

It doesn't do it all the times, sometimes it works without any problem. But often it starts doing it, like if the network wasn't working, or the site was offline. But when there are like 3/4 pages stuck at "loading" from the same site, if I try refreshing one many times, sometimes it loads, while the others are still "blank". So the site works and my network does, too, but FF still won't open those before many other seconds, or unless I click "refresh". The rare times it doesn't have this problem, I can open dozens of pages withing seconds and there's no problem at all. I have a 6Mbit/0.5Mbit DSL connection, the computer is connected directly to the router (not exacly a router, they call it a HAG, the line\phone cable goes into it, and network cables come out of it, there's no router between it and the computer).

FF 3.6 never did this, and still doesn't (I still use it because of this problem). If I install FF 3.6 in a clean sandbox, and FF 21.0 in another clean one, and try to use them, the 3.6 has no problems, while the 21.0 still has it.

It's like something has been changed in the way FF connets\works (after version 3.6), and now my Windows isn't good anymore for FF. Can it be possible? Maybe I've removed some Windows component that wasn't needed by FF 3.6, but that causes this problem with the newest versions?

more options

network.http.keep-alive is no longer used, so you can reset this pref and it will be removed on the next start.


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

I have a similar issue but it seems to be related only to shortcuts on my desktop (or other folders) and web page links in my Outlook contacts. Sometimes they load immediately, sometimes they take a couple of minutes to load. However, if I copy the URL in the shortcut properties or in the Outlook contact and just paste it into Firefox, the page loads immediately. I have worked around this issue by bookmarking pages within Firefox, but I have dozens of web pages entered in my Outlook contacts and having to copy and paste those URLs into Firefox is tedious at best. This does not appear to be an issue with Internet Explorer, but I got so tired of all the ads that I made Firefox my default browser and installed AdBlock. My Firefox version is 23.0.1. Any ideas that don't require me to be a computer genius would be appreciated.

more options

Heres a suggestion, ask a new question, it gives us info about your configruration (version, OS, addons, plugins), we cant see that if you bump a three month thread (which emails everyone), and your problem is more likely to get solved.

more options
more options

Good idea -- I didn't know that. I thought I was continuing an ongoing discussion. I'll try that.

more options

I don't know how to check for problems with DDE. Would appreciate any help.