Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Unable to play live videos/streams on ubuntu

  • 14 Antworten
  • 0 haben dieses Problem
  • 2 Aufrufe
  • Letzte Antwort von zeroknight

more options

Over the past few weeks I've been unable to watch live videos on Firefox on Ubuntu 22.04. I thought it was just an issue with Twitch but I realized the problem also persists on live videos on Youtube and did some troubleshooting which didn't solve the issue. The only solution I was able to find for Ubuntu said to install ffmpeg, which I already had, but I made sure it was upgraded, refreshed Firefox, and still have the issue. Currently I'm on Firefox 121.0 but I've had this issue since before I updated it. I dual boot Ubuntu and Windows and am not having this issue when I boot Windows on the same computer and Firefox profile.

Over the past few weeks I've been unable to watch live videos on Firefox on Ubuntu 22.04. I thought it was just an issue with Twitch but I realized the problem also persists on live videos on Youtube and did some troubleshooting which didn't solve the issue. The only solution I was able to find for Ubuntu said to install ffmpeg, which I already had, but I made sure it was upgraded, refreshed Firefox, and still have the issue. Currently I'm on Firefox 121.0 but I've had this issue since before I updated it. I dual boot Ubuntu and Windows and am not having this issue when I boot Windows on the same computer and Firefox profile.

Alle Antworten (14)

more options

Show what you're getting when trying to play video. see screenshot

Did you try Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#search104

Can we get system info.


Operating System: openSUSE Tumbleweed 20231226 KDE Plasma Version: 5.27.10 KDE Frameworks Version: 5.113.0 Qt Version: 5.15.11 Kernel Version: 6.6.7-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Xeon® CPU E3-1535M v6 @ 3.10GHz Memory: 62.2 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics P630 Manufacturer: HP Product Name: HP ZBook 17 G4

Geändert am von jonzn4SUSE

more options

Make sure you have the latest FFmpeg and libavcodec packages installed.

more options

As I mentioned in the original post I have already made sure my ffmpeg package is up to date. Doing the same for libavcodec it was unable to find the package. I had the same issue in troubleshoot mode. I've attached a screenshot of what I'm getting on youtube which is the same as the errors I was seeing in other people's posts about similar issues but following their solutions (updating ffmpeg, updating firefox) hasn't solved it. Also added a screenshot of system info

more options

You can check the Web Console (Ctrl+Shift+K) to see if there is more detail available.

more options

Interesting... Same issue for me with Firefox in Safe Mode and privacy on Standard on the stable version of openSUSE Leap, but the KDE browser works. see screenshots Let me go see what happens on the bleeding edge rolling version Tumbleweed.

https://www.youtube.com/watch?v=R34ot1LETK0

more options

Here are the ffmpegs on openSUSE Leap. see screenshot What do you have installed?

Geändert am von jonzn4SUSE

more options

On the rolling bleeding edge version of openSUSE it works. see screenshots When it comes to ffmpegs, there are more things installed on Tumbleweed than Leap. I'm going to compare what's installed on Leap and make it match what's on Tumbleweed to see if it works, but IMHO this is more of a system issue and not a browser issue.

Geändert am von jonzn4SUSE

more options

You could also just join Team Green!  ;-)) Another happy user! https://www.youtube.com/watch?v=pcFiiE1ow5o

On this site they talk about rolling releases and I see something called Rhino (never heard of it) for Ubuntu. https://itsfoss.com/best-rolling-release-distros/

Geändert am von jonzn4SUSE

more options

After updating the packages on Leap to match Tumbleweed. The video now works. see screenshots Just update your packages using the screenshot and see if it works for you. Let us know.

more options

Even other video sites like Rumble are working on this computer now. Thanks ;-))

Geändert am von jonzn4SUSE

more options

I'm curious to know if this worked for you.

Geändert am von jonzn4SUSE

more options

jonzn4SUSE said

Here are the ffmpegs on openSUSE Leap. see screenshot What do you have installed?

I'm not sure where to check this? I have ffmpeg version 4.4.2. I don't use openSUSE so not sure if your suggestion would require me to be using that distribution or if it'd also apply to ubuntu 22.04 which is what I have

more options

Time to hit the Ubuntu forums.

more options

Try installing the Firefox flatpak package and the ffmpeg flatpak:

flatpak install org.freedesktop.Platform.ffmpeg-full