Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

DNS over HTTPS with Nord VPN Not Updating Status

  • 2 Antworten
  • 0 haben dieses Problem
  • 1 Aufruf
  • Letzte Antwort von zeroknight

more options

OS: Ubuntu 23.10 Firefox version: 119.0 Mozilla Firefox Snap for Ubuntu

I have DNS over HTTPS enabled and set to Default Protection in Firefox.

According to the following article (https://support.mozilla.org/en-US/kb/dns-over-https?as=u&utm_source=inproduct#w_why-would-a-network-tell-firefox-not-to-use-secure-dns) DNS over HTTPS should automatically switch to "Not Active" when connected to a VPN.

I am using the NordVPN CLI for linux and have found that when I connect to the VPN, Firefox DNS over HTTPS stays active and does not switch to "Not Active" like it is supposed to.

Does anyone know why this might be happening?

OS: Ubuntu 23.10 Firefox version: 119.0 Mozilla Firefox Snap for Ubuntu I have DNS over HTTPS enabled and set to Default Protection in Firefox. According to the following article (https://support.mozilla.org/en-US/kb/dns-over-https?as=u&utm_source=inproduct#w_why-would-a-network-tell-firefox-not-to-use-secure-dns) DNS over HTTPS should automatically switch to "Not Active" when connected to a VPN. I am using the NordVPN CLI for linux and have found that when I connect to the VPN, Firefox DNS over HTTPS stays active and does not switch to "Not Active" like it is supposed to. Does anyone know why this might be happening?
Angefügte Screenshots

Alle Antworten (2)

more options

It's explained in this article: Canary domain - use-application-dns.net

more options

ProtonVPN CLI has the expected behavior for me on Ubuntu 23.10 with the Firefox snap package, turning it on immediately causes DoH in "Default Protection" mode to switch status from "Active" to "Off". The system status bar shows "VPN" when connected.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.