Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox saved passwords not functioning on new iMac.

  • 4 Antworten
  • 1 hat dieses Problem
  • 12 Aufrufe
  • Letzte Antwort von cor-el

more options

I have a new iMac (sonoma): I've migrated previous data to this machine and updated Firefox, but saved passwords are having problems. Some of my paid subscriptions are not letting me sign in, either through saved pws, or doing it manually. A few others seem to work okay. I've tried a few on Safari, where they work, so I suspect I have to change a setting in Firefox. But what? Any advice gratefully received.



/edit: moved thread from Firefox for iOS (for iPhone/iPad) to Firefox section as you have macOS

I have a new iMac (sonoma): I've migrated previous data to this machine and updated Firefox, but saved passwords are having problems. Some of my paid subscriptions are not letting me sign in, either through saved pws, or doing it manually. A few others seem to work okay. I've tried a few on Safari, where they work, so I suspect I have to change a setting in Firefox. But what? Any advice gratefully received. /edit: moved thread from Firefox for iOS (for iPhone/iPad) to Firefox section as you have <b>macOS</b>

Geändert am von James

Alle Antworten (4)

more options

Question is how did you migrate the data? If one didn't use the Firefox FAQ on data migration there are high chance the new system doesn't recognize folder and files copied and will remove them as unneeded or corrupted data and deletes them.

more options

Did you copy logins.json and key4.db from the old device to the profile folder on the new device or did you use Sync or transfer them otherwise ? Do you see all logins in the Password Manager (about:logins) ?

more options

I transferred with an external hard drive and Time Machine. The passwords are there: they show up seamlessly in Safari. But not in Firefox. Turns out I can get what I need to function in Private mode, but not in regular mode.

I'll check the Firefox FAQ on data migration. Thanks for this, all.

more options

If you aren't able to login then there might be a problem with the cookies (stored in cookies.sqlite).

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings) or click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

You can check for issues with Total Cookie Protection.


If clearing cookies doesn't help, it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.