Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Themes are synced even though I've disabled it with lightweightThemes and activeThemeID

  • 6 Antworten
  • 1 hat dieses Problem
  • 14 Aufrufe
  • Letzte Antwort von Cédric

more options

Hello,

I have 3 different profiles and I'd like to have a visual indication of the currently active profile. I've found that using themes is the best option (a red theme for production, green for test, grey for default) but I can't prevent Firefox Sync to sync the active theme between my profiles.

I have set both services.sync.prefs.sync.extensions.activeThemeID and services.sync.prefs.sync.lightweightThemes to false and restarted all my Firefox profiles.

After a while, all windows/profiles are synced to the same theme.

Are those settings really read by Firefox Sync ? I'm on Windows 10, Firefox 91.10.0esr (32-bit)

Thanks in advance for your help !

Hello, I have 3 different profiles and I'd like to have a visual indication of the currently active profile. I've found that using themes is the best option (a red theme for production, green for test, grey for default) but I can't prevent Firefox Sync to sync the active theme between my profiles. I have set both services.sync.prefs.sync.extensions.activeThemeID and services.sync.prefs.sync.lightweightThemes to false and restarted all my Firefox profiles. After a while, all windows/profiles are synced to the same theme. Are those settings really read by Firefox Sync ? I'm on Windows 10, Firefox 91.10.0esr (32-bit) Thanks in advance for your help !

Ausgewählte Lösung

Setting services.sync.prefs.sync.extensions.activeThemeID = false should be sufficient to exclude the theme from sync (the other pref is no longer supported). You can also try this pref in addition:

  • services.sync.addons.ignoreUserEnabledChanges = true
Diese Antwort im Kontext lesen 👍 2

Alle Antworten (6)

more options

Hi

As a first step O recommend that you reverse those about:config prefs. They may not be needed for this.

If you open your Firefox Sync settings, do you have add-ons set to sync?

Hilfreich?

more options

Yes, I have everything checked except credit cards and open tabs.

Hilfreich?

more options

I have created brand new profiles using the profile manager and activated Firefox Sync in each one and so far it seems the theme isn't changed whenever Sync runs.

I have a feeling my problem was due to how I created the profiles before: after creating a new profile, I copied the content of my main profile folder under AppData\Roaming\Mozilla\Firefox\Profiles to the new profile folder, as I wanted to keep the same toolbar layout. Maybe this messed things up ? What's the best way to duplicate a profile then ?

Hilfreich?

more options

Well, it seems I spoke too soon, the default grey theme got applied on all profiles again... Really frustrating !

Hilfreich?

more options

Ausgewählte Lösung

Setting services.sync.prefs.sync.extensions.activeThemeID = false should be sufficient to exclude the theme from sync (the other pref is no longer supported). You can also try this pref in addition:

  • services.sync.addons.ignoreUserEnabledChanges = true

Hilfreich?

more options

I think that last setting made the trick : the enabled/disabled status of the themes aren't synced between profiles anymore, and as result, each profile keeps its active theme even after a sync. Thanks !

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.