Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How do I make these fonts bold?

more options

As you can see from the screenshot, they are hard to read.

Angefügte Screenshots

Geändert am von cor-el

Ausgewählte Lösung

I notice this line at the bottom of your code that doesn't work for current releases because they changed browser.xul to browser.xhtml as the consequence of moving from XUL to HTML namespace. Best is to leave out and only leave the #PlacesToolbarItems line.

@-moz-document url(chrome://browser/content/browser.xul){
  #PlacesToolbarItems { font-weight: bold !important; }
}

Change to :

 #PlacesToolbarItems { font-weight: bold !important; }

For that tab bar you need the .tabbrowser-tab selector. You may have to adjust the text color as well.

.tabbrowser-tab { font-weight: bold !important; }
Diese Antwort im Kontext lesen 👍 1

Alle Antworten (8)

more options

Are you possibly using code in userChrome.css that could cause this?

Looks like a problem with the lightweight theme that you use to style the navigator toolbox area with a background image. You can try a different theme to see if you can find one that works better.

Any special reason you use an outdated and no longer supported Firefox version ?

Hilfreich?

more options

Thanks for the very helpful information, especially the link with all the code. However, I do not see any code to do with this issue at the site. Can you please give me the lines of code I need to add to the userchrome.css file?

The reason am using an older version is deliberate as the add-ons I want have stopped working with the new versions.

Geändert am von Fire Marshal Bil

Hilfreich?

more options

One more question. I would like the tab fonts to be bold and black. What line would I add to the userchrome.css file to accomplish this? I modified it around to match what I want but this one eludes me. This is the only one that even came close.

#PlacesToolbarItems { font-weight: bold !important; }

Pl. see screenshot. Thanks. Here is the entire code:

/* 4. TABS: on bottom [display: block !important;] is a fix for ff 71*/
/* Those 2 lines, maybe don't need. */
/* #navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10} */
/* #TabsToolbar {-moz-box-ordinal-group:1000!important} */

#TabsToolbar {
 display: block !important;
 position: absolute !important;
 bottom: 0 !important;
 width: 100vw !important;
}

.tab-background[selected="true"] {
    background-attachment: none!important;
    background-color: #d0850d!important;
    background-image: none!important;
    background-position: none!important;
    background-repeat: none!important;
    background-size: none!important;
}

/* ROUNDED INACTIVE TABS */
.tabbrowser-tab::after, .tabbrowser-tab::before {
border-left: none !important;
}
.tab-background {
border-radius: 12px 12px 0px 0px !important;
}
.tab-line {
display: none !important;
}

#tabbrowser-tabs {
  width: 100vw !important;
}
#main-window:not([chromehidden*="toolbar"]) #navigator-toolbox {padding-bottom: var(--tab-min-height) !important;}

:root #tabbrowser-tabs {
 --tab-min-height: 28px !important; /* needs to be the same as above under :root */
 --tab-min-width: 80px !important;
}

#TabsToolbar {
 height: var(--tab-min-height) !important;
 margin-bottom: 1px !important;
 box-shadow: ThreeDShadow 0 -0px inset, -moz-dialog 0 0px !important;
}

#tabbrowser-tabs,
#tabbrowser-tabs > .tabbrowser-arrowscrollbox,
.tabbrowser-tabs[positionpinnedtabs] > .tabbrowser-tab[pinned] {
  min-height: var(--tab-min-height) !important;
  max-height: var(--tab-min-height) !important;
}

/* 6. drag space */
.titlebar-spacer[type="pre-tabs"],
.titlebar-spacer[type="post-tabs"] {
  width: 40px;
}

/* 7. Override vertical shifts when moving a tab */
#navigator-toolbox[movingtab] > #titlebar > #TabsToolbar {
  padding-bottom: unset !important;
}
#navigator-toolbox[movingtab] #tabbrowser-tabs {
  padding-bottom: unset !important;
  margin-bottom: unset !important;
}
#navigator-toolbox[movingtab] > #nav-bar {
  margin-top: unset !important;
}

/* Combine nav and menu bars */
#nav-bar {
	padding-left: 310px !important;
}

#toolbar-menubar {
	-moz-box-ordinal-group: 2 !important;
	min-height: .1px !important;
	max-height: 0px !important;
}

#main-menubar {
	z-index: 1;
	height: 32px !important;
	position: absolute !important;
}

#PersonalToolbar {
	-moz-box-ordinal-group: 4 !important;
}

/* Change the bookmarks folder color */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

.bookmark-item[container] {
  fill: red  !important;
}

@namespace xul url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

@-moz-document url(chrome://browser/content/browser.xul){

#PlacesToolbarItems { font-weight: bold !important; }

}

Geändert am von cor-el

Hilfreich?

more options

The code you posted is for the Bookmarks Toolbar.

#PlacesToolbarItems { font-weight: bold !important; }

Your first screenshot shows the menu bar. That would be this code.

#menubar-items { font-weight: bold !important; }

Hilfreich?

more options

Thanks kindly.

So, I added the line: #menubar-items { font-weight: bold !important; } to the end of the css file inside the flower bracket and rebooted Firefox, but nothing has changed. The fonts on the tabs are still not bolded. Any suggestions?

TIA.

Hilfreich?

more options

Ausgewählte Lösung

I notice this line at the bottom of your code that doesn't work for current releases because they changed browser.xul to browser.xhtml as the consequence of moving from XUL to HTML namespace. Best is to leave out and only leave the #PlacesToolbarItems line.

@-moz-document url(chrome://browser/content/browser.xul){
  #PlacesToolbarItems { font-weight: bold !important; }
}

Change to :

 #PlacesToolbarItems { font-weight: bold !important; }

For that tab bar you need the .tabbrowser-tab selector. You may have to adjust the text color as well.

.tabbrowser-tab { font-weight: bold !important; }

Hilfreich?

more options

For all items in the navigator-toolbox you can use this code instead of the individual CSS selectors.

#navigator-toolbox { font-weight: bold !important; }

Hilfreich?

more options

Thank you so much for all your valuable help.

I added the following two lines and got exactly what I wanted:

#PlacesToolbarItems { font-weight: bold !important; }
#tabbrowser-tabs { font-weight: bold !important; }

Geändert am von cor-el

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.