Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Certificate Error SSL_ERROR_BAD_CERT_DOMAIN

  • 1 Antwort
  • 1 hat dieses Problem
  • 7 Aufrufe
  • Letzte Antwort von FredMcD

more options

Background -- I have a Synology Disk Station. When setting it up, in order to make a secure connection I registered the Domain I planned to use with Synology and received a registered Domain Name. I then applied for and received a certificate from “Lets Encrypt. It worked fine for a few years. I was able to login to the Disk Station Locally using the Local Network IP I had assigned to it, and also able log in via the registered Domain through Synology with a Secure Connection using either method when logging in. Everything worked perfectly. Over a year ago I had some issues with my network (it has been too long ago for me to remember what it was). I could not resolve it, so when I called Netgear Tech Support they had me reset my router to factory settings. This did fix the issue I was having, but I later noticed resetting had changed my IP address. I thought this was not a problem at the time. It was then I also noticed I was no longer getting a Secure Connection on through my Disk Station. Have been trying to resolve this on my own, but I am not having any luck. But I am learning as I go. Present Day – I am still having issues logging in. The message I get when I log into the Synology registered Domain with Firefox is "Unable to Connect". I tried Chrome and get a similar message. When I log in locally using the assigned IP address I get "Warning: Potential Security Risk Ahead".

I click on the "Advanced" button where Firefox displays the Error Message:  SSL_ERROR_BAD_CERT_DOMAIN.  I continue with the exception and able to log into the Disk Station. 

My Goal is to get it working with a secure connection as it did before the Router Reset. -- I have checked all the appropriate ports are open. 5000 and 5001. -- Have checked for any firewall restrictions. -- I have tried replacing the previous certificate with a new one. -- Synology Tech Support does not seem to know, so I figure the problem lies within Windows 10 or Firefox. -- The Certificate in my Windows mmc Console says the Certificate is OK. Weather that is the one that is used for this connection I am speaking of, I do not know. -- The Certificate is current and has not expired. My apologies for this description being lengthy, I just want to make sure I state everything I can think of in order to get this fixed. I do not know a lot about this topic, but am learning as I go. Any help is very much appreciated.

Ausgewählte Lösung

Alle Antworten (1)

more options

Ausgewählte Lösung

  • MOZILLA_PKIX_ERROR_MITM_DETECTED
  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER


There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

Websites don't load - troubleshoot and fix error messages

http://kb.mozillazine.org/Error_loading_websites

What do the security warning codes mean

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.