X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox is making multiple processes again

Veröffentlicht

Once again, Firefox is making multiple processes in the task manager. I've already set both browser.tabs.remote.autostart.2 and browser.tabs.remote.autostart to false, yet I still have multiple processes anyway, and setting the content process limit to 1 doesn't seem to do anything. I'm using Firefox version 68.0 and running Window 7.

Once again, Firefox is making multiple processes in the task manager. I've already set both browser.tabs.remote.autostart.2 and browser.tabs.remote.autostart to false, yet I still have multiple processes anyway, and setting the content process limit to 1 doesn't seem to do anything. I'm using Firefox version 68.0 and running Window 7.
Angefügte Screenshots

Ausgewählte Lösung

You can also set an environment variable in the Windows Control Panel => System.

You can create a firefox-e10s.cmd file with this content:

set MOZ_FORCE_DISABLE_E10S=1
start "" "<path_to_firefox>\firefox.exe"
  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"
Diese Antwort im Kontext lesen 1
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Weitere Informationen

My_Cheese_Is_Slippin'
  • Top 10 Contributor
56 Lösungen 705 Antworten
Veröffentlicht

Hi Tathamet, This article from ghacks will help explain what is going on: Multi-Process Firefox: everything you need to know

Hi Tathamet, This article from ghacks will help explain what is going on: [https://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-Process Firefox: everything you need to know]
Hat Ihnen das weitergeholfen? 0
Zitieren

Fragesteller

While it's nice to know what's going on, it doesn't really do a good job of explaining how I can disable it, which is what I'm looking to do, sorry if I didn't really make that clear in the original post. Any ideas on how I can do that?

While it's nice to know what's going on, it doesn't really do a good job of explaining how I can disable it, which is what I'm looking to do, sorry if I didn't really make that clear in the original post. Any ideas on how I can do that?

Geändert am von Tathamet

Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
520 Lösungen 4893 Antworten
Veröffentlicht

Hilfreiche Antwort

Hello Tathamet,

You can set an environment variable to disable multi-process. :

• set MOZ_FORCE_DISABLE_E10S=1

How to set environment variables : http://www.computerhope.com/issues/ch000549.htm

You can use the set command to create a temporary environment variable.

  • open command prompt window
  • change to installation directory
  • type "set MOZ_FORCE_DISABLE_E10S=1" and press enter
  • type "firefox.exe" and press enter

How to use set command : http://www.computerhope.com/sethlp.htm

'Hope that will work for you .....

Hello Tathamet, You can set an environment variable to disable multi-process. : • set MOZ_FORCE_DISABLE_E10S=1 How to set environment variables : http://www.computerhope.com/issues/ch000549.htm You can use the set command to create a temporary environment variable. * open command prompt window * change to installation directory * type "set MOZ_FORCE_DISABLE_E10S=1" and press enter * type "firefox.exe" and press enter How to use set command : http://www.computerhope.com/sethlp.htm 'Hope that will work for you .....
Hat Ihnen das weitergeholfen? 2
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17416 Lösungen 157344 Antworten
Veröffentlicht

Ausgewählte Lösung

You can also set an environment variable in the Windows Control Panel => System.

You can create a firefox-e10s.cmd file with this content:

set MOZ_FORCE_DISABLE_E10S=1
start "" "<path_to_firefox>\firefox.exe"
  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"
You can also set an environment variable in the Windows Control Panel => System. You can create a firefox-e10s.cmd file with this content: <pre><nowiki>set MOZ_FORCE_DISABLE_E10S=1 start "" "<path_to_firefox>\firefox.exe"</nowiki></pre> *(64-bit Firefox) "C:\Program Files\Mozilla Firefox\" *(32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"
Hat Ihnen das weitergeholfen? 1
Zitieren
davidearlagoura 0 Lösungen 3 Antworten
Veröffentlicht

I tried both of these 3 times. They did not work. I have tried EVERYTHING suggested on ALL of the Mozilla suggestion pages. NOTHING works. All the Firefox iterations in Taskmanager keep locking up my computer and crashing Firefox. I even completely uninstalled and reinstalled Firefox (and lost all my settings even though I did everything I was supposed to). If I cant find a solution soon I will simply have to abandon Firefox completely.

I tried both of these 3 times. They did not work. I have tried EVERYTHING suggested on ALL of the Mozilla suggestion pages. NOTHING works. All the Firefox iterations in Taskmanager keep locking up my computer and crashing Firefox. I even completely uninstalled and reinstalled Firefox (and lost all my settings even though I did everything I was supposed to). If I cant find a solution soon I will simply have to abandon Firefox completely.
Hat Ihnen das weitergeholfen? 1
Zitieren
davidearlagoura 0 Lösungen 3 Antworten
Veröffentlicht

Hilfreiche Antwort

EVERYONE WHO SAYS THERE IS A SOLUTION IS WRONG! Sorry "My_Cheese_Is_Slippin" your quoted solutions are from 3 years ago! THEY. DO. NOT. WORK. Neither does anything else. I don't know why Firefox seems determined to drive away its users.


https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html

Mozilla removes Support for non-e10s mode

Mozilla made changes to future Firefox version where visiting about:config and changing pref ” browser.tabs.remote.autostart” value to false simply won’t disable e10s and further more, support for force-disable and force-enable e10s prefs has been removed as well, this applies if you’re running official Firefox builds and not running automated tests for debugging.

In Firefox 68, visiting about:config and toggling browser.tabs.remote.autostart pref has no effect on e10s


Dear Firefox. Why are you determined to drive away all of your users? Here's a hint: when the message boards are full of frustrated people who say they are abandoning your product because of your poor customer service, that's when you should re think your strategy.

EVERYONE WHO SAYS THERE IS A SOLUTION IS WRONG! Sorry "My_Cheese_Is_Slippin" your quoted solutions are from 3 years ago! THEY. DO. NOT. WORK. Neither does anything else. I don't know why Firefox seems determined to drive away its users. https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html Mozilla removes Support for non-e10s mode Mozilla made changes to future Firefox version where visiting about:config and changing pref ” browser.tabs.remote.autostart” value to false simply won’t disable e10s and further more, support for force-disable and force-enable e10s prefs has been removed as well, this applies if you’re running official Firefox builds and not running automated tests for debugging. In Firefox 68, visiting about:config and toggling browser.tabs.remote.autostart pref has no effect on e10s Dear Firefox. Why are you determined to drive away all of your users? Here's a hint: when the message boards are full of frustrated people who say they are abandoning your product because of your poor customer service, that's when you should re think your strategy.
Hat Ihnen das weitergeholfen? 2
Zitieren
davidearlagoura 0 Lösungen 3 Antworten
Veröffentlicht

Dear Firefox. Why are you determined to drive away all of your users? Here's a hint: when the message boards are full of frustrated people who say they are abandoning your product because of your poor customer service, that's when you should re think your strategy.

It's worth restating....

Dear Firefox. Why are you determined to drive away all of your users? Here's a hint: when the message boards are full of frustrated people who say they are abandoning your product because of your poor customer service, that's when you should re think your strategy. It's worth restating....
Hat Ihnen das weitergeholfen? 1
Zitieren
ronen1968 0 Lösungen 9 Antworten
Veröffentlicht

cor-el said

You can also set an environment variable in the Windows Control Panel => System. You can create a firefox-e10s.cmd file with this content:
set MOZ_FORCE_DISABLE_E10S=1
start "" "<path_to_firefox>\firefox.exe"
  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

You need to dumb it down for those of us who aren't as computer savvy as others and who have windows 7. What does this mean? And why did mozilla choose to make this disabling process more difficult than ever?

''cor-el [[#answer-1237223|said]]'' <blockquote> You can also set an environment variable in the Windows Control Panel => System. You can create a firefox-e10s.cmd file with this content: <pre><nowiki>set MOZ_FORCE_DISABLE_E10S=1 start "" "<path_to_firefox>\firefox.exe"</nowiki></pre> *(64-bit Firefox) "C:\Program Files\Mozilla Firefox\" *(32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\" </blockquote> You need to dumb it down for those of us who aren't as computer savvy as others and who have windows 7. What does this mean? And why did mozilla choose to make this disabling process more difficult than ever?
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.