X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox signs me out of websites when closed, which I would like to turn off.

Veröffentlicht

A while ago, I remember changing my settings so that when I close Firefox, it automatically signs me out of websites I had open unless there's still a tab open. This is a setting I'd like to change back, but I don't know how. I've gone through the settings and haven't seen/found anything like this. It saves my passwords, but sometimes its just faster if I don't have to sign into every needed website when I turn my laptop on.

A while ago, I remember changing my settings so that when I close Firefox, it automatically signs me out of websites I had open unless there's still a tab open. This is a setting I'd like to change back, but I don't know how. I've gone through the settings and haven't seen/found anything like this. It saves my passwords, but sometimes its just faster if I don't have to sign into every needed website when I turn my laptop on.

Ausgewählte Lösung

The login status for a website is stored in a special cookie. Make sure you are not clearing that data when closing the browser.

Type about:preferences#privacy<enter> in the address bar.

The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Diese Antwort im Kontext lesen 1
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 28.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
3668 Lösungen 50312 Antworten
Veröffentlicht

Ausgewählte Lösung

The login status for a website is stored in a special cookie. Make sure you are not clearing that data when closing the browser.

Type about:preferences#privacy<enter> in the address bar.

The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

The login status for a website is stored in a special cookie. Make sure you are not clearing that data when closing the browser. Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History, ''' select '''Use Custom Settings. ''' Turn off '''Always Use Private Browsing Mode''' Turn on '''Remember My Browsing And Download History''' At the bottom of the page, turn on '''Clear History When Firefox Closes. ''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off.
Hat Ihnen das weitergeholfen? 1
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
16391 Lösungen 147877 Antworten
Veröffentlicht

You can let the cookies expire when Firefox is closed to make them session cookies instead of using "Clear history when Firefox closes" to clear the cookies.

  • Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> Cookies: Keep until: "I close Firefox"

You can create an "Allow" exception to keep specific cookies.

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing "Cookies" will remove all selected cookies including cookies with an "Allow" exception you may want to keep
You can let the cookies expire when Firefox is closed to make them session cookies instead of using "Clear history when Firefox closes" to clear the cookies. *Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> Cookies: Keep until: "I close Firefox" You can create an "Allow" exception to keep specific cookies. In case you use "Clear history when Firefox closes" or otherwise clear history. *do not clear the Cookies *do not clear the Site Preferences *Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" -> Settings *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox *clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data *clearing "Cookies" will remove all selected cookies including cookies with an "Allow" exception you may want to keep
Hat Ihnen das weitergeholfen?
Zitieren
mdhilliard 0 Lösungen 9 Antworten
Veröffentlicht

Firefox keeps signing me out of iCloud when I close my browser. How do I stop this?!?!? The selected response does not solve the problem nor does it match what is found on the page recommended for resolving the issue. There is no "off" or "On" anywhere on that page.

Firefox keeps signing me out of iCloud when I close my browser. How do I stop this?!?!? The selected response does not solve the problem nor does it match what is found on the page recommended for resolving the issue. There is no "off" or "On" anywhere on that page.
Hat Ihnen das weitergeholfen?
Zitieren
FredMcD
  • Top 10 Contributor
3668 Lösungen 50312 Antworten
Veröffentlicht

If the above did not help, check the options on the website. It may have been set up to log you out automatically. Some sites do that.

If the above did not help, check the options on the website. It may have been set up to log you out automatically. Some sites do that.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
16391 Lösungen 147877 Antworten
Veröffentlicht

In the History section I see a checkmark on the line to "Clear history when Firefox closes". You can click the Settings button and make sure that Cookies doesn't have a checkmark.

Further down there is a special Cookies section. The screenshot only shows the header (Cookies and Site Data).

In the History section I see a checkmark on the line to "Clear history when Firefox closes". You can click the Settings button and make sure that Cookies doesn't have a checkmark. Further down there is a special Cookies section. The screenshot only shows the header (Cookies and Site Data).
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.